Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 193340 - vmware-server init script causes spurious blank lines with RC_PARALLEL_STARTUP="yes"
Summary: vmware-server init script causes spurious blank lines with RC_PARALLEL_STARTU...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High trivial (vote)
Assignee: Gentoo VMWare Bug Squashers [disabled]
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-21 16:12 UTC by Malte Starostik
Modified: 2011-12-17 13:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Remove spurious empty lines (vmware-server.rc.diff,629 bytes, patch)
2007-09-21 16:14 UTC, Malte Starostik
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Malte Starostik 2007-09-21 16:12:32 UTC
With RC_PARALLEL_STARTUP="yes", vmware-server's init script causes alot of blank lines. Fix attached.

Reproducible: Always

Steps to Reproduce:
1. Set RC_PARALLEL_STARTUP="yes" in /etc/conf.d/rc
2. start or stop vmware-server
3.

Actual Results:  
some empty lines are printed

Expected Results:  
those lines shouldn't be output
Comment 1 Malte Starostik 2007-09-21 16:14:40 UTC
Created attachment 131531 [details, diff]
Remove spurious empty lines
Comment 2 Malte Starostik 2007-09-21 16:16:18 UTC
All of this refers to app-emulation/vmware-server-1.0.3.44356
Comment 3 Mike Auty gentoo-dev 2007-09-21 17:00:00 UTC
Malte, 

Thanks for the patch (although it appears to be backwards, but I think I've got the idea of your fixes)!  5:)  I'm not entirely certain why there's that extra echo hanging around there, this is startup code that's been around for ages.  The reason for the einfon rather than einfo is so that the eend can properly finish the same line that's being output, which may not affect parallel mode, but I'm fairly sure would introduce spurious new lines to non-parallel mode.

I'll take a look into the issue and see if there's a good solution for both parallel and non-parallel startups, but please be aware this is low on our list of priorities...
Comment 4 Andreas K. Hüttel gentoo-dev 2010-07-14 20:53:05 UTC
The version referenced here is long gone from the tree, so maybe this bug can be resolved?
Comment 5 Malte Starostik 2010-07-18 21:18:57 UTC
Not too sure.  Looking at http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-emulation/vmware-server/files/vmware-server.rc?revision=1.6&view=markup those einfon/echo-pairs are still in place.  I don't use the package anymore though, but I can give it a try sometime this week.
Comment 6 Vadim Kuznetsov (RETIRED) gentoo-dev 2011-12-17 13:51:42 UTC
vmware server was removed from the tree. Bug 354383.