Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 19314 - fdformat cannot format a floppy if it has physical errors.
Summary: fdformat cannot format a floppy if it has physical errors.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2003-04-14 14:22 UTC by Aniruddha Shankar
Modified: 2003-04-15 16:46 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Aniruddha Shankar 2003-04-14 14:22:56 UTC
Attempting to format a vfat floppy using kfloppy.
Settings in KFloppy >>>
Floppy Drive: Primary 
Size: 3.5" 1.44MB
File System: DOS
Full format, Verify Integrity were switched on
Volume Label was switched on and was "KDE floppy"

during the verification phase, KFloppy aborts with the following message: 
Cannot format: /dev/fd0u1440
Problem reading cylinder 79, expected 18432, read 10240

KFloppy also aborted with a similar error when I tried to format the floppy usin 
g ext2. Although I have floppy usually mounted as supermount, I dont think this 
should make a difference as I unmounted the supermounted drive manually before 
trying to run kfloppy

Reproducible: Always
Steps to Reproduce:
1.obtain a partially corrupt floppy
2.make sure the floppy is not mounted
3.try and format it using kfloppy

Actual Results:  
Kfloppy aborted with an error.

Expected Results:  
It should have marked the bad portions of the floppy as such and successfully 
formatted the floppy.

# /etc/fstab: static file system information.
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/fstab,v 1.10 2002/11/18 19:
39:22 azarah Exp $
/dev/hda1               /boot           ext2            noauto,noatime  1 1
/dev/hda9               /               ext3            noatime,data=journal     
       0 1
/dev/hda5               none            swap            sw                      
0 0
/dev/hda6               /var/tmp/portage                reiserfs                
noatime,notail                  0 0
/dev/hda7               /Documents              ext3    defaults,atime,
data=journal                     0 0
/dev/hda8               /home           ext3            noatime,data=journal     
               0 0
proc                    /proc           proc            defaults                
0 0
/floppy /floppy supermount fs=vfat,dev=/dev/fd0,--,users,sync,noatime 0 0
tmpfs                   /dev/shm        tmpfs           defaults                
0 0

Portage 2.0.47-r10 (default-x86-1.4, gcc-3.2.2, glibc-2.3.2-r1)
System uname: 2.4.20-ck4 i686 Celeron (Coppermine)
GENTOO_MIRRORS=" ftp://ftp.easynet.
nl/mirror/gentoo// ftp://ftp.belnet.
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config 
/usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config 
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 oss apm encode libg++ libwww mikmod xml2 gdbm berkdb slang readline 
arts bonobo ggi tcltk guile sdl gpm tcpd perl python esd qt motif -nls acpi 
mozsvg mozcalendar mozaccess mozinterfaceinfo mozp3p mozxmlterm moznoirc 
moznomail alsa avi crypt cups dga gif gnome gtk2 gtk gtkhtml imap imlib java 
jikes jpeg kde lcms ldap maildir mmx mozilla mpeg ncurses oav oggvorbis opengl 
pam pdflib png quicktime samba spell sse ssl svga tiff truetype wmf X xmms xv 
zlib -usb -3dnow -aalib -canna -cdr -cjk -dvd -doc -gphoto2"
CFLAGS="-O3 -march=pentium2 -pipe"
CXXFLAGS="-O3 -march=pentium2 -pipe"
FEATURES="sandbox ccache"


/dev/root / ext3 rw,noatime 0 0
none /dev devfs rw 0 0
proc /proc proc rw 0 0
/dev/hda6 /var/tmp/portage reiserfs rw,noatime,notail 0 0
/dev/hda7 /Documents ext3 rw,data=journal 0 0
/dev/hda8 /home ext3 rw,noatime,data=journal 0 0
tmpfs /dev/shm tmpfs rw 0 0
Comment 1 Aniruddha Shankar 2003-04-14 14:32:19 UTC
The problem persists when I'm using a vanillla 2.4.20 kernel ... so this is not something localised to CK4 or because i'm using supermount *phew* hopefully someone out there can confirm this bug... 

Aniruddha Shankar
Bangalore, India
Comment 2 Aniruddha Shankar 2003-04-14 14:33:35 UTC
The problem is also present when using gfloppy, Gnome's floppy formatter. I'm ccing the gnome team on this as well (apologies if this is the inappropriate thing to do)

Aniruddha Shankar
Bangalore, India
Comment 3 Dan Armak (RETIRED) gentoo-dev 2003-04-15 10:40:49 UTC
floppy is only a frontend, in this case for fdformat. The error message comes straight from 
fdformat and there's nothing we can do on the kfloppy side; this is not a kfloppy bug. This is 
the true extent of fdformat's capabilities and if I understand correctly the diskette cannot be 
used. (Can you make it usable with some means other than kfloppy?) 
The kfloppy interface and help is perhaps a little misleading if you don't know what's 
underneath and what it is capable of. But, there's nothing we can do about it. 
Comment 4 Aniruddha Shankar 2003-04-15 14:37:10 UTC
I thought as much because I get the same weird errors when using fdformat. However, there is a way to format the floppy successfully : 
1. umount the floppy
2. mformat a: 
3. dosfsck -waft /dev/fd0 
this results in a floppy that can be used with confidence as the bad sectors are marked as such by dosfsck. 

To preclude the possibility that this is an error that is unique in some manner to my hardware / software configuration, could you please see if you could duplicate this bug (despite the fact that it's not, strictly speaking, a KDE bug) ?

Assuming you can (and I have no reason to think that you will not be able to, as I have seen this bug arise in all versions of Gentoo from 1.1 to 1.4rc4) I would submit that this is a cause for concern in re KDE/Gnome as many newbies (especially in the third world where bad quality floppies are widely used) will encounter this bug.

If I were to prepare a detailed bugreport, could you please submit that upstream to the maintainer of fdformat ? I'm asking because in my experience maintainers of packages pay more attention to bugreports from as opposed to 

Thanks a lot,

Aniruddha Shankar
Bangalore, India
Comment 5 Dan Armak (RETIRED) gentoo-dev 2003-04-15 15:35:46 UTC
Well, as it happens, I use a laptop that has no builtin floppy drive, and have no floppies around. 
So I'm reopening this bugreport and giving it to the bug-wranglers again, who will assign it to 
whoever is responsible for fdformat. has already verified this - he produed the same error by scratching a floppy 
on purpose and running fdformat. (Though it may not always be as easy to reproduce, 
because 'scratching a floppy' in't a very precise operation...) 
Comment 6 Martin Holzer (RETIRED) gentoo-dev 2003-04-15 16:46:14 UTC
sorry, not a gentoo bug
if you like, submit a official bug. this is where you can report only gentoo bug