Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 19307 - libsdl-1.2.5-r2 doesnt compile under kernel 2.5.67
Summary: libsdl-1.2.5-r2 doesnt compile under kernel 2.5.67
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: x86-kernel@gentoo.org (DEPRECATED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-04-14 13:00 UTC by Bret Towe
Modified: 2007-09-19 18:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
linux-2.5.67-fb_h.patch (linux-2.5.67-fb_h.patch,888 bytes, text/plain)
2003-04-14 19:32 UTC, Bret Towe
Details
quake2-error (quake2-error,4.85 KB, text/plain)
2007-09-19 18:29 UTC, timofonic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bret Towe 2003-04-14 13:00:06 UTC
summary says it all
the error is as follows

In file included from XF86DGA2.c:28:
/usr/include/linux/fb.h:342: parse error before "dst"
/usr/include/linux/fb.h:345: parse error before "lock"
/usr/include/linux/fb.h:346: parse error before "count"
make[3]: *** [XF86DGA2.lo] Error 1
make[3]: Leaving directory
`/var/tmp/portage/libsdl-1.2.5-r2/work/SDL-1.2.5/src/video/XFree86/Xxf86dga'

i did provide the full compile line cause i dont think its needed
i can provide a full log if needed tho
the problem is that file is including framebuffer stuff even when its disabled
and the header looks like it might have a problem also i got it to shutup for
all but the count error i dont understand how the spinlock_t stuff should be defined

yes /usr/include/linux links to 2.5.67

Reproducible: Always
Steps to Reproduce:
Comment 1 Bret Towe 2003-04-14 19:32:02 UTC
Created attachment 10656 [details]
linux-2.5.67-fb_h.patch

ok i found the problem the kernel header was at fault
attached is the patch to fix the problem
can someone send this upstream?
(or should i go ahead and create an account with kernel bugzilla?)
Comment 2 Bret Towe 2003-04-16 17:15:20 UTC
never mind i submited a bug on it
( http://bugzilla.kernel.org/show_bug.cgi?id=593 )
Comment 3 Jay Pfeifer (RETIRED) gentoo-dev 2003-04-27 01:11:08 UTC
user took bug to kernel.org 
 
Jay 
Comment 4 timofonic 2007-09-19 18:29:22 UTC
Created attachment 131323 [details]
quake2-error