Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 192314 - Synaptics Touchpad in a Lenovo 3000 C200 unstable on heavy CPU load
Summary: Synaptics Touchpad in a Lenovo 3000 C200 unstable on heavy CPU load
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2007-09-12 16:17 UTC by André
Modified: 2011-06-28 09:51 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Xorg.conf (xorg.conf,5.78 KB, text/plain)
2007-09-12 16:20 UTC, André
Actual kernel configuration (config-2.6.21_rc7,50.39 KB, text/plain)
2007-09-12 16:21 UTC, André
dmesg (cat /dev/hdc > hdc) (dmesg,26.38 KB, text/plain)
2007-09-17 21:57 UTC, André
dmesg (cat /dev/hdc > hdc with i8042.nomux=1) (dmesg-i8042.nomux,24.68 KB, text/plain)
2007-09-18 19:03 UTC, André

Note You need to log in before you can comment on or make changes to this bug.
Description André 2007-09-12 16:17:19 UTC
I'm currently using 2.6.21-rc7 kernel (gentoo patchset).
The laptop is a Lenovo 3000 C200, the problem occurs when performorming intensive CPU tasks, such as compiling or burning.
Here is the interesting part of my dmesg output:
psmouse.c: TouchPad at isa0060/serio4/input0 lost sync at byte 1
psmouse.c: TouchPad at isa0060/serio4/input0 lost sync at byte 1
psmouse.c: issuing reconnect request
psmouse.c: TouchPad at isa0060/serio4/input0 lost sync at byte 4
psmouse.c: TouchPad at isa0060/serio4/input0 - driver resynched.
psmouse.c: TouchPad at isa0060/serio4/input0 lost sync at byte 4
I have try also with the last stable gentoo-sources (2.6.22-r5) but the problem is worst, I lost sync every time, just by loading any application.

I have try with ACPI off too, it's better but still not working properly.
I have try with:
- 'clocksource=tsc' kernel option
- 'clocksource=pit' kernel option
- and 'acpi=off" kernel option
with no success.

dmesg | grep Synaptics
Synaptics Touchpad, model: 1, fw: 6.3, id: 0x1a0b1, caps: 0xa04713/0x200000
input: SynPS/2 Synaptics TouchPad as /class/input/input4

Thank you.

Reproducible: Always

Steps to Reproduce:
1.put a DVD
2.cp /dev/hda /tmp/dvd
3.use the touchpad

emerge --info
Portage (default-linux/x86/2006.1, gcc-4.1.2, glibc-2.5-r4, 2.6.21-rc7 i686)
System uname: 2.6.21-rc7 i686 Intel(R) Core(TM)2 CPU T5500 @ 1.66GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Tue, 11 Sep 2007 23:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
CFLAGS="-march=pentium-m -msse3 -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/svn/env /usr/kde/svn/share/config /usr/kde/svn/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-march=pentium-m -msse3 -O2 -pipe -fomit-frame-pointer"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict"
LINGUAS="fr fr_FR"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTDIR_OVERLAY="/usr/local/layman/xeffects /usr/local/layman/kde"
USE="X a52 aac acpi alsa apache2 bash-completion berkdb bidi bitmap-fonts cli cracklib crypt cups dri dts dvd ffmpeg flac font-server fortran freetype gdbm gif glitz gnutls gpm gstreamer gtk hal iconv ipv6 isdnlog jack jpeg kde matroska midi mp3 mpeg mudflap mysql ncurses nls nptl nptlonly ogg oggvorbis opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt4 readline real reflection samba session spl ssl stream svg svga tcpd theora truetype truetype-fonts type1-fonts unicode wifi win32codecs wma wxwindows x86 xft xine xinerama xml xml2 xorg zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" USERLAND="GNU" VIDEO_CARDS="i810 i915 intel vesa"
Comment 1 André 2007-09-12 16:20:58 UTC
Created attachment 130742 [details]
Comment 2 André 2007-09-12 16:21:39 UTC
Created attachment 130743 [details]
Actual kernel configuration
Comment 3 Mike Pagano gentoo-dev 2007-09-17 21:30:56 UTC
please attach the output of dmesg.
Comment 4 André 2007-09-17 21:57:13 UTC
Created attachment 131174 [details]
dmesg (cat /dev/hdc > hdc)
Comment 5 Mike Pagano gentoo-dev 2007-09-17 22:33:10 UTC
Can you try booting into your kernel with the following boot parameter added:


Comment 6 André 2007-09-18 19:03:02 UTC
Created attachment 131233 [details]
dmesg (cat /dev/hdc > hdc with i8042.nomux=1)

It's seem to be better with "nomux=1" but I still lost sync (see the new dmesg).
Comment 7 Mike Pagano gentoo-dev 2007-09-20 13:33:49 UTC
There is a bug filed upstream by a user with the same symptoms and the same laptop:

Comment 8 Mike Pagano gentoo-dev 2007-09-20 13:42:24 UTC
Sorry for the bugspam, but can you test the latest vanilla kernel which is 2.6.23_rc7 as of this writing.
Comment 9 André 2007-09-20 18:21:02 UTC
I just try with vanilla kernel (2.6.23_rc7) and the problem is worst. For example I lost sync at kdm start (do you want a dmesg from this kernel too?).
Thank you for the link I will follow this discussion to, you true, it's seem to be the same problem.
I don't think this is an issue of broken hardware because I have seen this problem the first time I try to burn a CD with Gentoo, it was few days after buying this laptop.
Comment 10 Maarten Bressers (RETIRED) gentoo-dev 2007-09-21 01:07:10 UTC
Please post the output of:
cat /proc/bus/input/devices

Here are two more kernel boot options you might try:
If either of these produces better results, please post the dmesg output for that one.
Comment 11 André 2007-09-23 19:33:40 UTC
here my /proc/bus/input/devices

cat /proc/bus/input/devices
I: Bus=0019 Vendor=0000 Product=0002 Version=0000
N: Name="Power Button (FF)"
P: Phys=button_power/button/input0
S: Sysfs=/class/input/input0
H: Handlers=kbd event0
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/class/input/input1
H: Handlers=event1
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button (CM)"
P: Phys=PNP0C0C/button/input0
S: Sysfs=/class/input/input2
H: Handlers=kbd event2
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0011 Vendor=0002 Product=0007 Version=0000
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio4/input0
S: Sysfs=/class/input/input3
H: Handlers=mouse0 event3
B: EV=b
B: KEY=6420 0 70000 0 0 0 0 0 0 0 0
B: ABS=11000003

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/class/input/input4
H: Handlers=kbd event4
B: EV=120013
B: KEY=4 2000000 3802078 f940d001 feffffdf ffefffff ffffffff ffffffff
B: MSC=10
B: LED=7


I tried also (kernel 2.6.21-rc7)
without success.
Still lost sync but seem to be different not better, just different.

Comment 12 Daniel Drake (RETIRED) gentoo-dev 2007-09-29 15:55:08 UTC
will track upstream bug
Comment 13 Alexey Parshin 2007-10-12 10:40:32 UTC
I have the same problem here, with Lenovo 3000N100, kernel 2.6.22
Comment 14 Daniele C. 2007-10-12 11:51:55 UTC
I do have thes same problem (perfectly worked around with i8042.nomux=1) and I am following the addressing upstream
Comment 15 Alexey Parshin 2007-10-12 14:31:52 UTC
i8042.nomux=1 works for me like a charm. Thanks a lot, guys!