Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 190351 - circular dependencies xorg
Summary: circular dependencies xorg
Status: RESOLVED DUPLICATE of bug 175808
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-27 01:28 UTC by Jo
Modified: 2007-08-27 03:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jo 2007-08-27 01:28:24 UTC
Circular dependencies when merging xorg-x11

Reproducible: Always

Steps to Reproduce:

Actual Results:  
libach@libach ~ $ emerge -pv xorg-x11

...

!!! Error: circular dependencies:

('ebuild', '/', 'media-libs/fontconfig-2.4.2', 'merge') depends on
   ('ebuild', '/', 'app-text/docbook-sgml-utils-0.6.14', 'merge') (hard)
('ebuild', '/', 'app-text/jadetex-3.13-r1', 'merge') depends on
   ('ebuild', '/', 'app-text/tetex-3.0_p1-r3', 'merge') (hard)
('ebuild', '/', 'media-fonts/font-adobe-75dpi-1.0.0', 'merge') depends on
   ('ebuild', '/', 'media-libs/fontconfig-2.4.2', 'merge') (hard)
('ebuild', '/', 'media-fonts/font-misc-misc-1.0.0', 'merge') depends on
   ('ebuild', '/', 'media-libs/fontconfig-2.4.2', 'merge') (hard)
('ebuild', '/', 'media-fonts/font-cursor-misc-1.0.0', 'merge') depends on
   ('ebuild', '/', 'media-libs/fontconfig-2.4.2', 'merge') (hard)
('ebuild', '/', 'x11-drivers/xf86-input-mouse-1.2.1', 'merge') depends on
   ('ebuild', '/', 'x11-base/xorg-server-1.2.0-r3', 'merge') (hard)
('ebuild', '/', 'x11-base/xorg-server-1.2.0-r3', 'merge') depends on
   ('ebuild', '/', 'media-fonts/font-misc-misc-1.0.0', 'merge') (hard)
   ('ebuild', '/', 'x11-drivers/xf86-input-mouse-1.2.1', 'merge') (medium-soft)
   ('ebuild', '/', 'media-fonts/font-cursor-misc-1.0.0', 'merge') (hard)
   ('ebuild', '/', 'x11-drivers/xf86-input-keyboard-1.1.1', 'merge') (medium-soft)
   ('ebuild', '/', 'x11-drivers/nvidia-drivers-1.0.7185', 'merge') (medium-soft)
   ('ebuild', '/', 'media-fonts/font-adobe-75dpi-1.0.0', 'merge') (hard)
('ebuild', '/', 'app-text/docbook-sgml-utils-0.6.14', 'merge') depends on
   ('ebuild', '/', 'app-text/jadetex-3.13-r1', 'merge') (hard)
('ebuild', '/', 'app-text/tetex-3.0_p1-r3', 'merge') depends on
   ('ebuild', '/', 'x11-base/xorg-server-1.2.0-r3', 'merge') (hard)
('ebuild', '/', 'x11-drivers/xf86-input-keyboard-1.1.1', 'merge') depends on
   ('ebuild', '/', 'x11-base/xorg-server-1.2.0-r3', 'merge') (hard)
('ebuild', '/', 'x11-drivers/nvidia-drivers-1.0.7185', 'merge') depends on
   ('ebuild', '/', 'x11-base/xorg-server-1.2.0-r3', 'merge') (hard)

!!! Note that circular dependencies can often be avoided by temporarily
!!! disabling USE flags that trigger optional dependencies.




For a while I've added to my package.use 'app-text/docbook-sgml-utils -tetex'. With this it's OK.




Portage 2.1.2.11 (default-linux/x86/2007.0, gcc-4.1.1, glibc-2.5-r0, 2.6.22-gentoo-r2-august-2007-pentium-II i686)
=================================================================
System uname: 2.6.22-gentoo-r2-august-2007-pentium-II i686 Pentium II (Klamath)
Gentoo Base System release 1.12.9
Timestamp of tree: Sat, 18 Aug 2007 05:50:01 +0000
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
USE="X a52 aac aalib accessibility acl acpi adabas adns afs aim alsa ao apache apache2 apm audiofile avahi bash-completion bcmath berkdb bidi bindist birdstep bitmap-fonts blas bluetooth bzip2 cairo caps cdb cdparanoia cdr cli cracklib crypt cscope ctype cups curl curlwrappers db2 dbase dbm dbmaker dbus dbx directfb doc dts dv dvb dvd dvdr dvdread emacs empress empress-bcs encode esd esoob evo examples exif expat fam fastcgi fbcon ffmpeg fftw filepro firebird firefox flac fltk foomaticdb fortran freetds frontbase ftp gcj gd gdbm geoip ggi gif ginac glut gmp gnustep gnutls gphoto2 gpm gps graphviz gstreamer guile hal howl icc iconv icq idn ieee1394 ifc imagemagick imap imlib informix inifile innodb interbase iodbc ipv6 isdnlog jabber jack java javascript jbig jikes jpeg jpeg2000 junit kerberos krb4 ladcca ladspa lapack lash lcms ldap leim libcaca libedit libg++ libgda libnotify libsamplerate libwww lirc lm_sensors lua m17n-lib mad maildir mailwrapper matroska matrox mbox memlimit mhash midi mikmod milter mime mmap mmx mng mnogosearch mono mozilla mp3 mpeg mpi mplayer msn msql mssql mudflap mule musepack mysql nas ncurses neXt netboot netcdf nis nls nntp nptl nptlonly nsplugin ocaml oci8 odbc ogg openal openexr openmp oracle oracle7 osc oscar oss ovrimos pam pcntl pcre pdf perl php plotutils png portaudio posix pppd prelude profile pulseaudio python qt3 qt4 quicktime radius rdesktop readline recode reflection ruby samba sapdb sasl savedconfig scanner sdl seamonkey session sharedmem shorten simplexml skey slang slp sndfile snmp soap sockets socks5 solid sox speex spell spl ssl startup-notification svg svga sybase sybase-ct symlink sysvipc szip tcl tcpd tetex theora threads tidy tiff tk tokenizer truetype truetype-fonts type1-fonts unicode usb v4l vcd verbose vhosts vorbis wddx win32codecs wmf wxwindows x264 x86 xcomposite xface xine xinerama xinetd xml xmlrpc xorg xosd xpm xsl xvid yahoo yaz zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-08-27 03:31:46 UTC

*** This bug has been marked as a duplicate of bug 175808 ***