Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 190268 - sys-apps/portage- and FEATURES=test failure
Summary: sys-apps/portage- and FEATURES=test failure
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
Keywords: InVCS
Depends on:
Blocks: 181949
  Show dependency tree
Reported: 2007-08-26 08:35 UTC by Ravi Pinjala
Modified: 2007-09-08 09:31 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

filter SANDBOX_* from the calling environment (sandbox.patch,511 bytes, patch)
2007-09-07 03:17 UTC, Zac Medico
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ravi Pinjala 2007-08-26 08:35:32 UTC
(blah blah blah)
testIsValidAtom (tests.portage_dep.test_isvalidatom.IsValidAtom) ... ok
testDepGetCPV (tests.portage_dep.test_dep_getcpv.DepGetCPV) ... ok
testGetOperator (tests.portage_dep.test_get_operator.GetOperator) ... ok

FAIL: testLogfile (tests.portage.test_spawn.SpawnTestCase)
Traceback (most recent call last):
  File "/var/tmp/portage/sys-apps/portage-", line 28, in testLogfile
AssertionError: ['blah blah blah', 'blah blah blah'] != ['\x1b[31;01mACCESS DENIED\x1b[0m  open_rd:   /etc/spork/is/not/valid/profile.env', '/bin/bash: /etc/spork/is/not/valid/profile.env: Permission denied', 'blah blah blah', 'blah blah blah', '\x1b[31;01m--------------------------- ACCESS VIOLATION SUMMARY ---------------------------\x1b[0m', '\x1b[31;01mLOG FILE = "/var/log/sandbox/sandbox-sys-apps_-_portage-"\x1b[0m', '', 'open_rd:   /etc/spork/is/not/valid/profile.env', '\x1b[31;01m--------------------------------------------------------------------------------\x1b[0m', '\x07\x07\x07']

Ran 23 tests in 4.613s

FAILED (failures=1)
 * ERROR: sys-apps/portage- failed.
 * Call stack:
 *, line 1648:   Called dyn_test
 *, line 1049:   Called qa_call 'src_test'
 *, line 44:   Called src_test
 *   portage-, line 113:   Called die
 * test(s) failed
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-apps/portage-'.


3vil ravi # emerge --info
Portage (default-linux/amd64/2007.0/desktop, gcc-4.1.2, glibc-2.6-r0, x86_64)
System uname: x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System release 1.12.10
Timestamp of tree: Sun, 26 Aug 2007 07:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r4
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -march=athlon64 -funit-at-a-time"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/init.d /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=athlon64 -funit-at-a-time"
FEATURES="ccache collision-protect distlocks metadata-transfer nostrip parallel-fetch sandbox sfperms strict test unmerge-orphans userfetch userpriv"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTDIR_OVERLAY="/usr/local/overlays/portage /usr/local/overlays/xeffects/trunk /usr/local/overlays/zfs-fuse"
USE="3dnow 3dnowext X Xaw3d a52 aac aalib acl acpi alsa amd64 arts bash-completion berkdb bitmap-fonts bzip2 cairo cdr cjk cli cracklib crypt cups daap dbus dri dv dvd dvdr dvdread eds emboss emul-linux-x86 encode esd evo fam ffmpeg firefox flac fortran ftp gcj gdbm gecko-sdk gif glitz glut gpm gtk gtk2 hal iconv ipod ipv6 isdnlog java jpeg jpeg2k kdehiddenvisibility kerberos libcaca mad matroska midi mikmod mmx mmxext mono mozsvg mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly nvidia ogg opengl openmp oss pam pcre pdf perl png pppd python qt qt3 qt3support qt4 quicktime readline reflection samba sdl session spell spl sse sse2 ssl svg tcpd test tiff truetype truetype-fonts type1-fonts unicode userlocales vorbis x264 xinerama xml xml2 xorg xrandr xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"
Comment 1 Zac Medico gentoo-dev 2007-08-26 19:08:02 UTC
I'm unable to reproduce that sandbox violation here. Do you have anything in /etc/portage/bashrc that interacts with sandbox?
Comment 2 Ravi Pinjala 2007-08-27 15:51:39 UTC
Nope, nothing.
Comment 3 Zac Medico gentoo-dev 2007-08-27 16:28:46 UTC
The sandbox is definitely malfunctioning for some reason. First I'd try rebuilding sandbox. If that doesn't help, please edit /usr/lib/portage/bin/ and add 'set -x' at the very top, just below the header. Run `emerge portage &> debug.log` and attach the log.
Comment 4 Ravi Pinjala 2007-08-27 16:35:27 UTC
Ah, perhaps this is the root of the problem: sandbox didn't build, because my gcc-config seems to be broken. I'll fix that, and then see if that fixes things.
Comment 5 Ravi Pinjala 2007-09-06 22:05:11 UTC
Mmmkay, sandbox rebuilt (the problem was bug #133209), but portage still refuses to build. Same error and everything. 

The log you requested is at .
Comment 6 Zac Medico gentoo-dev 2007-09-07 03:17:26 UTC
Created attachment 130232 [details, diff]
filter SANDBOX_* from the calling environment

Initially I was unable to reproduce the problem because I had FEATURES=usersandbox enabled. With FEATURES="userpriv sandbox -usersandbox" I reproduced it.

The patch has to be applied inside src_compile() in order to prevent the src_test() phase from failing.
Comment 7 Ravi Pinjala 2007-09-07 04:08:20 UTC
Adding FEATURES=usersandbox fixed it for me. Thanks for your help! :)
Comment 8 Zac Medico gentoo-dev 2007-09-07 19:19:31 UTC
This has been released in
Comment 9 Ryan Hill (RETIRED) gentoo-dev 2007-09-08 04:46:42 UTC
I'm still hitting this with but with usersandbox enabled.  Disabling it works.

Portage (default-linux/x86/2007.0, gcc-4.2.2-pre20070903, glibc-2.6.1-r0, i686)
System uname: i686 Genuine Intel(R) CPU T2300 @ 1.66GHz
Timestamp of tree: Unknown
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0_rc4
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18
sys-devel/gcc-config: 1.4.0-r2
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
CFLAGS="-O2 -g -march=prescott -fomit-frame-pointer -fno-ident -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -g -march=prescott -fomit-frame-pointer -fno-ident -pipe"
FEATURES="assume-digests ccache collision-protect cvs digest distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms splitdebug strict test unmerge-orphans userfetch userpriv usersandbox"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu"
LINGUAS="en en_GB en_US"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="X a52 aac acpi alsa audiofile avahi bash-completion berkdb bzip2 cairo calendar caps cddb cdr cpudetection crypt cscope curl dbus dri dts dvd dvdr dvdread encode exif expat fam ffmpeg fftw flac gdbm gif gmp gnutls graphviz gstreamer gtk hal imagemagick imap imlib java jikes jpeg kde kdeenablefinal kdehiddenvisibility libnotify libsamplerate logrotate mad maildir mailwrapper mbox mmap mmx mng mp3 mpeg mplayer ncurses nntp nptl nsplugin odbc ogg opengl oss pam pcmcia pcre pdf perl pic png python qt3 qt4 quicktime readline ruby sasl sdl session sndfile spell sqlite sqlite3 sse sse2 ssl startup-notification svg tcl tcpd test theora threads truetype unicode urandom usb vcd vim-syntax vorbis win32codecs wxwindows x264 x86 xine xml xpm xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="*" ELIBC="glibc" INPUT_DEVICES="joystick mouse keyboard synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB en_US" USERLAND="GNU" VIDEO_CARDS="fglrx radeon"
Comment 10 Zac Medico gentoo-dev 2007-09-08 09:31:18 UTC
Thanks, this is fixed in