Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 190049 - blender ebuilds do not check MAKEOPTS carefully enough
Summary: blender ebuilds do not check MAKEOPTS carefully enough
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 202547 271479 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-08-24 14:41 UTC by Martin Wegner
Modified: 2009-05-28 01:44 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Wegner 2007-08-24 14:41:01 UTC
The ebuilds for blender that are currently in the portage tree do not check possible values of MAKEOPTS carefully enough: All ebuilds < version 2.43 do not do any checks at all, all versions >= 2.43 do remove -l[0-9], but there are according to site [1] more possibilities for that value, for example:

-l 2, -l 2.5

These are not matched by the removal and thus cause errors.

[1] http://www.gnu.org/software/make/manual/html_node/Parallel.html

The error is this one then:

>>> Unpacking ffmpeg-0.4.9-p20070330.tar.bz2 to /var/tmp/portage/media-gfx/blender-2.44/work/blender-2.44/extern
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/media-gfx/blender-2.44/work/blender-2.44 ...
usage: scons [OPTION] [TARGET] ...

SCons error: option -l: invalid integer value: '2.5'
usage: scons [OPTION] [TARGET] ...

SCons error: option -l: invalid integer value: '2.5'
 * 
 * ERROR: media-gfx/blender-2.44 failed.
 * Call stack:
 *   ebuild.sh, line 1654:   Called dyn_compile
 *   ebuild.sh, line 990:   Called qa_call 'src_compile'
 *   ebuild.sh, line 44:   Called src_compile
 *   blender-2.44.ebuild, line 96:   Called die
 * 
 * !!! Please add /var/tmp/portage/media-gfx/blender-2.44/work/blender-2.44/scons.config when filing bugs reports to bugs.gentoo.org
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/media-gfx:blender-2.44:20070824-143737.log'.
 * 


I have not any clue (yet) how other scons-based packages may be affected by this, too.

Reproducible: Always

Steps to Reproduce:
1. Set MAKEOPTS="-l 2.5" in /etc/make.conf
2. emerge blender

Actual Results:  
Compiling fails.

Expected Results:  
Should not fail but remove all possible occurences.

$ emerge --info
Portage 2.1.3.6 (default-linux/amd64/2006.1, gcc-4.1.2, glibc-2.6.1-r0, 2.6.22-gentoo-r1-mw x86_64)
=================================================================
System uname: 2.6.22-gentoo-r1-mw x86_64 Intel(R) Core(TM)2 CPU 6400 @ 2.13GHz
Gentoo Base System release 1.12.10
Timestamp of tree: Fri, 24 Aug 2007 04:50:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17.50.0.18
sys-devel/gcc-config: 1.4.0
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/ ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo"
LANG="C"
MAKEOPTS="-l 2.5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://ares/gentoo-portage"
USE="X Xaw3d a52 aac aalib acpi alsa amd64 aoss bash-completion berkdb bitmap-fonts blender-game branding bzip2 cdparanoia cdr cli cracklib crypt css cups curl d dbus dedicated dga dia directfb divx dri dvb dvd dvdnav dvdr dvi editor emerald encode escreen expat fam fbcon ffmpeg firefox flac ftp gd gdbm gif gimpprint glut gnome gnutls gtk gtkhtml hal hddtemp iconv icq idn imagemagick imap ipv6 jabber john jpeg jpeg2k lame libcaca libnotify logrotate mad mbox midi mng mozdevelop mozilla mp3 mudflap mysql nautilus ncurses nfs nls no-htdocs nptl nptlonly nsplugin nvidia offensive ogg openal opengl openmp openssl oscar pam pcre pdf perl php png pop postfix postgres ppds python quicktime readline realmedia rtc ruby samba sdl server session skins spl sqlite ssl startup-notification svg tcpd tetex theora thunderbird tiff tools truetype truetype-fonts type1-fonts unicode usb userlocales vim vim-with-x visualization vorbis wmf wmp wxwindows x264 xanim xchattext xine xinerama xml xorg xpm xprint xsl xv xvid zlib" ALSA_CARDS="cmipci hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Martin Wegner 2007-08-24 14:45:07 UTC
It just occured to me that also long options for -l (--load-average, --max-load) should be matched.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-08-24 14:51:49 UTC
Yeah, scons sucks.
Comment 3 Martin Wegner 2007-08-24 14:58:56 UTC
Uhm, I do not agree with WONTFIX. According to /etc/make.conf.example MAKEOPTS are options that are destined to be passed to make. Thus, all possible make options are valid so far. If ebuilds decide to pass MAKEOPTS to scons, they should check the options for invalid ones. Or, at least, the use of any other options than -j in MAKEOPTS should be discouraged in the comments in /etc/make.conf.example.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-08-24 15:07:48 UTC
Yeah, according to quick bugzilla search there are exactly two other users using -l in MAKEOPTS, and none of them using non-integer values for them. Noones that would use --load-average, two people that use --max-load. 

Sorry it fails for you, but no point in introducing crazy hacks in ebuilds to accommodate for scons suckage.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-12-17 06:56:55 UTC
*** Bug 202547 has been marked as a duplicate of this bug. ***
Comment 6 Benjamin Bannier 2007-12-19 21:58:38 UTC
(In reply to comment #5)
> *** Bug 202547 has been marked as a duplicate of this bug. ***
> 

The fix you proposed over at Bug 202547 worked for me, successful built blender. That should definitely go in the blender ebuild, claiming success but failing as with MAKEOPTS="--load-average=3" is not what anybody want.

So this one is still open for me.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-12-19 22:15:21 UTC
(In reply to comment #6)
> The fix you proposed over at Bug 202547 worked for me, successful built
> blender. That should definitely go in the blender ebuild, claiming success but
> failing as with MAKEOPTS="--load-average=3" is not what anybody want.

Meh, that's not a fix, that's a workaround for scons suckage. :) Ebuilds don't touch /etc/portage/env at all, plus as noted here, getting all possible combos of MAKEOPTS stuff that scons chokes on in the ebuild filtered out like this is kinda troublesome.
Comment 8 Samuli Suominen gentoo-dev 2008-01-21 19:36:13 UTC
Summary: Get scons fixed.
Comment 9 Mark Purtill 2009-05-28 01:44:15 UTC
*** Bug 271479 has been marked as a duplicate of this bug. ***