Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 189806 - dev-dotnet/pnet-0.8.0: bundles and install boehm-gc
Summary: dev-dotnet/pnet-0.8.0: bundles and install boehm-gc
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords: PMASKED
Depends on:
Blocks: bundled-libs
  Show dependency tree
 
Reported: 2007-08-22 09:25 UTC by José Romildo Malaquias
Modified: 2010-07-03 11:27 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description José Romildo Malaquias 2007-08-22 09:25:37 UTC
Emerging pnet-0.8.0 tries to overwrite library files belonging to boehm-gc.

Reproducible: Always

Steps to Reproduce:
# emerge -v pnet
Actual Results:  
[...]
* checking 177 files for package collisions
existing file /usr/lib64/libgc.a is not owned by this package
existing file /usr/lib64/libgc.la is not owned by this package
existing file /usr/include/gc/gc.h is not owned by this package
existing file /usr/include/gc/gc_mark.h is not owned by this package
existing file /usr/include/gc/gc_amiga_redirects.h is not owned by this package
existing file /usr/include/gc/gc_backptr.h is not owned by this package
existing file /usr/include/gc/gc_inline.h is not owned by this package
existing file /usr/include/gc/leak_detector.h is not owned by this package
existing file /usr/include/gc/new_gc_alloc.h is not owned by this package
existing file /usr/include/gc/gc_pthread_redirects.h is not owned by this package
existing file /usr/include/gc/gc_typed.h is not owned by this package
existing file /usr/include/gc/gc_config_macros.h is not owned by this package
existing file /usr/include/gc/gc_cpp.h is not owned by this package
existing file /usr/include/gc/gc_gcj.h is not owned by this package
existing file /usr/include/gc/weakpointer.h is not owned by this package
existing file /usr/include/gc/gc_allocator.h is not owned by this package
existing file /usr/lib64/libgc.so.1 is not owned by this package
existing file /usr/lib64/libgc.so is not owned by this package
* This package is blocked because it wants to overwrite
* files belonging to other packages (see messages above).
* If you have no clue what this is all about report it 
* as a bug for this package on http://bugs.gentoo.org

package dev-dotnet/pnet-0.8.0 NOT merged


Searching all installed packages for file collisions...
Press Ctrl-C to Stop

 * dev-libs/boehm-gc-7.0-r1:

     '/usr/lib64/libgc.a'
     '/usr/lib64/libgc.la'
     '/usr/include/gc/gc.h'
     '/usr/include/gc/gc_mark.h'
     '/usr/include/gc/gc_amiga_redirects.h'
     '/usr/include/gc/gc_backptr.h'
     '/usr/include/gc/gc_inline.h'
     '/usr/include/gc/leak_detector.h'
     '/usr/include/gc/new_gc_alloc.h'
     '/usr/include/gc/gc_pthread_redirects.h'
     '/usr/include/gc/gc_typed.h'
     '/usr/include/gc/gc_config_macros.h'
     '/usr/include/gc/gc_cpp.h'
     '/usr/include/gc/gc_gcj.h'
     '/usr/include/gc/weakpointer.h'
     '/usr/include/gc/gc_allocator.h'
     '/usr/lib64/libgc.so.1'
     '/usr/lib64/libgc.so'


Expected Results:  
No file collision.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-08-22 11:02:48 UTC
No need for multiple bugs about identical issue.

*** This bug has been marked as a duplicate of bug 187379 ***
Comment 2 Jurek Bartuszek (RETIRED) gentoo-dev 2007-08-22 14:46:01 UTC
Unfortunately, this isn't an identical issue. Whereas bug #187379 was related to versions 0.6.x and 0.7.x and was caused by documentation misplacement, here we have to deal with pnet-0.8.0 and libraries/includes collisions. Reopening for further investigation.
Comment 3 Jurek Bartuszek (RETIRED) gentoo-dev 2007-11-16 23:15:55 UTC
Fixed in CVS
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-12-27 17:21:03 UTC
Uh? Fixed with a blocker? This should _not_ install its own boehm-gc, it should use the system one if anything!
Comment 5 Pacho Ramos gentoo-dev 2010-07-03 11:27:18 UTC
pnet was dropped some time ago