Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 188929 - emerge --noreplace does not add package to world file
Summary: emerge --noreplace does not add package to world file
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Portage team
: 190341 191184 (view as bug list)
Depends on:
Blocks: 181949
  Show dependency tree
Reported: 2007-08-14 23:37 UTC by Jeremy Rann
Modified: 2007-09-03 23:07 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

fix 2.1.2.x so --noreplace properly adds atoms to the world file (noreplace.patch,717 bytes, patch)
2007-08-27 02:04 UTC, Zac Medico
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Rann 2007-08-14 23:37:37 UTC
I posted to the forums here: concerning the issue. From the post:

"I just finished an update, and I ran emerge --depclean --pretend, and it told me it was going to unmerge fluxbox. That's my WM of choice, so I know I want it. I did less /var/lib/portage/world, and fluxbox is indeed not there. So, I ran emerge --noreplace fluxbox, but to my surprise it still didn't add fluxbox to the world file."

I searched for other bugs and found Bug # 91002 ( from 2005, and it said it was resolved. I'm still getting the same behavior - it doesn't add the package to the world file. If the functionality of --noreplace has changed, then I think the warning on the --depclean option needs to also be updated to recommend manually adding the package to the world file instead. It's on the forum, but here's my emerge --info anyway:

# emerge --info
Portage (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.5-r4, 2.6.20-gentoo-r8 i686)
System uname: 2.6.20-gentoo-r8 i686 Mobile Intel(R) Pentium(R) 4 CPU 2.80GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Tue, 07 Aug 2007 14:50:02 +0000
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.21
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="X Xaw3d aac acl acpi alsa apache2 bash-completion berkdb bitmap-fonts bzip2 chroot cli cracklib crypt dbus dga doc dri examples fam fftw flac fortran gdbm gif glibc-omitfp gpm hal hpn iconv imlib ipv6 isdnlog jpeg jpeg2k justify ldap libg++ libnotify mad md5sum midi mmx mng motif mp3 mudflap mysql ncurses nls nptl nptlonly ogg opengl openmp pam paste64 pcre perl php png pppd python readline reflection samba session slang slp smp spell spl sse sse2 ssl svg swat syslog tcpd tiff toolbar truetype truetype-fonts type1-fonts unicode vorbis wma wmf x86 xcb xml xorg xprint zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="radeon vesa fglrx"

Reproducible: Always
Comment 1 Zac Medico gentoo-dev 2007-08-14 23:43:36 UTC
It's supposed to work. Can you try it with portage- There have been lots of changes in that code since 2.1.2.x and hopefully the bug has already been fixed.
Comment 2 Jeremy Rann 2007-08-16 07:28:19 UTC
I upgraded to Portage, and it worked just fine. Then, just to be sure, I downgraded Portage back to the "stable" version (not ~x86), removed fluxbox from the world file manually, and tried it again - I was able to repeat the same behavior. So, indeed, this appears to be fixed by Thanks!
Comment 3 Zac Medico gentoo-dev 2007-08-16 07:55:27 UTC
Great, thanks for testing that.
Comment 4 Zac Medico gentoo-dev 2007-08-26 23:39:28 UTC
*** Bug 190341 has been marked as a duplicate of this bug. ***
Comment 5 Renato Alves 2007-08-27 00:09:12 UTC
Since the solution is to upgrade to an "unstable" version of portage, is it wise to consider the stabilization of the "fixed" version (

Comment 6 Zac Medico gentoo-dev 2007-08-27 02:04:16 UTC
Created attachment 129273 [details, diff]
fix 2.1.2.x so --noreplace properly adds atoms to the world file

I think is good for stabilization but I'm planning to wait about 2 more weeks before I request it. If some emergency comes up before then that requires a release then this patch will be included.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-09-03 23:07:55 UTC
*** Bug 191184 has been marked as a duplicate of this bug. ***