Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 188705 - possible missing dependency in gnome-icon-theme-2.18.0 ebuild
Summary: possible missing dependency in gnome-icon-theme-2.18.0 ebuild
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-13 13:13 UTC by Steven E. Lamberson, Jr.
Modified: 2007-08-13 14:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven E. Lamberson, Jr. 2007-08-13 13:13:34 UTC
"emerge gnome-icon-theme" on my system fails during configure when "checking for XML::Parser ...".  

Reproducible: Always

Steps to Reproduce:
1. emerge gnome-icon-theme

Actual Results:  
>>> Unpacking source...
>>> Unpacking gnome-icon-theme-2.18.0.tar.bz2 to /var/tmp/portage/x11-themes/gnome-icon-theme-2.18.0/work
 * Fixing OMF Makefiles ...                                               [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/x11-themes/gnome-icon-theme-2.18.0/work/gnome-icon-theme-2.18.0 ...
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --build=i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking for style of include used by make... GNU
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether i686-pc-linux-gnu-gcc accepts -g... yes
checking for i686-pc-linux-gnu-gcc option to accept ANSI C... none needed
checking dependency style of i686-pc-linux-gnu-gcc... none
checking for intltool >= 0.35.0... 0.35.5 found
checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/x11-themes/gnome-icon-theme-2.18.0/work/gnome-icon-theme-2.18.0/config.log

!!! ERROR: x11-themes/gnome-icon-theme-2.18.0 failed.
Call stack:
  ebuild.sh, line 1632:   Called dyn_compile
  ebuild.sh, line 983:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  ebuild.sh, line 1322:   Called gnome2_src_compile
  gnome2.eclass, line 70:   Called gnome2_src_configure
  gnome2.eclass, line 66:   Called econf
  ebuild.sh, line 586:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/log/portage/x11-themes:gnome-icon-theme-2.18.0:20070813-130720.log'.



Note: I don't have gnome, I use xfce4.4 and the gnome-icon-theme package is a dependency of another package.

I am attempting to update from gnome-icon-theme-2.16.1 to gnome-icon-theme-2.18.0.  Version 2.16.1 did not have this problem.
Comment 1 Gilles Dartiguelongue gentoo-dev 2007-08-13 14:27:28 UTC

*** This bug has been marked as a duplicate of bug 41124 ***