Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 188629 - app-text/evince-0.8.3 fails to emerge due to problems with XML-Parser
Summary: app-text/evince-0.8.3 fails to emerge due to problems with XML-Parser
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2007-08-12 19:17 UTC by José Otávio Rizzatti Ferreira
Modified: 2007-08-12 21:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Config.log file produced during emerge (config.log,43.27 KB, text/plain)
2007-08-12 19:20 UTC, José Otávio Rizzatti Ferreira

Note You need to log in before you can comment on or make changes to this bug.
Description José Otávio Rizzatti Ferreira 2007-08-12 19:17:41 UTC
app-text/evince-0.8.3 merge fails at the configure phase, claiming it needs XML::Parser. But, dev-perl/XML-Parser-2.34 is installed at in the system.

Use flags being used for evince:

[ebuild     U ] app-text/evince-0.8.3 [0.6.1-r3] USE="dbus tiff -debug -djvu -doc -dvi -gnome -t1lib"


Reproducible: Always

Steps to Reproduce:
1. emerge =app-text/evince-0.8.3
2. Will break

Actual Results:  
Here is a peace of output showing the problem:
checking for intltool >= 0.35.0... 0.35.5 found
checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when filing a report to
!!! /var/tmp/portage/app-text/evince-0.8.3/work/evince-0.8.3/config.log

!!! ERROR: app-text/evince-0.8.3 failed.
Call stack:, line 1632:   Called dyn_compile, line 983:   Called qa_call 'src_compile', line 44:   Called src_compile, line 1322:   Called gnome2_src_compile
  gnome2.eclass, line 70:   Called gnome2_src_configure
  gnome2.eclass, line 66:   Called econf '--disable-scrollkeeper' '--enable-comics' '--enable-impress' '--enable-dbus' '--disable-djvu' '--disable-dvi' '--disable-t1lib' '--enable-tiff' '--disable-nautilus' '--disable-gtk-doc', line 586:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/app-text/evince-0.8.3/temp/build.log'.

Expected Results:  
Succesfully installed evince. Maybe, have some other newer version as it's dependency.

# emerge --info
Portage (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.21-gentoo-r4 i686)
System uname: 2.6.21-gentoo-r4 i686 Genuine Intel(R) CPU T1300 @ 1.66GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Sun, 12 Aug 2007 08:20:01 +0000
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.21
CFLAGS="-O2 -march=prescott -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=prescott -pipe"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="X acl acpi alsa avahi berkdb bitmap-fonts bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread emboss encode evo fam firefox fontconfig fortran gdbm gif gnutls gpm graphviz gstreamer gtk hal iconv ipv6 isdnlog jpeg kerberos ldap libnotify mad midi mikmod mmx mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl png pppd python quicktime readline reflection ruby samba sasl sdl session slp spell spl sse sse2 ssl startup-notification svg tcpd threads tiff truetype truetype-fonts type1-fonts unicode vorbis win32codecs x86 xcomposite xinetd xml xorg xscreensaver xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev mouse keyboard synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="i810 vesa"
Comment 1 José Otávio Rizzatti Ferreira 2007-08-12 19:20:06 UTC
Created attachment 127896 [details]
Config.log file produced during emerge
Comment 2 José Otávio Rizzatti Ferreira 2007-08-12 19:31:01 UTC
x11-libs/vte-0.16.6-r1 shows the same behavior.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-08-12 19:40:53 UTC

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 4 José Otávio Rizzatti Ferreira 2007-08-12 19:43:00 UTC
Re-emerging dev-perl/XML-Parser-2.34 solved the problem with x11-libs/vte-0.16.6-r1.
Now evince breaks when building, due to problems with
I have rebuild dev-libs/expat-2.0.1 and running:
# revdep-rebuild -X --library

The packages that need to be rebuilt:
emerge --oneshot  =sys-devel/gettext-0.16.1 =sys-apps/dbus-1.0.2-r2 =media-libs/mesa-6.5.2-r1 =dev-libs/dbus-glib-0.73 =media-gfx/graphviz-2.12 =net-dns/avahi-0.6.19-r2 =sys-apps/hal-0.5.9-r1 
Comment 5 José Otávio Rizzatti Ferreira 2007-08-12 21:13:50 UTC
rebuilding XML-Parser and expat solved the problem.