Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 187853 - app-cdr/cdemu-0.8 cannot compile
Summary: app-cdr/cdemu-0.8 cannot compile
Status: RESOLVED DUPLICATE of bug 159015
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: SpanKY
URL:
Whiteboard:
Keywords:
: 200836 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-08-05 21:24 UTC by Aaron Slunt
Modified: 2008-03-17 21:12 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to compile on newer kernels (cdemu-0.8-gfrpatch.diff,1.95 KB, patch)
2007-08-06 08:58 UTC, Andreas Arens
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Slunt 2007-08-05 21:24:27 UTC
Trying to compile cdemu-0.8, it fails. Also tried using FEATURES="-sandbox", and it still fails.

------------------------------------------------------------------

localhost portage # emerge cdemu
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) app-cdr/cdemu-0.8 to /
 * cdemu-0.8.tar.bz2 RMD160 ;-) ...                                       [ ok ]
 * cdemu-0.8.tar.bz2 SHA1 ;-) ...                                         [ ok ]
 * cdemu-0.8.tar.bz2 SHA256 ;-) ...                                       [ ok ]
 * cdemu-0.8.tar.bz2 size ;-) ...                                         [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking cdemu-0.8.tar.bz2 ;-) ...                                     [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/2.6.22-gentoo-r2/build
 * Found sources for kernel version:
 *     2.6.22-gentoo-r2
>>> Unpacking source...
>>> Unpacking cdemu-0.8.tar.bz2 to /var/tmp/portage/app-cdr/cdemu-0.8/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8 ...
 * Preparing cdemu module
rm -f .cdemu*.{ko,mod.o,o}.cmd cdemu*.{ko,o,mod.{c,o}} *.pyc core *~
rm -rf .tmp_versions Modules.symvers
rm -f docs/cdemu.{dvi,pdf}
make[1]: Entering directory `/usr/src/linux-2.6.22-gentoo-r2'
  CC [M]  /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.o
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: In function ‘cdemu_transfer_bio’:
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:179: warning: format ‘%i’ expects type ‘int’, but argument 3 has type ‘ssize_t’
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: In function ‘cdemu_ioctl’:
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:489: warning: implicit declaration of function ‘generic_file_read’
  CC [M]  /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.o
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.c: In function ‘cdemu_exit’:
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.c:198: error: too many arguments to function ‘invalidate_bdev’
make[2]: *** [/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.o] Error 1
make[1]: *** [_module_/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.22-gentoo-r2'
make: *** [default] Error 2
 *
 * ERROR: app-cdr/cdemu-0.8 failed.
 * Call stack:
 *   ebuild.sh, line 1648:   Called dyn_compile
 *   ebuild.sh, line 988:   Called qa_call 'src_compile'
 *   ebuild.sh, line 44:   Called src_compile
 *   ebuild.sh, line 1328:   Called linux-mod_src_compile
 *   linux-mod.eclass, line 516:   Called die
 *
 * Unable to make   clean default.
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-cdr/cdemu-0.8/temp/build.log'.
 *

 * Messages for package app-cdr/cdemu-0.8:

 *
 * ERROR: app-cdr/cdemu-0.8 failed.
 * Call stack:
 *   ebuild.sh, line 1648:   Called dyn_compile
 *   ebuild.sh, line 988:   Called qa_call 'src_compile'
 *   ebuild.sh, line 44:   Called src_compile
 *   ebuild.sh, line 1328:   Called linux-mod_src_compile
 *   linux-mod.eclass, line 516:   Called die
 *
 * Unable to make   clean default.
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-cdr/cdemu-0.8/temp/build.log'.
 *


--------------------------------------------------------------------------------

####################################################################

localhost portage # emerge --info
Portage 2.1.3.3 (default-linux/amd64/2007.0/desktop, gcc-4.2.0, glibc-2.6-r0, 2.6.22-gentoo-r2 x86_64)
=================================================================
System uname: 2.6.22-gentoo-r2 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System release 1.12.10
Timestamp of tree: Sun, 05 Aug 2007 18:00:10 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17.50.0.18
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O3 -pipe -funroll-loops"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-march=athlon64 -O3 -pipe -funroll-loops"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/xeffects /usr/portage/local/layman/sunrise"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa amd64 berkdb bitmap-fonts cairo cdparanoia cdr cli cpudetection cracklib crypt cups custom-cflags dbus directfb dri dts dv dvb dvd dvdr dvdread emboss encode evo fam fbcon ffmpeg firefox fortran gdbm gif gpm gtk hal iconv ipv6 isdnlog jpeg kde kdeenablefinal kdehiddenvisibility kerberos lame libg++ mad midi mikmod mmx mmxext mp3 mpeg mplayer mtp mudflap musepack ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pcre pdf perl png pppd python qt qt3 qt3support qt4 quicktime readline reflection sdl sensord session speex spell spl sse sse2 ssl svg tcpd tiff truetype truetype-fonts type1-fonts unicode vorbis x264 xml xorg xv xvid zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

####################################################################

Reproducible: Always
Comment 1 Andreas Arens 2007-08-06 08:58:04 UTC
Created attachment 127042 [details, diff]
patch to compile on newer kernels
Comment 2 Andreas Arens 2007-08-06 09:01:41 UTC
Uhm. comment with patch lost.

The above patch extracted from upstream svn makes it work with newer kernels, but could break compatibility with older ones. Probably a non-issue since all kernels that could be broken by it should be masked already, and all current ones should work.

So currently there is no working combination without the patch.

It might be better however to bin the 0.8 complete and use a vastly enhanced svn snapshot instead.

Comment 3 Karen 2007-09-01 12:38:12 UTC
Same heppens here:
/var/tmp/portage/app-cdr/cdemu-0.8/temp/build.log:
=========================================
 ^[[32;01m*^[[0m Determining the location of the kernel source code
 ^[[32;01m*^[[0m Found kernel source directory:
 ^[[32;01m*^[[0m     /usr/src/linux
 ^[[32;01m*^[[0m Found kernel object directory:
 ^[[32;01m*^[[0m     /lib/modules/2.6.22-gentoo-r5/build
 ^[[32;01m*^[[0m Found sources for kernel version:
 ^[[32;01m*^[[0m     2.6.22-gentoo-r5
>>> Unpacking source...
>>> Unpacking cdemu-0.8.tar.bz2 to /var/tmp/portage/app-cdr/cdemu-0.8/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8 ...
 ^[[32;01m*^[[0m Preparing cdemu module
rm -f .cdemu*.{ko,mod.o,o}.cmd cdemu*.{ko,o,mod.{c,o}} *.pyc core *~
rm -rf .tmp_versions Modules.symvers
rm -f docs/cdemu.{dvi,pdf}
make[1]: Entering directory `/usr/src/linux-2.6.22-gentoo-r5'
  CC [M]  /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.o
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: In function 'cdemu_ioctl':
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:489: warning: implicit declaration of function 'generi
c_file_read'
 ^[[32;01m*^[[0m Determining the location of the kernel source code
 ^[[32;01m*^[[0m Found kernel source directory:
 ^[[32;01m*^[[0m     /usr/src/linux
 ^[[32;01m*^[[0m Found kernel object directory:
 ^[[32;01m*^[[0m     /lib/modules/2.6.22-gentoo-r5/build
 ^[[32;01m*^[[0m Found sources for kernel version:
 ^[[32;01m*^[[0m     2.6.22-gentoo-r5
>>> Unpacking source...
>>> Unpacking cdemu-0.8.tar.bz2 to /var/tmp/portage/app-cdr/cdemu-0.8/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8 ...
 ^[[32;01m*^[[0m Preparing cdemu module
rm -f .cdemu*.{ko,mod.o,o}.cmd cdemu*.{ko,o,mod.{c,o}} *.pyc core *~
rm -rf .tmp_versions Modules.symvers
rm -f docs/cdemu.{dvi,pdf}
make[1]: Entering directory `/usr/src/linux-2.6.22-gentoo-r5'
  CC [M]  /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.o
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: In function 'cdemu_ioctl':
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:489: warning: implicit declaration of function 'generi
c_file_read'
 ^[[32;01m*^[[0m Determining the location of the kernel source code
 ^[[32;01m*^[[0m Found kernel source directory:
 ^[[32;01m*^[[0m     /usr/src/linux
 ^[[32;01m*^[[0m Found kernel object directory:
 ^[[32;01m*^[[0m     /lib/modules/2.6.22-gentoo-r5/build
 ^[[32;01m*^[[0m Found sources for kernel version:
 ^[[32;01m*^[[0m     2.6.22-gentoo-r5
>>> Unpacking source...
>>> Unpacking cdemu-0.8.tar.bz2 to /var/tmp/portage/app-cdr/cdemu-0.8/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8 ...
 ^[[32;01m*^[[0m Preparing cdemu module
rm -f .cdemu*.{ko,mod.o,o}.cmd cdemu*.{ko,o,mod.{c,o}} *.pyc core *~
rm -rf .tmp_versions Modules.symvers
rm -f docs/cdemu.{dvi,pdf}
make[1]: Entering directory `/usr/src/linux-2.6.22-gentoo-r5'
  CC [M]  /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.o
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: In function 'cdemu_ioctl':
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:489: warning: implicit declaration of function 'generi
c_file_read'
  CC [M]  /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.o
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.c: In function 'cdemu_exit':
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.c:198: error: too many arguments to function 'invalidate_
bdev'
make[2]: *** [/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.o] Error 1
make[1]: *** [_module_/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.22-gentoo-r5'
make: *** [default] Error 2

!!! ERROR: app-cdr/cdemu-0.8 failed.
Call stack:
  ebuild.sh, line 1638:   Called dyn_compile
  ebuild.sh, line 985:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  ebuild.sh, line 1328:   Called linux-mod_src_compile
  linux-mod.eclass, line 516:   Called die

!!! Unable to make   clean default.
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/app-cdr/cdemu-0.8/temp/build.log'.
===============================

emerge --info
Portage 2.1.2.12 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.22-gentoo-r5 i686)
=================================================================
System uname: 2.6.22-gentoo-r5 i686 Intel(R) Pentium(R) 4 CPU 3.06GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Wed, 29 Aug 2007 23:00:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="x86"
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol"
ANT_HOME="/usr/share/ant-core"
ARCH="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=i686 -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CLASSPATH="."
CLEAN_DELAY="5"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CVS_RSH="ssh"
CXXFLAGS="-march=i686 -O2 -pipe"
DISPLAY=":0.0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/bin/nano"
ELIBC="glibc"
EMERGE_WARNING_DELAY="10"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
FETCHCOMMAND="/usr/bin/wget -t 5 -T 60 --passive-ftp -O ${DISTDIR}/${FILE} ${URI}"
GCC_PATH="/usr/i686-pc-linux-gnu/gcc-bin/4.1.2"
GCC_SPECS=""
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
GREP_COLOR="31"
G_BROKEN_FILENAMES="1"
G_FILENAME_ENCODING="UTF-8"
HOME="/root"
INFOPATH="/usr/share/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.17/info:/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/info"
INPUT_DEVICES="keyboard mouse evdev"
JAVAC="/etc/java-config-2/current-system-vm/bin/javac"
JAVA_HOME="/etc/java-config-2/current-system-vm"
JDK_HOME="/etc/java-config-2/current-system-vm"
KDEDIRS="/usr:/usr/local:/usr/kde/3.5"
KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LINGUAS="en en_GB il he"
LOGNAME="root"
MAKEOPTS=""
MANPATH="/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.17/man:/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/man:/etc/java-config/system-vm/man/:/usr/lib/php5/man/:/usr/kde/3.5/share/man:/usr/qt/3/doc/man"
OPENGL_PROFILE="nvidia"
PAGER="/usr/bin/less"
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.2:/usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/qt/3/bin"
PKGDIR="/usr/portage/packages"
PKG_CONFIG_PATH="/usr/qt/3/lib/pkgconfig"
PORTAGE_ARCHLIST="ppc s390 amd64 x86 ppc64 x86-fbsd m68k arm sparc sh mips ia64 alpha ppc-macos hppa sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib/portage/bin"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="log warn error"
PORTAGE_ELOG_MAILFROM="portage"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_PYM_PATH="/usr/lib/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
PRELINK_PATH_MASK="/usr/lib/gstreamer-0.10:/usr/lib/gstreamer-0.8"
PWD="/root"
PYTHONDOCS="/usr/share/doc/python-docs-2.4.4/html/lib"
PYTHONPATH="/usr/lib/portage/pym"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 5 -T 60 --passive-ftp -O ${DISTDIR}/${FILE} ${URI}"
ROOT="/"
ROOTPATH="/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.2:/usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/qt/3/bin"
RPMDIR="/usr/portage/rpm"
SHELL="/bin/bash"
SHLVL="1"
STAGE1_USE="nptl nptlonly unicode"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
TERM="xterm"
USE="X a52 aac aalib acl acpi aim aimextras akode alias alsa amarok amazon ao apache2 aqua_theme arts artworkextra asf automount autoreplace bash-completion berkdb bidi bitmap-fonts bzip2 cairo cdda cddb cdr cli connectionstatus contactnotes cracklib crypt cscope css dbus divx doc dri dvb dvd dvdr dvdread eds emboss encode escreen esd etwin evo extensions fam fame fat ffmpeg firefox flac fortran gdbm gif gmedia gpm gstreamer gtk gtk2 hal highlight iconv icq imagemagick ipv6 irc isdnlog jabber jpeg kde kerberos l7filter lame ldap libwww logitech-mouse logrotate mad matroska midi mikmod mjpeg mozilla mp3 mp4 mpeg mpeg2 mplayer msn mudflap music musicbrainz mysql ncurses net nethack network nls nowlistening nptl nptlonly nsplugin nvidia ogg opengl openmp oss pam pcre pda pdf perl php png pppd python qt3 qt3support qt4 quicktime quotas rdesktop readline real realmedia reflection ruby samba screen scsi sdl serial session skins sms spell spl ssl svg swat symlink syslog tcpd threads tiff tk truetype truetype-fonts type1 type1-fonts unicode usb v4l v4l2 vim vim-syntax visual visualization vorbis webpresence win32codecs winpopup wmp wxwindows x86 xcomposite xine xinerama xml xorg xscreensaver xv xvid xvmc xvnc yahoo zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB il he" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
USER="root"
USERLAND="GNU"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS CAMERAS CROSSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS INPUT_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal:env.d"
VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
XARGS="xargs -r"
XAUTHORITY="/root/.xauthK6Kcet"
XDG_DATA_DIRS="/usr/share:/usr/kde/3.5/share:/usr/local/share"
_="/usr/bin/emerge"
Comment 4 Bjoern Olausson 2007-09-03 10:57:55 UTC
Thanks for the patch works fine here:

Linux freax 2.6.22.5 #1 SMP PREEMPT Mon Aug 27 11:15:03 CEST 2007 x86_64 Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz GenuineIntel GNU/Linux

Compiles on linux-2.6.23-rc3 to.

why not make a -r1 and put it into portage?

regards
Bjoern
Comment 5 haarp 2007-11-09 17:26:34 UTC
I agree that a -r1 should be made. Should be pretty easy afaik
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-11-30 16:10:47 UTC
*** Bug 200836 has been marked as a duplicate of this bug. ***
Comment 7 Rui Ramos 2008-01-29 23:11:29 UTC
Doesn't compile on 2.6.23-gentoo-r3 x86_64 AMD after applying this patch.

make[1]: Entering directory `/usr/src/linux-2.6.23-gentoo-r3'
  CC [M]  /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.o
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: In function 'cdemu_transfer_bio':
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:176: error: 'const struct file_operations' has no member named 'sendfile'
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: At top level:
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:215: warning: 'request_queue_t' is deprecated
make[2]: *** [/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.o] Error 1
make[1]: *** [_module_/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.23-gentoo-r3'
make: *** [default] Error 2
 * 
 * ERROR: app-cdr/cdemu-0.8 failed.
 * Call stack:
 *          ebuild.sh, line 1701:  Called dyn_compile
 *          ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *          ebuild.sh, line   44:  Called src_compile
 *          ebuild.sh, line 1383:  Called linux-mod_src_compile
 *   linux-mod.eclass, line  519:  Called die
 * The specific snippet of code:
 *                      emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" \
 *                                ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS} \
 *                              || die "Unable to make ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}."
 *  The die message:
 *   Unable to make   clean default.
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-cdr/cdemu-0.8/temp/build.log'.
 * 

 Can any one confirm the build in amd64 ?
Comment 8 Alex J. Ivasyuv 2008-02-06 00:11:21 UTC
Also in 2.6.24:

# emerge -va cdemu

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] app-cdr/cdemu-0.8  0 kB

Total: 1 package (1 new), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) app-cdr/cdemu-0.8 to /
 * cdemu-0.8.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                   [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                   [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                  [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                 [ ok ]
 * checking cdemu-0.8.tar.bz2 ;-) ...                                                                                                                  [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     2.6.24-oss
>>> Unpacking source...
>>> Unpacking cdemu-0.8.tar.bz2 to /usr/tmp/portage/app-cdr/cdemu-0.8/work
>>> Source unpacked.
>>> Compiling source in /usr/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8 ...
 * Preparing cdemu module
rm -f .cdemu*.{ko,mod.o,o}.cmd cdemu*.{ko,o,mod.{c,o}} *.pyc core *~
rm -rf .tmp_versions Modules.symvers
rm -f docs/cdemu.{dvi,pdf}
make[1]: Entering directory `/usr/src/linux-2.6.24'
  CC [M]  /usr/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.o
/usr/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: In function 'cdemu_transfer_bio':
/usr/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:176: error: 'const struct file_operations' has no member named 'sendfile'
/usr/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: At top level:
/usr/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:215: warning: 'request_queue_t' is deprecated
/usr/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: In function 'cdemu_make_request':
/usr/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:248: error: too many arguments to function 'bio_endio'
/usr/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: In function 'cdemu_ioctl':
/usr/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:489: error: implicit declaration of function 'generic_file_read'
make[2]: *** [/usr/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.o] Error 1
make[1]: *** [_module_/usr/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.24'
make: *** [default] Error 2
 *
 * ERROR: app-cdr/cdemu-0.8 failed.
 * Call stack:
 *               ebuild.sh, line   46:  Called src_compile
 *             environment, line 3299:  Called linux-mod_src_compile
 *             environment, line 2473:  Called die
 * The specific snippet of code:
 *               emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS} || die "Unable to make ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}.";
 *  The die message:
 *   Unable to make   clean default.
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/usr/tmp/portage/app-cdr/cdemu-0.8/temp/build.log'.
 * The ebuild environment file is located at '/usr/tmp/portage/app-cdr/cdemu-0.8/temp/environment'.
 *

 * Messages for package app-cdr/cdemu-0.8:

 *
 * ERROR: app-cdr/cdemu-0.8 failed.
 * Call stack:
 *               ebuild.sh, line   46:  Called src_compile
 *             environment, line 3299:  Called linux-mod_src_compile
 *             environment, line 2473:  Called die
 * The specific snippet of code:
 *               emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS} || die "Unable to make ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}.";
 *  The die message:
 *   Unable to make   clean default.
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/usr/tmp/portage/app-cdr/cdemu-0.8/temp/build.log'.
 * The ebuild environment file is located at '/usr/tmp/portage/app-cdr/cdemu-0.8/temp/environment'.
 *
#

# emerge --info
Portage 2.1.4.1 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.7-r1, 2.6.24-oss i686)
=================================================================
System uname: 2.6.24-oss i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Timestamp of tree: Tue, 05 Feb 2008 01:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.3-r4, 2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -mtune=prescott -pipe -O2 -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=prescott -mtune=prescott -pipe -O2 -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://src.gentoo.pl"
LANG="ru_RU.UTF-8"
LC_ALL="C"
LINGUAS="ru"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X X509 Xaw3d a52 aac aalib accessibility acl acpi activefilter administrator aften akode alsa amarok ao aqua_theme audacious audiofile bash-completion berkdb bitmap-fonts blender-game bzip2 c++ cairo carbone_theme cdio cdparanoia chm cjk cli cpudetection cracklib crypt css cups cvs cvsgraph cyrillic d dbus debug dga divx djvu dmx dri dts dv dvb dvd dvdr dvdread dvi emacs emoticon emovix encode examples expat extensions fame fat ffmpeg fftw firefox flac fltk fontconfig foomaticdb fortran ftp fuse gdbm ggi gif gimp gimpprint glitz gpm gs gsm gstreamer gtk hal hddtemp hfs iconv icu id3 id3tag ieee1394 image imagemagick imlib ipv6 isdnlog jabber jack jack-tmpfs java javascript jfs jingle jpeg jpeg2k kde kdepim kqemu ladspa lame ldap ldap-sasl libcaca libsamplerate libsexy libvisual libwww lirc lm_sensors logitech-mouse logrotate lua mad matroska matrox md5sum midi mikmod mixer mjpeg mmap mmx mmxext mng motif moznopango mp2 mp3 mp3rtp mp4 mp4live mpeg mpeg2 mplayer mppe-mppc mudflap multiuser musepack musicbrainz mysql nas ncurses neXt nethack netjack network nfs nls nptl nptlonly nss ntfs nut ogg openal openexr opengl openmp openssh openssl opensslcrypt optimisememory oss pam pcre pdf perl png pnm portaudio posix postgres ppds pppd print pulseaudio pvr pyste python qt3 qt3support qt4 radio rar rdesktop readline reflection reiser4 reiserfs rtc ruby samba scanner schedule sdl seamonkeysensord server session skins slang smp sms sndfile sound sox speex spell spl sql sqlite sse sse2 ssl startup-notification subversion svg svga swat symlink syslog tcl tcpd teletext tga themes theora threads thunderbird tiff timidity tk tools tordns transcode trayicon truetype truetype-fonts type1-fonts unicode unzip urandom usb v4l v4l2 vcd verse vidix vim vim-pager vim-syntax vim-with-x vlm vnc vorbis vorbis-psy wav wavpack win32codecs wma wxwindows x264 x86 xcomposite xfs xhtml xine xinerama xml xorg xosd xpm xv xvid zlib zvbi" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" LIRC_DEVICES="audio audio_alsa avermedia" USERLAND="GNU" VIDEO_CARDS="vesa vga fglrx radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY



Comment 9 Tony E 2008-02-16 23:49:38 UTC
I don't know if any info of mine will help, but I'm getting this same error as well.  For reference, my output & emerge info:
--

[ebuild  N    ] app-cdr/cdemu-0.8  

Would you like to merge these packages? [Yes/No] y
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) app-cdr/cdemu-0.8 to /
 * cdemu-0.8.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                          [ ok ]
 * checking ebuild checksums ;-) ...                                                                                          [ ok ]
 * checking auxfile checksums ;-) ...                                                                                         [ ok ]
 * checking miscfile checksums ;-) ...                                                                                        [ ok ]
 * checking cdemu-0.8.tar.bz2 ;-) ...                                                                                         [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/2.6.24-gentoo-r2/build
 * Found sources for kernel version:
 *     2.6.24-gentoo-r2
>>> Unpacking source...
>>> Unpacking cdemu-0.8.tar.bz2 to /var/tmp/portage/app-cdr/cdemu-0.8/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8 ...
 * Preparing cdemu module
rm -f .cdemu*.{ko,mod.o,o}.cmd cdemu*.{ko,o,mod.{c,o}} *.pyc core *~
rm -rf .tmp_versions Modules.symvers
rm -f docs/cdemu.{dvi,pdf}
make[1]: Entering directory `/usr/src/linux-2.6.24-gentoo-r2'
  CC [M]  /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.o
  CC [M]  /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.o
  CC [M]  /var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_proc.o
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.c:64: warning: 'request_queue_t' is deprecated
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.c:65: warning: 'request_queue_t' is deprecated
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.c: In function 'cdemu_init':
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.c:173: error: void value not ignored as it ought to be
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.c: In function 'cdemu_exit':
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.c:198: error: too many arguments to function 'invalidate_bdev'
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.c:218: error: void value not ignored as it ought to be
make[2]: *** [/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_mod.o] Error 1
make[2]: *** Waiting for unfinished jobs....
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: In function 'cdemu_transfer_bio':
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:176: error: 'const struct file_operations' has no member named 'sendfile'
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: At top level:
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:215: warning: 'request_queue_t' is deprecated
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: In function 'cdemu_make_request':
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:248: error: too many arguments to function 'bio_endio'
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c: In function 'cdemu_ioctl':
/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.c:489: error: implicit declaration of function 'generic_file_read'
make[2]: *** [/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8/cdemu_core.o] Error 1
make[1]: *** [_module_/var/tmp/portage/app-cdr/cdemu-0.8/work/cdemu-0.8] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.24-gentoo-r2'
make: *** [default] Error 2
 * 
 * ERROR: app-cdr/cdemu-0.8 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3267:  Called linux-mod_src_compile
 *             environment, line 2439:  Called die
 * The specific snippet of code:
 *               emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS} || die "Unable to make ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}.";
 *  The die message:
 *   Unable to make   clean default.
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-cdr/cdemu-0.8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-cdr/cdemu-0.8/temp/environment'.




# emerge --info
Portage 2.1.4.4 (default-linux/x86/2007.0, gcc-4.2.2, glibc-2.7-r1, 2.6.24-gentoo-r2 i686)
=================================================================
System uname: 2.6.24-gentoo-r2 i686 Pentium III (Katmai)
Timestamp of tree: Sat, 16 Feb 2008 09:46:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-lang/python:     2.4.4-r4, 2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium3 -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium3 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y "
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://gentoo.mirrors.easynews.com/linux/gentoo/ http://mirror.espri.arizona.edu/gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/"
INSTALL_MASK=""
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS=""
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="acl apache2 berkdb bitmap-fonts cli cracklib crypt cups dri fortran gdbm iconv imap ipv6 isdnlog libwww maildir mailwrapper midi mudflap mysql ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection sasl session snmp spl ssl tcpd threads truetype truetype-fonts type1-fonts unicode x86 xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTDIR_OVERLAY
Comment 10 Arthur Bousquet 2008-02-19 17:51:29 UTC
(In reply to comment #7)
> 
>  Can any one confirm the build in amd64 ?
> 

I am getting this identical build error in x86_64 2.6.23-r6 with the patch.
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2008-03-17 21:12:12 UTC

*** This bug has been marked as a duplicate of bug 159015 ***