Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 187056 - cdrtools-2.01.01_alpha30 - cdrecord fails on /dev/srX if user is not root
Summary: cdrtools-2.01.01_alpha30 - cdrecord fails on /dev/srX if user is not root
Status: VERIFIED DUPLICATE of bug 116026
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2007-07-29 19:12 UTC by Johannes Hirte
Modified: 2007-07-29 19:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Hirte 2007-07-29 19:12:04 UTC
cdrecord from cdrtools-2.01.01_alpha30 can't send scsi-commands to /dev/srX if the user is not root.

cdrecord -v blank=fast dev=/dev/sr0
Cdrecord-ProDVD-ProBD-Clone 2.01.01a30 (x86_64-unknown-linux-gnu) Copyright (C) 1995-2007 Jörg Schilling
TOC Type: 1 = CD-ROM
cdrecord: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits.cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
cdrecord: WARNING: This causes a high risk for buffer underruns.
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '/dev/sr0'
devname: '/dev/sr0'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.9'.
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 5
Response Format: 2
Capabilities   :
Vendor_info    : 'HL-DT-ST'
Identifikation : 'DVD-RW GWA-4082N'
Revision       : 'CW02'
Device seems to be: Generic mmc2 DVD-R/DVD-RW/DVD-RAM.
Current: CD-RW
Profile: DVD-R sequential recording
Profile: DVD-R/DL sequential recording
Profile: DVD-RW sequential recording
Profile: DVD-RW restricted overwrite
Profile: DVD+RW
Profile: DVD+R
Profile: DVD+R/DL
Profile: DVD-ROM
Profile: CD-R
Profile: CD-RW (current)
Profile: CD-ROM
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Drive buf size : 1053696 = 1029 KB
Drive pbuf size: 1966080 = 1920 KB
Drive DMA Speed: 13192 kB/s 74x CD 9x DVD 2x BD
cdrecord: Operation not permitted. Cannot send SCSI cmd via ioctl.
cdrecord: Operation not permitted. Cannot open or use SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

Using dev=/dev/sgX works non-root.

Reproducible: Always
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-07-29 19:25:00 UTC
Either use cdrkit or complain upstream.

*** This bug has been marked as a duplicate of bug 116026 ***
Comment 2 Johannes Hirte 2007-07-29 19:39:47 UTC
cdrkit solved the problem for me, but its not the same bug. Up to cdrtools-2.01.01_alpha27 cdrecord worked on /dev/sr0 on my system. 

I've also to correct me, /dev/sg1 worked for blanking the disc but I wasn't able to burn successfull. It always ended in some SCSI-Errors.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-07-29 19:50:28 UTC
Well, app-cdr/cdrkit is the way to go; cdrtools will be eventually removed from the tree because of perpetual issues w/ upstream.