Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 184479 - mythtv-0.21_pre13775 mythfrontend hangs when rebuffering
Summary: mythtv-0.21_pre13775 mythfrontend hangs when rebuffering
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Doug Goldstein (RETIRED)
Depends on:
Reported: 2007-07-07 08:25 UTC by Hasse Hagen Johansen
Modified: 2007-08-22 15:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Hasse Hagen Johansen 2007-07-07 08:25:37 UTC
There is a problem when viewing a channel and then the program ends and a new one starts - mythtv would then rebuffer, but mythfrontend hangs every time it would have to rebuffer(the ringbuffer I think). I have no problem switching channels. It is only when watching a program ending(it is always reproduceable here). It could be though that it also happened in the middle of a program(I am not sure)

Reproducible: Always
Comment 1 David Grant 2007-07-27 18:50:04 UTC
Did this happen for you in previous version of mythtv?
Comment 2 Hasse Hagen Johansen 2007-07-27 20:00:24 UTC
No I didn't have this problem with the earlier subversion package in gentoo (mythtv-0.21_pre13285.ebuild) and the mythtv-0.20 versions have also worked without problems

Right now I am running a newer subversion revision 14025. This also have that problem.
Comment 3 Hasse Hagen Johansen 2007-08-06 15:12:52 UTC
Ok. I tried with a subversion release from yesterday. I also have the problem with that. It could be it actually is a ivtv problem. I saw something about a fix where it would hang when changing channels..I can change channels without problems. I only experience the hang when mythtv is rebuffering between programs
Comment 4 Hasse Hagen Johansen 2007-08-06 19:35:43 UTC
Ohh..I have just found out some new info. I was lazy and didn't restart my after it hung I didn't restart it...and about 10 minutes after the hung it started to play live-tv again
Comment 5 Doug Goldstein (RETIRED) gentoo-dev 2007-08-07 16:42:54 UTC
There are several tickets about this issue upstream. A better place for this discussion is upstream since the 0.21 series of ebuilds are merely just random trunk snapshots and are provided as a convenience to Gentoo users and are not officially maintained.
Comment 6 Hasse Hagen Johansen 2007-08-07 17:37:23 UTC
ok. I was just about to suggest that I asked around on myth-users and file a bug upstream

DO you know of a bug id upstream?
Comment 7 Doug Goldstein (RETIRED) gentoo-dev 2007-08-22 15:05:48 UTC
Can't tell you a ticket number off the top of my head, but it was a common thing discussed by MythTV developers on IRC.

This is what happens when you go with trunk, things can break.

Either way, 13775 is no longer in the tree and has been replaced with much newer ebuilds.