Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 183240 - Circular dependancy in linux Gentoo on AMD64 X2
Summary: Circular dependancy in linux Gentoo on AMD64 X2
Status: RESOLVED DUPLICATE of bug 175808
Alias: None
Product: Gentoo Infrastructure
Classification: Unclassified
Component: CVS/SVN/Git (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 183244 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-06-26 12:07 UTC by Dmitri Seletski
Modified: 2011-10-30 22:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitri Seletski 2007-06-26 12:07:43 UTC
localhost ~ # emerge -pv media-gfx/graphviz

These are the packages that would be merged, in order:

Calculating dependencies... done!
[nomerge      ] gnome-base/gnome-mount-0.4-r5  USE="-debug"
[nomerge      ]  gnome-base/libgnomeui-2.16.1  USE="doc jpeg -debug"
[nomerge      ]   gnome-base/gnome-vfs-2.16.3-r1  USE="doc hal ipv6 samba ssl -avahi -debug -gnutls"
[nomerge      ]    dev-libs/dbus-glib-0.73  USE="doc -debug (-selinux)"
[nomerge      ]     app-doc/doxygen-1.4.7  USE="doc unicode -qt3 -tetex"
[nomerge      ]      app-text/ghostscript-gpl-8.54  USE="cups gtk jpeg2k -X -cjk -djvu -emacs"
[nomerge      ]       net-print/cups-1.2.10-r1  USE="dbus jpeg nls pam png samba ssl -X -ldap -php -ppds -slp -tiff"
[ebuild  N    ]        virtual/ghostscript-0
[ebuild  N    ]        net-fs/samba-3.0.24-r3  USE="acl cups doc pam python readline -async -automount -caps -examples -fam -kerberos -ldap -oav -quotas (-selinux) -swat -syslog -winbind" LINGUAS="-ja -pl"
[ebuild  N    ]        app-text/ghostscript-gpl-8.54  USE="cups gtk jpeg2k -X -cjk -djvu -emacs"
[ebuild  N    ]         net-print/cups-1.2.10-r1  USE="dbus jpeg nls pam png samba ssl -X -ldap -php -ppds -slp -tiff"
[ebuild  N    ]          sys-apps/dbus-1.0.2-r2  USE="doc -X -debug (-selinux)"
[ebuild  N    ]           app-doc/doxygen-1.4.7  USE="doc unicode -qt3 -tetex"
[ebuild  N    ]    dev-libs/dbus-glib-0.73  USE="doc -debug (-selinux)"
[ebuild  N    ]    sys-apps/hal-0.5.9-r1  USE="acpi crypt doc -debug -dell -disk-partition -pcmcia (-selinux)"
[ebuild  N    ]   gnome-base/libbonoboui-2.16.0  USE="doc -X -debug"
[ebuild  N    ]    gnome-base/libgnome-2.16.0  USE="doc -debug -esd"
[ebuild  N    ]     gnome-base/gnome-vfs-2.16.3-r1  USE="doc hal ipv6 samba ssl -avahi -debug -gnutls"
[nomerge      ] gnome-base/gnome-mount-0.4-r5  USE="-debug"
[nomerge      ]  gnome-base/libgnomeui-2.16.1  USE="doc jpeg -debug"
[nomerge      ]   gnome-base/gnome-vfs-2.16.3-r1  USE="doc hal ipv6 samba ssl -avahi -debug -gnutls"
[nomerge      ]    dev-libs/dbus-glib-0.73  USE="doc -debug (-selinux)"
[nomerge      ]     app-doc/doxygen-1.4.7  USE="doc unicode -qt3 -tetex"
[ebuild  N    ]      media-gfx/graphviz-2.12  USE="doc gnome gtk nls perl python -X -examples -pango -ruby -tcl -tk"
[ebuild  N    ]       gnome-base/libgnomeui-2.16.1  USE="doc jpeg -debug"
!!! Error: circular dependencies:

('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') depends on
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3-r1', 'merge') (hard)
('ebuild', '/', 'sys-apps/dbus-1.0.2-r2', 'merge') depends on
   ('ebuild', '/', 'app-doc/doxygen-1.4.7', 'merge') (hard)
('ebuild', '/', 'sys-apps/hal-0.5.9-r1', 'merge') depends on
   ('ebuild', '/', 'app-doc/doxygen-1.4.7', 'merge') (hard)
   ('ebuild', '/', 'dev-libs/dbus-glib-0.73', 'merge') (hard)
('ebuild', '/', 'app-text/ghostscript-gpl-8.54', 'merge') depends on
   ('ebuild', '/', 'net-print/cups-1.2.10-r1', 'merge') (hard)
('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3-r1', 'merge') depends on
   ('ebuild', '/', 'sys-apps/hal-0.5.9-r1', 'merge') (hard)
   ('ebuild', '/', 'dev-libs/dbus-glib-0.73', 'merge') (hard)
   ('ebuild', '/', 'net-fs/samba-3.0.24-r3', 'merge') (hard)
('ebuild', '/', 'media-gfx/graphviz-2.12', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') (hard)
('ebuild', '/', 'dev-libs/dbus-glib-0.73', 'merge') depends on
   ('ebuild', '/', 'sys-apps/dbus-1.0.2-r2', 'merge') (hard)
   ('ebuild', '/', 'app-doc/doxygen-1.4.7', 'merge') (hard)
('ebuild', '/', 'app-doc/doxygen-1.4.7', 'merge') depends on
   ('ebuild', '/', 'app-text/ghostscript-gpl-8.54', 'merge') (hard)
   ('ebuild', '/', 'virtual/ghostscript-0', 'merge') (hard)
   ('ebuild', '/', 'media-gfx/graphviz-2.12', 'merge') (hard)
('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
('ebuild', '/', 'gnome-base/libgnomeui-2.16.1', 'merge') depends on
   ('ebuild', '/', 'gnome-base/libbonoboui-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/libgnome-2.16.0', 'merge') (hard)
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3-r1', 'merge') (hard)
('ebuild', '/', 'net-fs/samba-3.0.24-r3', 'merge') depends on
   ('ebuild', '/', 'net-print/cups-1.2.10-r1', 'merge') (hard)
('ebuild', '/', 'virtual/ghostscript-0', 'merge') depends on
   ('ebuild', '/', 'app-text/ghostscript-gpl-8.54', 'merge') (medium)
   ('ebuild', '/', 'net-print/cups-1.2.10-r1', 'merge') (soft)
('ebuild', '/', 'net-print/cups-1.2.10-r1', 'merge') depends on
   ('ebuild', '/', 'sys-apps/dbus-1.0.2-r2', 'merge') (hard)

!!! Note that circular dependencies can often be avoided by temporarily
!!! disabling USE flags that trigger optional dependencies.




made sync of portage system on 26/06/2007 on 13.00

Reproducible: Always

Steps to Reproduce:
quite obvious fails all the time when try install gnome or graphiz(which is part 
of it)
Actual Results:  
nothing, thats the problem. wasnt able to install software.

Expected Results:  
expected to have gnome installed on my system

install gnome on my pc(or at least graphiz).
Comment 1 Samuli Suominen gentoo-dev 2007-06-26 12:17:34 UTC
You can disable USE="doc" to get pass these until it's fixed, IIRC.
Comment 2 Samuli Suominen gentoo-dev 2007-06-26 12:18:44 UTC
*** Bug 183244 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-06-26 12:19:58 UTC

*** This bug has been marked as a duplicate of bug 175808 ***