Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 182555 - sys-kernel/mips-sources-2.6.20.14 - misc-2.6.20-ip28-i2_impact-support.patch fails
Summary: sys-kernel/mips-sources-2.6.20.14 - misc-2.6.20-ip28-i2_impact-support.patch ...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: MIPS Linux
: High normal (vote)
Assignee: MIPS Porters
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-19 08:56 UTC by Mathias Weigt
Modified: 2010-01-10 09:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Weigt 2007-06-19 08:56:04 UTC
mips-sources-2.6.20.14 don't emerge with USE="ip28" because it fails to apply misc-2.6.20-ip28-i2_impact-support.patch
Apparently there were some major changes upstream so that this patch won't work.

Reproducible: Always

Steps to Reproduce:
1.USE="ip28" emerge =mips-sources-2.6.20.14
2.
3.

Actual Results:  
* >>> Patching kernel for SGI Indigo2 Impact R10000 (IP28) support ...
 * Applying misc-2.6.20-ip28-i2_impact-support.patch ...

 * Failed Patch: misc-2.6.20-ip28-i2_impact-support.patch !
 *  ( /var/tmp/portage/sys-kernel/mips-sources-2.6.20.14/work/mips-patches/misc-2.6.20-ip28-i2_impact-support.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/sys-kernel/mips-sources-2.6.20.14/temp/misc-2.6.20-ip28-i2_impact-support.patch-13550.out


Expected Results:  
should emerge fine

This are the first lines of output:

***** misc-2.6.20-ip28-i2_impact-support.patch *****

====================================================

PATCH COMMAND:   patch -p0 -g0 -E --no-backup-if-mismatch <
/var/tmp/portage/sys-kernel/mips-sources-2.6.20.14/work/mips-patches/misc-2.6.20-ip28-i2_impact-support.patch

====================================================
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Naurp linux-2.6.20.10.orig/arch/mips/Kconfig linux-2.6.20.10/arch/mips/Kconfig
|--- linux-2.6.20.10.orig/arch/mips/Kconfig     2007-04-28 17:16:03.000000000 -0400
|+++ linux-2.6.20.10/arch/mips/Kconfig  2007-04-28 17:58:29.000000000 -0400
--------------------------
No file to patch.  Skipping patch.
3 out of 3 hunks ignored
Comment 1 Brian Harring gentoo-dev 2010-01-10 08:44:13 UTC
Marking FIXED since the version is long since out of the tree...