Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 182204 - gnome-base/gnome-games has file collisions for score files
Summary: gnome-base/gnome-games has file collisions for score files
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-16 09:03 UTC by Hans de Graaff
Modified: 2008-03-01 07:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info output (emerge-info.txt,8.97 KB, text/plain)
2007-06-20 06:02 UTC, Hans de Graaff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hans de Graaff gentoo-dev 2007-06-16 09:03:14 UTC
When trying to install gnome-applets-2.18.1 I get the following report:

existing file /var/lib/games/gnometris.scores is not owned by this package
existing file /var/lib/games/same-gnome.Small.scores is not owned by this package
existing file /var/lib/games/mahjongg.difficult.scores is not owned by this package
existing file /var/lib/games/gnotski.1.scores is not owned by this package
existing file /var/lib/games/gnobots2.robots2_easy.scores is not owned by this package
* This package is blocked because it wants to overwrite
* files belonging to other packages (see messages above).
* If you have no clue what this is all about report it 
* as a bug for this package on http://bugs.gentoo.org

package gnome-extra/gnome-games-2.18.1 NOT merged

According to equery these files belong to no package.  There are actually a whole set of score files in the /var/lib/games directory, but these are the only ones that are non-zero, probably indicating that I played them at some point and left a score in them.

Unless there are requirements due to changed formats the score files which have been changed should not be overwritten.

Reproducible: Always
Comment 1 Daniel Gryniewicz (RETIRED) gentoo-dev 2007-06-20 01:39:38 UTC
First off:  I'm assuming it's gnome-games, not gnome-applets, like in the Summary?


Second, the .score files are not overwritten.  Any score files that exist in the filesystem are copyied over the distribution ones first.  I play lots of games and have score files for most, but have never gotten these errors.  Are you upgrading gnome-games?  Did you unmerge and re-emerge it?

Please include emerge --info
Comment 2 Hans de Graaff gentoo-dev 2007-06-20 06:02:06 UTC
Aargh. Yes, obviously this is about gnome-games-2.18.1, no applets to be found here. I'm upgrading gnome-games:

[ebuild     U ] gnome-extra/gnome-games-2.18.1 [2.16.3] USE="guile opengl%* -artworkextra -debug" 0 kB 

Comment 3 Hans de Graaff gentoo-dev 2007-06-20 06:02:33 UTC
Created attachment 122571 [details]
emerge --info output
Comment 4 Hans de Graaff gentoo-dev 2007-06-21 11:00:53 UTC
I've looked a bit further into this, and the real problem seems to be that those specific score files are not listed in the CONTENTS file for gnome-games-2.16.3. So, it looks like something went wrong when installing that version. Easy enough for me to fix locally, but I'll leave things as they are for now in case you need me to dig around a bit more.
Comment 5 Daniel Gryniewicz (RETIRED) gentoo-dev 2007-06-23 01:20:49 UTC
Okay, this is a result of bug #167277.  Before, the scorefiles were not installed if they existed in the filesystem.  Now, they're copied out of the live filesystem, and re-installed over themselves.  This will result, I believe, in collisions.  Just emerging with FEATURES=-collision-protect will do the correct thing in this case.
Comment 6 Gilles Dartiguelongue gentoo-dev 2008-02-28 23:31:41 UTC
couldn't reproduce with 2007.0 install materials on my 1 1/2 month old install. I guess this can be closed ?
Comment 7 Hans de Graaff gentoo-dev 2008-03-01 07:30:07 UTC
Given that this is only caused when upgrading from gnome 2.16 and given that there isn't an easy fix to make that upgrade smooth I'd say we can close this, yes.