Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 181270 - sys-libs/pam-0.78-r5 has dependencies in /usr w/ USE=berkdb
Summary: sys-libs/pam-0.78-r5 has dependencies in /usr w/ USE=berkdb
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: PAM Gentoo Team (OBSOLETE)
Depends on: 185203
  Show dependency tree
Reported: 2007-06-08 05:03 UTC by Werner M. Mayer
Modified: 2007-11-04 15:34 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Werner M. Mayer 2007-06-08 05:03:11 UTC
+++ This bug was initially created as a clone of Bug #85679 +++

This one doesn't die on pam_unix (as in 84836) or pam_access (85069), or others 
mentioned in other reports, it chokes on pam_userdb and I don't know which
library is to remove here.

make[2]: Leaving directory `/var/tmp/portage/sys-libs/pam-0.78-r5/work/Linux-PAM-0.78/modules/pam_xauth'
make[1]: Leaving directory `/var/tmp/portage/sys-libs/pam-0.78-r5/work/Linux-PAM-0.78/modules'
 * Checking if all modules were built...

 * ERROR: pam_userdb have dependencies in /usr.

!!! ERROR: sys-libs/pam-0.78-r5 failed.
Call stack:, line 1614:   Called dyn_install, line 1060:   Called qa_call 'src_install'
  environment, line 3485:   Called src_install
  pam-0.78-r5.ebuild, line 312:   Called die

!!! pam_userdb have dependencies in /usr.
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/log/portage/sys-libs:pam-0.78-r5:20070607-191224.log'.
I'll shorten my emerge --info a little:
 Portage (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.5-r0, i6 86)
 System uname: i686 Pentium III (Coppermine)
 Gentoo Base System release 1.12.9 Timestamp of tree: Tue, 01 May 2007 18:50:01 +0000
 ccache version 2.3 [enabled]      dev-lang/python:     2.4.3-r4
 dev-python/pycrypto: 2.0.1-r5     dev-util/ccache:     2.3
 sys-apps/sandbox:    1.2.17       sys-devel/autoconf:  2.13, 2.61
 sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
 sys-devel/binutils:  2.16.1-r3    sys-devel/gcc-config: 1.3.15-r1
 sys-devel/libtool:   1.5.22       virtual/os-headers:  2.6.17-r2
 ACCEPT_KEYWORDS="x86"      AUTOCLEAN="yes"      CBUILD="i686-pc-linux-gnu"
 CFLAGS="-march=pentium3 -O3 -pipe"              CHOST="i686-pc-linux-gnu"
 CXXFLAGS="-march=pentium3 -O3 -pipe"      DISTDIR="/usr/portage/distfiles"
 FEATURES="autoaddcvs buildpkg ccache cvs distlocks keeptemp keepwork 
 metadata-t ransfer noclean notitles sandbox sfperms strict userpriv usersandbox"
 LANG="de_DE@euro"  LINGUAS="de"  MAKEOPTS="-j2"  PKGDIR="/usr/portage/packages"
 PORTAGE_TMPDIR="/var/tmp"  PORTDIR="/usr/portage" PORTDIR_OVERLAY="/usr/local/portage"
 USE="X alsa berkdb bitmap-fonts cdr cli cracklib crypt cups dri dvd fortran gdb m gpm gtk gtk2 iconv ipv6 isdnlog jpeg libg++ midi ncurses nls nptl nptlonly pa m pcre perl png ppds pppd python readline reflection session spl ssl tcpd truet ype-fonts type1-fonts unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp  atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es196 8 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx -modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty
 extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null pl ug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse ev dev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm 001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="apm ark ati c hips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mga neomagic nsc nv re ndition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l v esa vga via vmware voodoo"

I don't know where to look or which library to deactivate for this one.

Any ideas anyone?
Comment 1 Werner M. Mayer 2007-06-08 05:08:03 UTC
Forgot to retype, that I had a running system, which decided to update using
emerge -vuane system. Got through almost everything on my laptop, but quit
with the above error message in sys-libs/pam-0.78-r5.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-06-08 06:27:43 UTC
Please, don't clone bugs, it stick loads of people that are not interested in the issue to CC. 

I highly doubt anyone will touch the pam-0.78 mess; just do `echo "sys-libs/pam -berkdb" >> /etc/portage/package.use`
Comment 3 Werner M. Mayer 2007-06-10 20:47:28 UTC
Thank you for your help and solution, it worked well.

I do however still have two questions:
1. For what reason does the clone option exist, when is it OK to use it, 
   if the reason I used it for was not OK?

2. When doing an emerge -vuen system, when approx. 120 Packages are to be 
   reemerged or updated, and the emerge process fails somewhere inbetween, what 
   option will resume the emerge without a restart from the beginning?

   I have tried the emerge option -n but it doesn't help, i.e. it gets ignored.

   I need an emerge option that somehow registers that the package has already  
   been reemerged and therefore doesn't need a third reemerging process.
   Does such an potion exist?

   The problem lately was that most emerge processes on my systems started to 
   fail somewhere in between and restart the emerge from the beginning after
   shipping around the error package(s).

   I don't have absolutely new hardware, mine is mostly quite old and takes a
   few day to compile, which is very time consuming, when reerged processes
   begin to fail with messages "force recompile with removal of the .compiled
   file" or similiar.

Thank you for your help in the past.


Werner M. Mayer
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2007-11-04 15:34:57 UTC
pam 0.78 is no more supported, please upgrade to pam 0.99.