Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 179971 - dev-lang/vala - the compiler for the GObject type system (new ebuild)
Summary: dev-lang/vala - the compiler for the GObject type system (new ebuild)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 2 votes (vote)
Assignee: Default Assignee for New Packages
URL: http://live.gnome.org/Vala
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2007-05-27 07:58 UTC by Zsombor G.
Modified: 2008-10-24 12:50 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
the ebuild for the 0.0.9 release (vala-0.0.9.ebuild,501 bytes, text/plain)
2007-05-27 07:58 UTC, Zsombor G.
Details
vala-0.1.2.ebuild (vala-0.1.2.ebuild,354 bytes, text/plain)
2007-08-10 19:48 UTC, Chris Mayo
Details
Vala 0.1.3 with vapigen use flag (vala-0.1.3.ebuild,501 bytes, text/plain)
2007-09-01 18:24 UTC, Jean-François Wauthy
Details
dev-lang/vala-0.1.6 (vala-0.1.6.ebuild,590 bytes, text/plain)
2008-01-27 14:01 UTC, Christoph Brill (egore) (RESIGNED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zsombor G. 2007-05-27 07:58:05 UTC
An ebuild for vala, whichis a new programming language that aims to bring modern programming language features to GNOME developers without imposing any additional runtime requirements and without using a different ABI compared to applications and libraries written in C.

Reproducible: Always
Comment 1 Zsombor G. 2007-05-27 07:58:45 UTC
Created attachment 120418 [details]
the ebuild for the 0.0.9 release
Comment 2 Chris Mayo 2007-08-10 19:48:42 UTC
Created attachment 127683 [details]
vala-0.1.2.ebuild

Latest version plus:
- Now hosted on gnome.org so use gnome2.eclass, a lot easier
- Couple of extra docs
- License is LGPL not GPL
Comment 3 Claes Mogren 2007-08-31 14:51:31 UTC
Vala 0.1.3 is out, this time with a lot of new bindings. Does this mean we need to add some use flags to the ebuild?
http://www.paldo.org/pipermail/vala/2007-August/000399.html

Btw, just renaming to vala-0.1.3.ebuild works just fine.
/C.M
Comment 4 Olivier Crete (RETIRED) gentoo-dev 2007-09-01 03:08:43 UTC
From what I understand, the bindings are pre-built, not compiled at build-time.. so they should all be installed (they are just small text files).

Also there is an optional dep on enchant that is use to run enchant tests... so it should probably be under the test use flag... or maybe ignored...
Comment 5 Olivier Crete (RETIRED) gentoo-dev 2007-09-01 03:19:27 UTC
Also, there should be a use flag for --enable-vapigen
Comment 6 Jean-François Wauthy 2007-09-01 18:24:46 UTC
Created attachment 129782 [details]
Vala 0.1.3 with vapigen use flag

I'm not an ebuild expert but here is the ebuild i put together. It supports a vapigen use flag for those who wants to build the API generation tools.
Comment 7 Claes Mogren 2007-10-10 06:08:41 UTC
Vala 0.1.4 is out: http://www.paldo.org/pipermail/vala/2007-October/000518.html

I renamed Jean-François' ebuild to vala-0.1.4.ebuild and compiled it with the vapigen use flag. Installed without a hitch.

(Getting some strange warnings from valac when compiling code with 0.1.4 that I didn't get with 0.1.3 and the dbustest.vala from the homepage doesn't work any more.)
Comment 8 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2007-12-03 16:36:14 UTC
0.1.5 built and ran fine with vala-0.1.3.ebuild
Comment 9 Christoph Brill (egore) (RESIGNED) 2008-01-27 14:01:01 UTC
Created attachment 141885 [details]
dev-lang/vala-0.1.6

Changes:
* Bumped to 0.1.6
* Add support for --enable-gen-project
* Drop XML-Twig dependency (was replaced by a C parser afaik)
Comment 10 Alexandre Rostovtsev (RETIRED) gentoo-dev 2008-02-04 22:39:38 UTC
vala is now in the sunrise overlay. You can get the latest version from
http://overlays.gentoo.org/svn/proj/sunrise/reviewed/dev-lang/vala/
Comment 11 Maciej Piechotka 2008-04-24 17:02:59 UTC
Without noticing the sunrise overlay I created my own(git://github.com/uzytkownik/vala-overlay.git).

Pros:
- dev-lang/vala-9999.ebuild
Cons:
- I don't know how the sunrise devs but I will not be able to check/add releases more then once-twice a day

Comment 12 Maciej Piechotka 2008-10-21 12:58:59 UTC
Sorry - merged with gnome overlay (git://github.com/uzytkownik/vala-overlay.git)
Comment 13 Rémi Cardona gentoo-dev 2008-10-21 13:16:24 UTC
I've actually been using vala 0.3.5 for a few weeks now. I think I'll be adding 0.4.0 (once I test it) to portage under the Gnome herd, if other herders agree of course :)

Thanks
Comment 14 Rémi Cardona gentoo-dev 2008-10-24 12:50:55 UTC
Done, vala is in tree and part of the Gnome herd, as there seems to be growing interest in it.

Closing :)