Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 179687 - hald and gnome-volume-manager respectively "cannot mount volume"
Summary: hald and gnome-volume-manager respectively "cannot mount volume"
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-24 21:43 UTC by Timo Meinen
Modified: 2007-08-28 21:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timo Meinen 2007-05-24 21:43:58 UTC
I want to let my usbsticks automounted, so I installed hald and gnome-volume-manager. When I attach a usbstick to my usb-port a message window appears declaring: "Cannot mount volume".

So, I found a tipp in a mailinglist:

editing /etc/dbus-1/system.d/hal.conf :

I changed <policy group="plugdev"> to <policy group="444"> (444 is the gid of plugdev-group). After restarting hald everything works fine.


Is this a bug?

Timo

Reproducible: Always

Steps to Reproduce:
1. Insert a mountable device



sys-apps/hal: 0.5.7.1-r5
gnome-base/gnome-volume-manager: 2.15.0-r1
Comment 1 Rémi Cardona gentoo-dev 2007-05-25 05:42:30 UTC
Do you have an ldap or NIS server? do you use nscd? did you edit /etc/ns* files?
Comment 2 Timo Meinen 2007-05-25 10:59:23 UTC
(In reply to comment #1)
> Do you have an ldap or NIS server? do you use nscd? did you edit /etc/ns*
> files?
> 

NO, I don't have a NIS and I don't have a LDAP server and I didn't edited any ns* files.

Just normal. ;-)

Timo
Comment 3 Doug Goldstein (RETIRED) gentoo-dev 2007-05-31 20:26:00 UTC
Seems like a dbus problem looking up the group.

Please provide the output of "id" as run as your user.
Comment 4 Doug Goldstein (RETIRED) gentoo-dev 2007-08-28 21:35:50 UTC
need info requested previously by me. Additionally emerge --info. Also, the version of HAL used it no longer supported since it's been superseded. Also, need dbus version.