Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 17964 - festival-1.4.2-r3 ebuild fails; it refuses to go any further than fetching files
Summary: festival-1.4.2-r3 ebuild fails; it refuses to go any further than fetching files
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Jeremy Huddleston (RETIRED)
Depends on:
Reported: 2003-03-21 18:33 UTC by Migrant Programmer
Modified: 2004-05-01 12:28 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---

Updated festival-1.4.2-r3 fixing that bug (festival-1.4.2-r4.ebuild,6.25 KB, text/plain)
2003-04-12 12:20 UTC, Thomas Preissler

Note You need to log in before you can comment on or make changes to this bug.
Description Migrant Programmer 2003-03-21 18:33:52 UTC
When I try to emerge festival, it downloads the proper tar.gz files but stops
after verifying md5 sums. Here are the error messages:

>>> emerge (1 of 1) media-sound/festival-1.4.2-r3 to /
/usr/sbin/ line 865:
/var/tmp/portage/festival-1.4.2-r3/work/speech_tools/eclass-debug.log: No such
file or directory

(MD5 checks work ok)

/usr/sbin/ line 865:
/var/tmp/portage/festival-1.4.2-r3/work/speech_tools/eclass-debug.log: No such
file or directory
/usr/sbin/ line 1171:
/var/tmp/portage/festival-1.4.2-r3/work/speech_tools/environment: No such file
or directory

Reproducible: Always
Steps to Reproduce:
1. emerge sync
2. emerge festival

Actual Results:  
Emerge gave the error messages detailed above and stopped.

Expected Results:  
Unpacked, compiled and installed festival.

There are two forum topics talking about this problem, since February:

emerge info:

Portage 2.0.47-r10 (default-x86-1.4, gcc-3.2.2, glibc-2.2.5-r2,2.3.1-r2)
System uname: 2.4.20-gaming-r1 i686 AMD Athlon(tm) Processor
"CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config
/usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config /usr/kde/3/share/config
CONFIG_PROTECT_MASK="/etc/init.d /etc/gnome /etc/gnome-vfs-2.0 /etc/ppp
/etc/sound /etc/X11/starthere /etc/gconf /etc/env.d"
USE="x86 oss 3dnow apm avi crypt encode gif jpeg libg++ mikmod mmx mpeg ncurses
nls pdflib png quicktime spell truetype xml2 xmms xv zlib gdbm slang readline
arts java X sdl tcpd pam libwww ssl python imlib oggvorbis gnome gtk qt kde motif
opengl gphoto2 alsa -berkdb bonobo -cups dga dvd esd -gpm gtk2 gtkhtml guile
mozilla perl svga tcltk tetex"
CFLAGS="-march=athlon-tbird -O3 -pipe -fomit-frame-pointer"
CXXFLAGS="-O2 -mcpu=i686 -pipe"
FEATURES="sandbox ccache"
Comment 1 Migrant Programmer 2003-04-02 12:51:34 UTC
Ok, I tried manually unpacking things and compiling it. I couldn't get it to compile with GCC 3.2.2, even after applying all the patches in the ebuild. I managed to get it to compile with GCC 2.95.3, and faked the install manually, then did an ebuild qmerge to get it "merged." The program works fine as installed, it just took quite a bit more extra work than I'm used to with Portage!
Comment 2 Abhishek Amit (RETIRED) gentoo-dev 2003-04-10 01:53:04 UTC
I have the same problem. I too am running -r10 wih gcc-3.2.2.
Emerge info:
Portage 2.0.47-r10 (default-x86-1.4, gcc-3.2.2, glibc-2.3.1-r2)
System uname: 2.4.20-gentoo-r2 i586 AMD-K6(tm) 3D processor
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config /usr/kde/2/share/config /usr/kde/3/share/config /var/bind:/usr/X11R6/lib/X11/xkb:/opt/jakarta/tomcat/conf:/usr/kde/cvs/share/config:/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/:/usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 oss 3dnow apm avi crypt cups encode gif jpeg kde libg++ mmx mpeg ncurses nls pdflib png quicktime spell truetype xml2 zlib alsa gdbm readline arts svga tcltk java guile X sdl gpm tcpd pam ssl python imlib oggvorbis qt motif opengl cdr aalib -berkdb bonobo esd evo -gnome -gtk junit -libwww maildir -mikmod mysql odbc pda perl samba -slang tetex -xmms -xv"
CFLAGS="-march=k6 -O3 -pipe"
CXXFLAGS="-march=k6 -O3 -pipe"
FEATURES="sandbox ccache"
Comment 3 Thomas Preissler 2003-04-12 12:20:34 UTC
Created attachment 10563 [details]
Updated festival-1.4.2-r3 fixing that bug
Comment 4 Thomas Preissler 2003-04-12 12:22:38 UTC
I am just compiling festival. I had the same errors as described here. And it looks now that it compiles properly. Have phun!
Comment 5 Axxackall 2003-05-02 18:08:51 UTC
r4 doesn't help in my case and I have exactly the same errors as with r3
Comment 6 Axxackall 2003-05-02 20:22:53 UTC
I am not sure but this fix doen't fix anything, IMHO:
# diff festival-1.4.2-r3.ebuild  festival-1.4.2-r4.ebuild
< S=${WORKDIR}/${PN}
< T=${WORKDIR}/speech_tools
> S="${WORKDIR}/${PN}"
> #T="${WORKDIR}/speech_tools"
> T="${WORKDIR}/speech_tools"
Comment 7 Richard Freeman gentoo-dev 2003-05-02 23:27:35 UTC
I also tried the patch (having the problems described here with the version in protage).  The revised ebuild gives the same errors as before.
Comment 8 Kasper Souren 2003-05-11 13:11:35 UTC
festival still doesn't merge on my box, even with 1.4.2-r3. 
This is where it stops: 
/usr/sbin/ line 865: 
/var/tmp/portage/festival-1.4.2-r3/work/speech_tools/eclass-debug.log: No such file or 
/usr/sbin/ line 1171: 
/var/tmp/portage/festival-1.4.2-r3/work/speech_tools/environment: No such file or 
Comment 9 Paul Giordano 2003-05-31 22:17:03 UTC
Main problem is that the "T" variable is assigned right away to a path that does not exist. By definition, ${T} is the package defined temporary directory - and because it doesn't exist, the ebuild fails. Since the ebuild sets the variable before any code in the ebuild can create the temp dir, the build fails when debug initialization resolves.

So, first shot is change the T= to S2= and the ${T} to ${S2} everywhere.

Of course, with the changes in gcc 3.2.2+, the compile is "butt ugly", but it does compile.

I'll be opening a new bug for an ebuild of festival 1.4.3 tonight or tomorrow morning - the compile's cleaner, but I need to patch it to handle shared libs and gcc 3.2.3.
Comment 10 Paul Giordano 2003-05-31 22:49:03 UTC
OK, ugly as it is, that emerge ran under gcc 3.2.3 with the changes I outlined, saytime works, but the echo to festival --tts fails, looks like the emerge doesn't catch all of the libraries. I'll fix that in 1.4.3 too.
Comment 11 Paul Giordano 2003-06-01 12:21:50 UTC
See bug 22053 for a fix that addresses this.
Comment 12 Andrew Cooks (RETIRED) gentoo-dev 2003-11-30 00:15:53 UTC
This bug has been inactive for more than 180 days.

There's been no updates to the festival ebuild in months (1.4.2-r3). There are definite problems with the latest unmasked ebuild. It should be masked and/or updated.

The latest stable release, 1.4.3, was released in January 2003 and claims to have "new compiler support".

Can someone look into this?
Comment 13 Decibels 2004-02-13 08:45:26 UTC
Same errors are happening now when try to emerge it or unmerge it. 

bash-2.05b# emerge -Cv festival

    selected: 1.4.2-r3 1.4.3
   protected: none
     omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging media-sound/festival-1.4.2-r3...
No package files given... Grabbing a set.
/usr/sbin/ line 1030: /var/tmp/portage/festival-1.4.2-r3/work/speech_tools/eclass-debug.log: No such file or directory
/usr/sbin/ line 1432: /var/tmp/portage/festival-1.4.2-r3/work/speech_tools/environment: No such file or directory
!!! FAILED prerm: 1
Comment 14 Decibels 2004-02-13 09:33:16 UTC
Also, it is trying to unmerge festival and failing the same way whenever emerge anything. For instance, just found out that gconfd-1 had to be upgraded to masked package gconf-1.0.9.ebuild because gnucash wouldn't start due to gconfd-2 running and gconfd-1 not running. So emerged it and when removing the previous gconfd-1 files it finished and started trying to still remove festival. Of course which fails.
Comment 15 Decibels 2004-02-13 14:01:37 UTC
Seem to have gotten rid of it by renaming the 1.4.2-r3 ebuild to 1.4.3 and emerging it. Then unmerged it and not getting the error anymore.
Comment 16 tar 2004-02-24 15:32:53 UTC
Not to contribute to anyone's email overload, but I'm having the same problem as
It's pretty annoying.  I've tried copying the 1.4.3 ebuild over the 1.4.2-r3,
vice versa, nothing works.  I continue to get

>>> Unmerging media-sound/festival-1.4.2-r3...
No package files given... Grabbing a set.
/usr/sbin/ line 1030: /var/tmp/portage/festival-1.4.2-r3/work/speech_tools/eclass-debug.log: No such file or directory
/usr/sbin/ line 1432: /var/tmp/portage/festival-1.4.2-r3/work/speech_tools/environment: No such file or directory
!!! FAILED prerm: 1

I get this EVERY TIME I emerge a package (because I have AUTOCLEAN enabled).
Comment 17 Brandon Hale (RETIRED) gentoo-dev 2004-03-09 06:32:51 UTC
Abhishek, is this still an issue in the latest version?
Comment 18 Decibels 2004-03-09 15:25:09 UTC
Tim, didn't copy it over. Renamed 1.4.3 with an extension like  .bak . Then renamed the 1.4.2-r3 to 1.4.3 (left 1.4.2-r3 as is except for the name. Temp renamed original 1.4.3 ebuild to get it out of the way).

Emerge and unmerged the 'new' 1.4.3 . Then renamed them back the way they were orignially.
Comment 19 Jeremy Huddleston (RETIRED) gentoo-dev 2004-03-12 22:45:39 UTC
Is this still an issue?  Please try festival-1.4.3-r1
Comment 20 Jeremy Huddleston (RETIRED) gentoo-dev 2004-03-13 01:30:53 UTC
cleanup your /var/tmp/portage space (rm -rf /var/tmp/portage/festival*) if you're having unmerge problems like that...
Comment 21 Jeremy Huddleston (RETIRED) gentoo-dev 2004-03-17 23:38:29 UTC
no response... assuming it is fixed in the newer ebuild.