Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 179021 - net-im/pidgin-2.0 sometimes blocks all my ICQ contacts when starts
Summary: net-im/pidgin-2.0 sometimes blocks all my ICQ contacts when starts
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-18 16:21 UTC by Martin Dratva
Modified: 2007-08-22 03:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Dratva 2007-05-18 16:21:15 UTC
I have not been able to find out why and when exactly does this occur.When I start Pidgin 2.0 it shows red squares next to my ICQ (not on MSN) contacts. That means, they are blocked. I can manually one by one unblock them. When doing so, I get this message:

Unable to Add
Could not add the buddy 321383426 for an unknown reason. The most commmon reason for this is that you have the maximum number of allowed buddies in your buddy list.

I have 39 ICQ contacts and 2 MSN contacts in my buddy list.

Restarting Pidgin does not help.


Reproducible: Sometimes





Portage 2.1.2.7 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r2, 2.6.21-sabayon i686)
=================================================================
System uname: 2.6.21-sabayon i686 AMD Athlon(tm) XP 1600+
Gentoo Base System release 1.12.10
Timestamp of tree: Fri, 18 May 2007 15:30:01 +0000
dev-java/java-config: 1.3.7, 2.0.32
dev-lang/python:     2.4.4-r2
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -mno-tls-direct-seg-refs -mmmx -m32 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/share/config/kdm/ /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -mno-tls-direct-seg-refs -mmmx -m32 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -s"
LINGUAS="en sk cs"
MAKEOPTS="-j2 -s "
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/einit /usr/portage/local/layman/sabayon"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dfx 7Zip X a52 aac aalib acl acpi ada aiglx alsa amarok apache2 arts artswrappersuid asf audiofile avahi beagle berkdb bidi bitmap-fonts bluetooth bzip2 cairo cdda cdr chm cjk clearcase cli commercial config_wizard cpudetection cracklib crypt css cups dbox2 dbus dga djvu dlloader dri dts dv dvb dvd dvdr dvdread dvi dxr3 eds effects emboss encode esd evo exscalibar ext-man ext-rtf ext-tex extraicons extramodules fam fame fat ffmpeg fftw firefox flac flash foomatic-db fortran freetype gcj gdbm gif gimpprint glitz gnokii gnutls gphoto2 gpm gs gsm gstreamer hal hfs iconv icq imap inkjar ipv6 irc isdnlog ivtv jack java jfs jingle jpeg kde kdeenablefinal kdehiddenvisibility kerberos kipi kqemu krb4 lame lcd libao libcaca libclamav libg++ libnotify live lj lm_sensors logitech-mouse lzo mad mail matroska midi mikmod mjpeg mmx mng mono moznocompose moznoirc moznomail moznopango mp3 mp3rtp mpeg msn musepack musicbrainz mysql mythtv ncurses network new-login nls nptl nptlonly nsplugin ntfs nvidia ogg ole openal opengl pam pam_console pascal pcmcia pcre pda pdf perl php plugin png postgres povray ppds pppd pulseaudio pwdb python qt qt3 qt3support qt4 quicktime quotas rar rdesktop readline real reflection reiser4 reiserfs rss ruby sdl session skins slp sms sndfile speech speex spell spl spreadsheet sql ssl startup-notification stream streams subversion svg switch_all_desktops symlink sysfs tcpd theora tiff truetype truetype-fonts type1-fonts udev unicode usb v4l v4l2 vcd visualization voice vorbis webservices win32codecs winbind wmf wxwindows x264 x86 xfs xine xinerama xml xorg xosd xpm xprint xscreensaver xsl xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse digitaledge vmmouse void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en sk cs" USERLAND="GNU" VIDEO_CARDS="nv nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Olivier Crete (RETIRED) gentoo-dev 2007-05-26 19:53:51 UTC
Can you try 2.0.1 and see if it happens again?
Comment 2 Martin Dratva 2007-05-27 11:34:45 UTC
I was not able to run version 2.0.1. It is kind of strange, as it compiled successfuly, but I was not able to start the program. I had the Pidgin entry in KDE menu, but withou icon. When clicked, nothing happened. I tried to run pidgin from command line, but without success. It looks like it was missing in my system. Could it be a problem with emuild ?
Comment 3 Martin Dratva 2007-06-02 09:23:04 UTC
I was finally able to emerge version 2.0.1. The problem persisted.
Comment 4 Olivier Crete (RETIRED) gentoo-dev 2007-06-02 09:32:07 UTC
Did you try backuping/deleting the .gaim directory to see if it works in this case? Otherwise, please report upstream.
Comment 5 Martin Dratva 2007-06-02 14:12:51 UTC
I fiddled a bit more with it and foud out, that for some reason I had privacy set to block everyone. When unchecked, everything seems to be working as it should. What I don't understand is, how did this happened as I did not set it myself I'm sure... And this happened only sometimes, not always in the beginning. Later it happened all the time. I think it can be closed for now as solved and I keep an eye on this if it somehow sets itsef on/off. 
Comment 6 Martin Dratva 2007-06-12 21:10:06 UTC
I have been using Pidgin for a while now and been checking its behaviour and I believe this bug needs to be reopened. For some reason, Pidgin sets its privacy settings to 'Allow only users below' instead of 'Allow all users to contact me' and thus blocks every contact.
I have not been able to find out what triggers this.
Comment 7 Kim Pedersen 2007-06-15 20:33:13 UTC
In any case, does this not seem like an upstream bug. And have you tried 2.0.2. I have compiled and use it without problems
Comment 8 Martin Dratva 2007-06-24 22:18:58 UTC
This problem persisted also in 2.0.2. I filled a bug report on Pidgin web.
Comment 9 Olivier Crete (RETIRED) gentoo-dev 2007-08-22 03:08:57 UTC
This is definitely an upstream bug... I hope its fixed in 2.1.1 .. otherwise complain upstream