Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 177970 - net-print/cnijfilter-2.70 - Canon pixma/pixus drivers (new ebuild)
Summary: net-print/cnijfilter-2.70 - Canon pixma/pixus drivers (new ebuild)
Status: VERIFIED DUPLICATE of bug 130645
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2007-05-10 21:26 UTC by Colin Kiegel
Modified: 2017-09-26 17:40 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
net-print/cnijfilter/cnijfilter-2.70.ebuild (cnijfilter-2.70.ebuild,6.87 KB, text/plain)
2007-05-10 21:28 UTC, Colin Kiegel
Details
net-print/cnijfilter/cnijfilter-2.70-r1.ebuild (cnijfilter-2.70-r1.ebuild,7.00 KB, text/plain)
2008-12-30 05:40 UTC, Łukasz Sowiński
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Kiegel 2007-05-10 21:26:36 UTC
These drivers are designed for Canon ip1800 ip2500 ip3300 ip4300 ip90 mp160 mp510 mp600.

You can choose which driver to install by useflag. Also you can choose whether
to compile some simple GTK+-1.2 based Maintenance Tools for cleaning nozzles,
aligning the printhead, and other things.

It's almost completely compiled from GPL2-source except for some proprietary
binary libraries.

cnijtools are currently available only on ~x86, but the basic drivers without
these maintenance tools are also available for ~amd64 (as 32-bit version using
some emul-linux-.. packages).

net-print/cnijfilter-2.70 is a successor of net-print/cnijfilter-2.70 (#130645) and net-print/bjfilter-2.50 (bug
#128560). For ~amd64 it depends on app-emulation/emul-linux-x86-bjdeps-0.1
(bug #129352).

It DOES NOT make the previous cnifilter and bjfilter ebuilds obsolete, but just adds a new range of supported printers.

Reproducible: Always
Comment 1 Colin Kiegel 2007-05-10 21:28:12 UTC
Created attachment 118804 [details]
net-print/cnijfilter/cnijfilter-2.70.ebuild
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-05-10 22:07:59 UTC
Please, continue in the pending bug.

*** This bug has been marked as a duplicate of bug 130645 ***
Comment 3 Vitali Kari 2008-02-11 15:23:32 UTC
(In reply to comment #2)
> Please, continue in the pending bug.
> 
> *** This bug has been marked as a duplicate of bug 130645 ***
> 
i think the bug 130645 is for anoter printer model's
Comment 4 Vitali Kari 2008-02-11 15:25:08 UTC
(In reply to comment #2)
> Please, continue in the pending bug.
> 
> *** This bug has been marked as a duplicate of bug 130645 ***
>
No. isn't.
Please REOPEN this Bug!
Comment 5 Vitali Kari 2008-02-11 15:30:45 UTC
I get the following error, any suggestions?
-----------------------------------------------  

make  all-recursive
make[1]: Entering directory `/var/tmp/portage/net-print/cnijfilter-2.70/work/cnijfilter-2.70/mp600/cnijfilter'
Making all in src
make[2]: Entering directory `/var/tmp/portage/net-print/cnijfilter-2.70/work/cnijfilter-2.70/mp600/cnijfilter/src'
gcc -DHAVE_CONFIG_H -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT bjferror.o -MD -MP -MF .deps/bjferror.Tpo -c -o bjferror.o bjferror.c
mv -f .deps/bjferror.Tpo .deps/bjferror.Po
gcc -DHAVE_CONFIG_H -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT bjfilter.o -MD -MP -MF .deps/bjfilter.Tpo -c -o bjfilter.o bjfilter.c
mv -f .deps/bjfilter.Tpo .deps/bjfilter.Po
gcc -DHAVE_CONFIG_H -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT bjfimage.o -MD -MP -MF .deps/bjfimage.Tpo -c -o bjfimage.o bjfimage.c
mv -f .deps/bjfimage.Tpo .deps/bjfimage.Po
gcc -DHAVE_CONFIG_H -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT bjfoption.o -MD -MP -MF .deps/bjfoption.Tpo -c -o bjfoption.o bjfoption.c
bjfoption.c: In Funktion »SetCmdOption«:
bjfoption.c:548: Warnung: Übergabe des Arguments 3 von »poptGetContext« von inkompatiblem Zeigertyp
mv -f .deps/bjfoption.Tpo .deps/bjfoption.Po
gcc -DHAVE_CONFIG_H -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT bjfpos.o -MD -MP -MF .deps/bjfpos.Tpo -c -o bjfpos.o bjfpos.c
mv -f .deps/bjfpos.Tpo .deps/bjfpos.Po
gcc -DHAVE_CONFIG_H -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT bjfrcaccess.o -MD -MP -MF .deps/bjfrcaccess.Tpo -c -o bjfrcaccess.o bjfrcaccess.c
mv -f .deps/bjfrcaccess.Tpo .deps/bjfrcaccess.Po
gcc -DHAVE_CONFIG_H -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT getipc.o -MD -MP -MF .deps/getipc.Tpo -c -o getipc.o getipc.c
getipc.c: In Funktion »GetIPCData«:
getipc.c:67: Warnung: Übergabe des Arguments 3 von »accept« von inkompatiblem Zeigertyp
mv -f .deps/getipc.Tpo .deps/getipc.Po
gcc -DHAVE_CONFIG_H -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT bjflist.o -MD -MP -MF .deps/bjflist.Tpo -c -o bjflist.o bjflist.c
mv -f .deps/bjflist.Tpo .deps/bjflist.Po
gcc  -O2 -L../../295/libs_bin  -o cif bjferror.o bjfilter.o bjfimage.o bjfoption.o bjfpos.o bjfrcaccess.o getipc.o bjflist.o -lcnbpcmcm295 -lcnbpess295 -lm -ldl -ltiff -lpng -lcnbpcnclapi295 -lcnbpcnclbjcmd295 -lcnbpcnclui295 -lpopt 
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible ../../295/libs_bin/libcnbpcmcm295.so when searching for -lcnbpcmcm295
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lcnbpcmcm295
collect2: ld gab 1 als Ende-Status zurück
make[2]: *** [cif] Fehler 1
make[2]: Leaving directory `/var/tmp/portage/net-print/cnijfilter-2.70/work/cnijfilter-2.70/mp600/cnijfilter/src'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/var/tmp/portage/net-print/cnijfilter-2.70/work/cnijfilter-2.70/mp600/cnijfilter'
make: *** [all] Fehler 2
  [31;01m* [0m 
  [31;01m* [0m ERROR: net-print/cnijfilter-2.70 failed.
  [31;01m* [0m Call stack:
  [31;01m* [0m                ebuild.sh, line 1701:  Called dyn_compile
  [31;01m* [0m                ebuild.sh, line 1039:  Called qa_call 'src_compile'
  [31;01m* [0m                ebuild.sh, line   44:  Called src_compile
  [31;01m* [0m   cnijfilter-2.70.ebuild, line  147:  Called src_compile_pr
  [31;01m* [0m   cnijfilter-2.70.ebuild, line  218:  Called die
  [31;01m* [0m The specific snippet of code:
  [31;01m* [0m   	make || die "Couldn't make ${_pr}/cnijfilter"
  [31;01m* [0m  The die message:
  [31;01m* [0m   Couldn't make mp600/cnijfilter
  [31;01m* [0m 
  [31;01m* [0m If you need support, post the topmost build error, and the call stack if relevant.
  [31;01m* [0m A complete build log is located at '/var/tmp/portage/net-print/cnijfilter-2.70/temp/build.log'.
  [31;01m* [0m This ebuild is from an overlay: '/usr/local/portage/'
  [31;01m* [0m 
---------------------------------------------

Comment 6 Łukasz Sowiński 2008-12-30 05:39:37 UTC
1. There is no way, this can be a duplicate of 130645. As far as I know, 2.60 and 2.70 support different printer models. Can a "sufficiently empowered user" change this, please?

2. At some point Cannon released newer version of these drivers (2.70-2). To make things more complicated, sources for 2.70-1 are nowhere to find.

3. I have modified the original ebuild to handle 2.70-2 and a fetch restriction. No big deal. All credits goes to the author of the original ebuild. Tested it for ip4300 on x86.
Comment 7 Łukasz Sowiński 2008-12-30 05:40:51 UTC
Created attachment 176838 [details]
net-print/cnijfilter/cnijfilter-2.70-r1.ebuild
Comment 8 gentoo 2017-09-26 17:40:35 UTC
If you are still interested in the 2.70 version, please request again the package for your printer series as explained in https://wiki.gentoo.org/wiki/Canon_Pixma_Printer. This way to sort between "no more needed" / "still needed" ones, and to avoid wasting time on obsolete / unused series.