Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 177697 - apache-2.2.4 now calls apxs2 just apxs - and does not create a symlink
Summary: apache-2.2.4 now calls apxs2 just apxs - and does not create a symlink
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: Highest major (vote)
Assignee: Apache Team - Bugzilla Reports
URL:
Whiteboard:
Keywords:
: 177710 177759 177768 177791 177808 177809 177811 177824 177870 178801 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-05-08 19:03 UTC by Dan A. Dickey
Modified: 2010-07-27 13:38 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan A. Dickey 2007-05-08 19:03:12 UTC
The apache before 2.2.4 provided an apxs2, which many things use.
Apache 2.2.4 just provides apxs, and does not create a symlink.
Quite a few things are trying to use apxs2 (apache-module.eclass),
and are not finding it.  They are then complaining that apache was
not installed with an MPM selected.
Something needs to be done soon.
Either 2.2.4 needs to provide a symlink to apxs, or the things
using apxs2 need to be modified to use apxs.  Probably both.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-05-08 20:10:49 UTC
*** Bug 177710 has been marked as a duplicate of this bug. ***
Comment 2 Jesús Guerrero Botella (RETIRED) gentoo-dev 2007-05-08 22:38:09 UTC
¿Is there any known workaround for this yet?

-- Jesús Guerrero
Comment 3 Tobias Minich 2007-05-08 22:57:37 UTC
(In reply to comment #2)
> ¿Is there any known workaround for this yet?
> 
> -- Jesús Guerrero
> 

ln -s /usr/sbin/apxs /usr/sbin/apxs2
Comment 4 Jesús Guerrero Botella (RETIRED) gentoo-dev 2007-05-08 23:29:29 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > ¿Is there any known workaround for this yet?
> > 
> > -- Jesús Guerrero
> > 
> 
> ln -s /usr/sbin/apxs /usr/sbin/apxs2
> 
Thanks so much.

Comment 5 Nathan Sullivan 2007-05-09 10:17:32 UTC
*** Bug 177759 has been marked as a duplicate of this bug. ***
Comment 6 Nathan Sullivan 2007-05-09 10:17:56 UTC
you guys might wanna take a look at 177759 for my suggestions there :P
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-05-09 11:03:21 UTC
*** Bug 177768 has been marked as a duplicate of this bug. ***
Comment 8 Bryan Østergaard (RETIRED) gentoo-dev 2007-05-09 12:56:34 UTC
I've added symlinks for all the commands that used to be called *2 in apache-2.2.4-r1 and apache-tools-2.2.4-r1. In time we'll go through eclasses and ebuilds and fix them to use the proper names but for now symlinks seems to be the best solution.
Comment 9 Samuli Suominen (RETIRED) gentoo-dev 2007-05-09 13:50:26 UTC
*** Bug 177791 has been marked as a duplicate of this bug. ***
Comment 10 Bryan Østergaard (RETIRED) gentoo-dev 2007-05-09 15:13:26 UTC
*** Bug 177808 has been marked as a duplicate of this bug. ***
Comment 11 Bryan Østergaard (RETIRED) gentoo-dev 2007-05-09 15:13:34 UTC
*** Bug 177809 has been marked as a duplicate of this bug. ***
Comment 12 Bryan Østergaard (RETIRED) gentoo-dev 2007-05-09 15:14:20 UTC
*** Bug 177811 has been marked as a duplicate of this bug. ***
Comment 13 Samuli Suominen (RETIRED) gentoo-dev 2007-05-09 16:29:32 UTC
*** Bug 177824 has been marked as a duplicate of this bug. ***
Comment 14 Christoph Mende (RETIRED) gentoo-dev 2007-05-09 22:15:16 UTC
*** Bug 177870 has been marked as a duplicate of this bug. ***
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2007-05-16 19:59:36 UTC
*** Bug 178801 has been marked as a duplicate of this bug. ***
Comment 16 Renato Caldas 2007-05-27 13:30:43 UTC
Now apache-2.2.4-r3 doesn't provide apxs at all. I'm not sure if the bug should be reopened or another one created..
Comment 17 Renato Caldas 2007-05-27 13:53:32 UTC
It does provide it, it's in the "support" directory.

But it needs to be installed manually and chmod'ed to be executable. Please update the apache ebuild..
Comment 18 Renato Caldas 2007-05-27 14:07:34 UTC
I've compiled apache by hand without any ./configure options and it does compile and install apxs. So there's something wrong with the 2.2.4-r3 ebuild..
Comment 19 Renato Caldas 2007-05-28 10:03:37 UTC
Fixed in apache-2.2.4-r4.