Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 177209 - stabilize dev-ruby/rails-1.2.3-r1
Summary: stabilize dev-ruby/rails-1.2.3-r1
Status: RESOLVED DUPLICATE of bug 195315
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 156092 181322
Blocks:
  Show dependency tree
 
Reported: 2007-05-05 17:23 UTC by Láďa Durchánek
Modified: 2007-10-16 06:13 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Láďa Durchánek 2007-05-05 17:23:43 UTC
What about stabilizing current version of Rails? Has been in tree for almost two months. I am using 1.2 (1.2.2 and then 1.2.3) branch on both amd64 (Mongrel) and x86 (FastCGI) without any problem.

Required dependencies should be:
>=dev-ruby/rake-0.7.2
=dev-ruby/actionwebservice-1.2.3
=dev-ruby/actionpack-1.13.3
=dev-ruby/activesupport-1.4.2
>=dev-ruby/rubygems-0.9.0
=dev-ruby/activerecord-1.15.3
=dev-ruby/actionmailer-1.3.3

Reproducible: Always
Comment 1 Hans de Graaff gentoo-dev 2007-05-05 19:34:20 UTC
Sounds like a good idea to me, but I think it would be a good idea to keep rails-1.1.6 in the tree for a while longer for those people (like me) that still have production services running on 1.1.6. As it's slotted that should matter for stabilizing rails-1.2.3. 

Stabilizing rake-0.7.2 should not be a problem given time and lack of open bugs.

rubygems is a bit more fickle and we only just unmased 0.9.2, so I propose to stabilize rubygems 0.9.0-r2 instead. However, I'm not sure if that version is actually problem-free. Nguyễn, perhaps you have beter insight in this?
Comment 2 Láďa Durchánek 2007-05-05 19:52:26 UTC
Of course, this should be mainly for everyone who wants to use all nice features of 1.2. Keeping 1.1.6 is a good thing.
I am using 1.2.3 with rubygems-0.9.0-r2, works great also with other gems (mongrel, ruby-gettext etc.). Hope this helps :-)
Comment 3 Hans de Graaff gentoo-dev 2007-05-12 18:53:27 UTC
It looks like the rubygems dependency is missing from the current rails-1.2.3 
ebuild, but the changelog for Rails clearly states that it is mandatory. 

This also means that rails can't go stable until rubygems-0.9.0-r2 has been 
marked stable.
Comment 4 Láďa Durchánek 2007-05-12 22:01:46 UTC
activesupport-1.4.2 depends on >=rubygems-0.9.0 maybe it is inough in this way?
Comment 5 Hans de Graaff gentoo-dev 2007-05-13 15:17:53 UTC
The dependency for activesupport will at least ensure that rails-1.2.3 is not stabilized prematurely, but according to the changelog rails-1.2.2 and higher also depend on rubygems-0.9.0 or better, so this should be fixed at some point.
Comment 6 Hans de Graaff gentoo-dev 2007-07-21 19:50:18 UTC
Add the rubygems 0.9.x bug 181322 as a dependency. Once this bug is resolved for all the arches I see no reason not to stabilize rails 1.2.3.
Comment 7 Josh Nichols (RETIRED) gentoo-dev 2007-07-23 17:35:19 UTC
(In reply to comment #6)
> Add the rubygems 0.9.x bug 181322 as a dependency. Once this bug is resolved
> for all the arches I see no reason not to stabilize rails 1.2.3.
> 

We still need to address the file collision with rails-1.1.x, ie bug 156092.
Comment 8 Hans de Graaff gentoo-dev 2007-07-23 17:58:16 UTC
Did you or someone else already test the rails eselect module I attached to that bug?
Comment 9 Josh Nichols (RETIRED) gentoo-dev 2007-09-01 13:40:48 UTC
1.2.3-r1 addresses the file collision issue, so now we need to wait 30 days before stabilizing. We should also do 1.1.6-r2 at that time as well.
Comment 10 Josh Nichols (RETIRED) gentoo-dev 2007-10-05 18:16:12 UTC
It's been a bit over a month since we did -r1, and there hasn't been any issues.

We should be good to stabilize now.
Comment 11 Friedrich Oslage (RETIRED) gentoo-dev 2007-10-05 20:25:06 UTC
Tested dev-ruby/rails-1.2.3-r1 USE="doc fastcgi mysql -postgres sqlite sqlite3" on sparc.

Using integrated webrick and www-servers/mongrel-1.0.1, sqlite db, sqlite3 db and mysql db.
Everything works fine.

Required dependencies are(all still testing):
=dev-ruby/activesupport-1.4.2
=dev-ruby/actionpack-1.13.3
=dev-ruby/actionwebservice-1.2.3
=dev-ruby/activerecord-1.15.3
=app-admin/eselect-rails-0.10
=dev-ruby/actionmailer-1.3.3

# emerge --info
Portage 2.1.3.9 (default-linux/sparc/sparc64/2007.0, gcc-4.1.2, glibc-2.5-r4, 2.6.22-gentoo-l7-r5 sparc64)
=================================================================
System uname: 2.6.22-gentoo-l7-r5 sparc64 sun4u
Timestamp of tree: Fri, 05 Oct 2007 02:50:01 +0000
app-shells/bash:     3.2_p17
dev-lang/python:     2.4.4-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="sparc"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-mcpu=ultrasparc -mtune=ultrasparc -O2 -pipe"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-mcpu=ultrasparc -mtune=ultrasparc -O2 -pipe"
DISTDIR="/tmp/distfiles"
FEATURES="collision-protect distlocks metadata-transfer parallel-fetch sandbox strict test userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://mirror.muntinternet.net/pub/gentoo/ http://gentoo.ynet.sk/pub"
LANG="en_US.UTF-8"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="64bit 7zip a52 ace adns alsa amr berkdb big-tables bzip2 caps cgi chroot clamav clamd cli clock-screen courier crypt ctype custom-cflags cvs divx dnsdb doc dvd dynamic elf examples exim exiscan exiscan-acl extensions extraengine fast fastcgi fat flac gd ggi gif gzip hacking hddtemp highlight hpn httpd image imagemagick imap ipv6 ithreads jpeg jpeg2k key-screen l7filter lighttpd live logrotate maildir max-idx-128 mouse mp3 mp4live mpeg multiuser mysql mysqli ncurses net netserver network network-cron networking nls nonfsv4 noudev nowin nptl nptlonly ogg pcre php png posix raw-mode readline rtsp sasl screen scsi search-screen server session snmp spamassassin sparc spf ssl stream subversion suhosin svn-mirror symlink syslog szip test threads threadsafe threadsonly tiff unicode utf8 vcd vidix vim vim-syntax vnc vorbis web x264 xml xvid zip zlib" ALSA_CARDS="CS4231" ALSA_PCM_PLUGINS="adpcm alaw copy dshare dsnoop extplug file hooks ladspa lfloat linear meter mulaw multi null rate route share shm" ELIBC="glibc" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="sunffb"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 12 Ferris McCormick (RETIRED) gentoo-dev 2007-10-05 21:41:29 UTC
AS Friedrich noted this also requires version bumps (or stabilization at least) for:
activesupport-1.4.2
actionpack-1.13.3
activerecord-1.15.3
activewebservice-1.2.3
actionmailer-1.3.3
>=rake-0.7.2
eselect-rails

With that, sparc stable.  Thanks, Friedrich.
Comment 13 Tobias Scherbaum (RETIRED) gentoo-dev 2007-10-06 14:11:56 UTC
ppc stable
Comment 14 Christian Faulhammer (RETIRED) gentoo-dev 2007-10-06 22:32:56 UTC
x86 stable
Comment 15 Christian Faulhammer (RETIRED) gentoo-dev 2007-10-16 06:01:32 UTC
*** Bug 195315 has been marked as a duplicate of this bug. ***
Comment 16 Christian Faulhammer (RETIRED) gentoo-dev 2007-10-16 06:13:33 UTC

*** This bug has been marked as a duplicate of bug 195315 ***