Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 176794 - kino/dvgrab or libdv do not capture from dvcam/ieee1394: AVC status error
Summary: kino/dvgrab or libdv do not capture from dvcam/ieee1394: AVC status error
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-02 11:45 UTC by simon
Modified: 2007-05-20 09:52 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (kino-bug.txt,3.00 KB, text/plain)
2007-05-02 11:48 UTC, simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description simon 2007-05-02 11:45:22 UTC
Kino 1.0.0 has problems with capturing from my DVCam. Cam is a Canon MV930,
raw1394 is loaded, /dev/raw1394 exists and has correct permission, user is in group "video".

In fact, the cam is recognized by Kino (Edit > Prefs > ieee1394), but capturing does not work, nor do the control buttons work with the cam.

When I start Kino from the console, it gives me the following:
# kino
> help language code en
> Kino Common being built
> Creating page editor
> Creating Capture Page
> Creating Export Page
> Creating Export1394 Page
> Creating ExportAVI Page
> Creating ExportStills Page
> Creating ExportAudio Page
> Creating ExportMJPEG Page
/usr/share/kino/scripts/dvdauthor/dvdauthor-k3b.sh
/usr/share/kino/scripts/dvdauthor/dvdauthor.sh
/usr/share/kino/scripts/dvdauthor/growisofs.sh
/usr/share/kino/scripts/dvdauthor/qdvdauthor.sh
which: no qdvdauthor in (/usr/kde/3.5/bin:/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/powerpc-unknown-linux-gnu/gcc-bin/4.1.1:/opt/ibm-jdk-bin-1.4.2.6/bin:/opt/ibm-jdk-bin-1.4.2.6/jre/bin:/usr/kde/3.5/bin:/usr/qt/3/bin)
/usr/share/kino/scripts/dvdauthor/none.sh
> Initializing MJPEG Export Page settings from Preferences
> Creating ExportPipe Page
/usr/share/kino/scripts/exports/ffmpeg_dvd_dual.sh
/usr/share/kino/scripts/exports/extract_chapters
/usr/share/kino/scripts/exports/rawplay.sh
/usr/share/kino/scripts/exports/ffmpeg_divx_dual.sh
/usr/share/kino/scripts/exports/ffmpeg_dvd.sh
/usr/share/kino/scripts/exports/ffmpeg_flv.sh
/usr/share/kino/scripts/exports/ffmpeg2theora.sh
which: no ffmpeg2theora in (/usr/kde/3.5/bin:/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/powerpc-unknown-linux-gnu/gcc-bin/4.1.1:/opt/ibm-jdk-bin-1.4.2.6/bin:/opt/ibm-jdk-bin-1.4.2.6/jre/bin:/usr/kde/3.5/bin:/usr/qt/3/bin)
/usr/share/kino/scripts/exports/ffmpeg_h264_dual.sh
/usr/share/kino/scripts/exports/ffmpeg_mp3.sh
/usr/share/kino/scripts/exports/ffmpeg_mp4.sh
/usr/share/kino/scripts/exports/mencoder.sh
/usr/share/kino/scripts/exports/ffmpeg_vcd.sh
/usr/share/kino/scripts/exports/ffmpeg_mp4_dual.sh
/usr/share/kino/scripts/exports/ffmpeg_h264.sh
/usr/share/kino/scripts/exports/ffmpeg_3gp.sh
/usr/share/kino/scripts/exports/ffmpeg_xvid_dual.sh
/usr/share/kino/scripts/exports/ffmpeg_utils.sh
/usr/share/kino/scripts/exports/ffmpeg_divx.sh
/usr/share/kino/scripts/exports/ffmpeg_xvid.sh
> Creating page trim
>>> Image Create: Colour Range
>>> Image Create: Fixed Colour
>>> Image Create: From File
>>> Image Create: Gradient
>>> Image Create: Random noise
>>> Image Filter: No Change
>>> Image Filter: Black & White
>>> Image Filter: Kaleidoscope
>>> Image Filter: Fade In
>>> Image Filter: Fade Out
>>> Image Filter: Flip
>>> Image Filter: Mirror
>>> Image Filter: Reverse Video
>>> Image Filter: Sepia
>>> Image Transition: Dissolve
>>> Image Transition: Barn Door Wipe
>>> Image Transition: Differences
>>> Image Transition: No Change
>>> Image Transition: Push Wipe
>>> Image Transition: Switch
>>> Audio Filter: No Change
>>> Audio Filter: Dub
>>> Audio Filter: Fade In
>>> Audio Filter: Fade Out
>>> Audio Filter: Gain
>>> Audio Filter: Mix
>>> Audio Filter: Silence
>>> Audio Transition: Cross Fade
>>> Audio Transition: No Change
> Creating Magick Page
>> Searching /usr/lib/kino-gtk2 for plugins
>>> Registering plugin /usr/lib/kino-gtk2/libdvtitler.so
>>> Registering plugin /usr/lib/kino-gtk2/libtimfx.so
>>> Registering plugin /usr/lib/kino-gtk2/libkinoplus.so
>>> Image Filter: Superimpose
>>> Image Filter: Titler
>>> Image Filter: Blur
>>> Image Filter: Colour Hold
>>> Image Filter: Soft Focus
>>> Image Transition: Luma Wipe
>>> Image Filter: Colour Average
>>> Image Filter: Charcoal
>>> Image Filter: Jerky
>>> Image Filter: Levels
>>> Image Filter: Pan and Zoom
>>> Image Filter: Pixelate
>>> Image Transition: Composite
>>> Image Transition: Blue Chroma Key
>>> Image Transition: Green Chroma Key
> setting video preview size to 360x202
>> Starting Editor
>>> iec61883Writer::iec61883Writer port 0 channel 63
>> Creating undo/redo buffer
>> Kino Common newFile
>>> Received playlist to store at position 0
>>>> Adding to end
>> Leaving Editor
>> Left Editor
>> Starting Capture
>> AV/C Enabled
>>> Using iec61883 capture
>>> iec61883Reader::StartThread on port 0
>>> AVC status error
>>> AVC status error
>>> AVC status error
>>> AVC status error
>>> AVC status error
>>> AVC status error,

"AVC status error" being repeated as long as stay in Capture View.

dvgrab does not work either:
simon@baruch ~ $ dvgrab --frames 25 Clip-
                                                                              ""     0.00 MB 0 frames
                                                                              Capture Stopped
Error: no DV

In the Gentoo-Forums, there is a hint that this might be due to a bug in libdv:
http://forums.gentoo.org/viewtopic-t-488061-highlight-avc+status+error.html

However, the solution found there - i.e., downgrading libdv - is not possible any more. I tried to upgrade libdv to the testing version - same result.



Reproducible: Always

Steps to Reproduce:
1.launch Kino
2.try to capture from dvcam connected to firewire-port
3.

Actual Results:  
capturin not working
Comment 1 simon 2007-05-02 11:48:06 UTC
Created attachment 117943 [details]
emerge --info
Comment 2 Stefan Richter 2007-05-13 11:25:10 UTC
What is the output of "dmesg"
  - when the ohci1394 kernel module was loaded,
  - when the camera is plugged in/ switched on,
  - when Kino is trying to access the camera?
Comment 3 simon 2007-05-13 13:57:45 UTC
when loading module:
ieee1394: Initialized config rom entry `ip1394'
ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[40]  MMIO=[f5000000-f50007ff]  Max Packet=[2048]  IR/IT contexts=[4/4]
...
ohci1394: fw-host0: SelfID received outside of bus reset sequence
ieee1394: Host added: ID:BUS[0-00:1023]  GUID[000393fffe1a8e70]

when plugging in and switching on the cam:
ieee1394: The root node is not cycle master capable; selecting a new root node and resetting...
ieee1394: Node added: ID:BUS[0-00:1023]  GUID[00008500013a51de]
ieee1394: Node changed: 0-00:1023 -> 0-01:1023
ieee1394: raw1394: /dev/raw1394 device initialized

when trying to access the cam from Kino:
no change, neither when pressing the Capture-View tab nor when pressing the Capture button in the capture-window 
(note that the play/forward/rewind buttons in Kino's capture window are greyed out. Message in the status bar of Kino is "AV/C Controls Not Enabled") 

Perhaps I should also mention that this happens only on my G4 Powerbook Ti, on my i386-Desktop capturing works fine.
Comment 4 Stefan Richter 2007-05-13 14:40:27 UTC
The driver outputs look OK. Perhaps there is an endianess bug in a library or in Kino.  Maybe you should post your report at kino-dev@lists.sourceforge.net .
Comment 5 Denis Dupeyron (RETIRED) gentoo-dev 2007-05-19 15:07:51 UTC
Thanks Simon for reporting this, and Stefan for trying to help.

Simon, this looks definitely like it's an upstream issue. Could you please see with them to try and debug your issue ? Their mailing list is there :
http://sourceforge.net/mailarchive/forum.php?forum_name=kino-dev
The main author, Dan Dennedy, is usually quite helpful.

In the meantime I'm resolving this as UPSTREAM. Do not hesitate to reopen in case you end up finding out it is a Gentoo issue after all. But I'd be really surprised.

Denis.
Comment 6 simon 2007-05-20 09:52:30 UTC
I reported the issue upstream right now.
Thanks everybody