Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 176590 - dev-java/ibm-jdk-bin breaks with xorg-server-1.3.0.0 (1.2 is fine) and xcb USEflag
Summary: dev-java/ibm-jdk-bin breaks with xorg-server-1.3.0.0 (1.2 is fine) and xcb US...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Java (show other bugs)
Hardware: PPC Linux
: High major (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 174434
  Show dependency tree
 
Reported: 2007-04-30 14:52 UTC by David Gurvich
Modified: 2009-09-13 08:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Gurvich 2007-04-30 14:52:33 UTC
Recent update of xorg-server breaks GUI packages using ibm-jdk-bin.  Packages that are built with gcj and use gcj as the jvm have no problem.

Reproducible: Always

Steps to Reproduce:
1.Install xorg-server-1.3.0
2.Set jvm to ibm-jdk-bin
3.Start any java application with a gui.

Actual Results:  
A core dump with xcb assertion error.
java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.


If you like I can provide the javacore files.
I have installed gcj as an alternative jvm as using ibm-jdk-bin is totally unstable for many programs. The xcb problem is only the latest problem.
Comment 1 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2007-04-30 15:37:03 UTC
Did you start to use xcb flag? If yes then it's probably dupe of bug 156353
Comment 2 David Gurvich 2007-04-30 19:18:31 UTC
(In reply to comment #1)
> Did you start to use xcb flag? If yes then it's probably dupe of bug 156353
> 

No.  I've been using xcb for some time.  ibm-jdk-bin works without a problem using xorg-server-1.2.0.  If I revert to version 1.2.0 the problem does not affect any programs.
Comment 3 Joshua Baergen (RETIRED) gentoo-dev 2007-04-30 23:16:25 UTC
Do you have all the latest X11 libs?
Comment 4 David Gurvich 2007-05-01 00:02:44 UTC
Adding 'append-flags "-DNDEBUG=1"' to libxcb-1.0.ebuild seems to work around the problem for now.  I don't know why xorg-server-1.2 doesn't hit the same bug.
Comment 5 Gianluca Parmiggiani 2007-05-14 09:43:12 UTC
enabling or disabling xcb means recompiling all binaries depending on X (so ibm jdk still links to something still using xcb even if you dropped xcb use flag)
I have exactly the same problem with all jdks (not only ibm) and for now i've been able to only workaround sun-jdk-1.4 (please note that i'm using onlyy sun jdks)
Ditto, i think this is a dupe of bug 156353
Comment 6 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2007-05-14 10:55:41 UTC
(In reply to comment #5)
> Ditto, i think this is a dupe of bug 156353
 
Well it's a different vendor and might fix it independently on Sun.
Comment 7 David Gurvich 2007-11-23 05:04:32 UTC
Using the xcb sloppy lock seems to fix the issue.
Comment 8 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2007-11-23 06:30:30 UTC
workaround != fix
Comment 9 Rémi Cardona gentoo-dev 2009-05-05 15:29:03 UTC
I doubt that the bug is linked to the X server, but libX11 instead. Other packages (among which other JVMs) have had issues with libX11 being built with xcb support.

The official workaround is to use xcb's sloppy locking. The proper way is to fix the JVM's code...

There's not much the x11 herd can do to help here.

Thanks
Comment 10 Rémi Cardona gentoo-dev 2009-09-13 08:09:58 UTC
Doesn't look like this will ever happen :)

Closing