Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 175447 - gnome focus switching, window moving doesn't work when clicking on contents of windows
Summary: gnome focus switching, window moving doesn't work when clicking on contents o...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-21 15:23 UTC by Simon Ruggier
Modified: 2007-12-23 11:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Ruggier 2007-04-21 15:23:56 UTC
If I click on the title bar of an out of focus window, it will come into focus.  However, if I click on the contents of an out of focus window instead of the borders, nothing happens.  Also, <Meta>+Mouse1, which I have has my "movement key", does nothing when the click is on an area that doesn't respond with a change in focus.

There are a couple exceptions, i.e. firefox comes to the foreground, but doesn't gain focus, while widgetless areas of gnome-mouse-properties and gnome-window-properties work fine, both for moving and for changing focus.

# emerge --info
Portage 2.1.2.2 (default-linux/x86/2006.1/desktop, gcc-4.1.2, glibc-2.5-r0, 2.6.19-gentoo-r5 i686)
=================================================================
System uname: 2.6.19-gentoo-r5 i686 Mobile AMD Athlon(tm) 64 Processor 3400+
Gentoo Base System release 1.12.9
Timestamp of tree: Wed, 18 Apr 2007 04:50:01 +0000
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.31-r5
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.15-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64 -ggdb -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/init.d /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=athlon64 -ggdb -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer nostrip sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://mirror.datapipe.net/gentoo http://gentoo.chem.wisc.edu/gentoo/ http://distfiles.gentoo.org/"
LANG="en_CA.utf8"
LC_ALL="en_CA.utf8"
LINGUAS="en en_GB en_CA"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/etc/portage/overlay"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X X509 Xaw3d a52 aac aalib acpi aiglx alsa amr arts asf asm async audiofile automount avahi bash-completion berkdb bitmap-fonts bl bluetooth bootsplash branding bzip2 cairo cdda cddb cdparanoia cdr chroot cjk cli cpudetection cracklib crypt cscope ctype cups curl curlwrappers d dbus dhcp divx dri dts dv dvd dvdr dvdread dvi edl eds emboss encode exif expat fam fat fbcon ffmpeg firefox flac foomaticdb fortran ftp gd gdbm gif gimp gimpprint glitz glut gmedia gmp gnome gnutls gpm gs gstreamer gtk gtk2 hal hfs howl-compat hpn iconv idn ieee1394 imagemagick imlib ipv6 isdnlog java javascript jfs joystick jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility lcms ldap libcaca libg++ libnotify live logitech-mouse logrotate lua lzo mad matroska md5sum memlimit midi mikmod mjpeg mmap mmx mmxext mng mp3 mpeg mplayer msn multicall musicbrainz nas nautilus ncurses network new-login nfs nls nntp no-htdocs nptl nptlonly nsplugin ntfs offensive ogg on-the-fly-crypt openal opengl oss pam pch pcmcia pcre pda pdf perl png povray ppds pppd python qt3 qt3support qt4 quicktime rdesktop readline real realmedia reflection reiser4 reiserfs rtc rtsp samba sasl scanner sdl session simplexml slp soap sockets speex spell spl sqlite sse sse2 ssl startup-notification stream subtitles svg svga sysfs syslog t1lib tcpd tga theora threads tiff tokenizer truetype truetype-fonts type1-fonts unicode usb userlocales v4l v4l2 vcd vidix vim-with-x vorbis vv widescreen wifi win32codecs wmf wmp x86 xanim xcomposite xfs xine xinerama xml xorg xpm xprint xrandr xscreensaver xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev joystick keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB en_CA" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Reproducible: Always

Steps to Reproduce:
1.  Boot into my system (I'm guessing this isn't going to be trivial to reproduce)
2.  Log into the only session I have and use, gnome
3.  click on the contents of a window that doesn't have the focus

Actual Results:  
the window that received the click doesn't gain focus

Expected Results:  
the windows that received the click should gain focus

All of my xorg packages are unstabled.
Comment 1 Matti Bickel (RETIRED) gentoo-dev 2007-04-21 19:32:17 UTC
which version of gnome are using?
Comment 2 Simon Ruggier 2007-04-22 22:39:03 UTC
A mix of 2.16.2 and unstable apps.  To be clear, this doesn't just affect gnome apps, it happens with Kopete and Amarok as well.
Comment 3 Gilles Dartiguelongue gentoo-dev 2007-12-22 23:52:24 UTC
whichever it is, this sounds like a window manager problem. what are you using, metacity, compiz, ... ?
Comment 4 Simon Ruggier 2007-12-23 04:23:37 UTC
It was metacity at the time, but I can't test this now, my system no longer has Gentoo on it.  I can upload my package.keywords file if it would help someone who wants to duplicate this problem.
Comment 5 Gilles Dartiguelongue gentoo-dev 2007-12-23 11:47:23 UTC
I'll say it's a cantfix for now, because it looks like a local problem and if you removed your gentoo install, there is not much we can do. Also next time, avoid mixing too much stable system with unstable packages, this sort of problem might have been triggered this way.