Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 174306 - 2007.0 amd64 pre-release fails to autoconfigure X on ATI system
Summary: 2007.0 amd64 pre-release fails to autoconfigure X on ATI system
Status: RESOLVED DUPLICATE of bug 177726
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: LiveCD/DVD (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-12 18:03 UTC by Malcolm Lashley (RETIRED)
Modified: 2007-05-09 20:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Malcolm Lashley (RETIRED) gentoo-dev 2007-04-12 18:03:25 UTC
Testing new livecd media for Kugelfang. On Dell Optiplex 745 (E6400, ATI X1300) - the mkxf86config.sh decides I need an ati driver - but none appears to be on the livecd - second it reports a missing symbol from the xorg opengl library...

(By forcing Driver="vesa" in xorg.conf - X starts up fine.

livecd ~ # startx
xauth:  creating new authority file /root/.serverauth.4288
xauth:  creating new authority file /root/.Xauthority
xauth:  creating new authority file /root/.Xauthority
 
X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: UNKNOWN
Current Operating System: Linux livecd 2.6.19-gentoo-r5 #1 SMP Fri Mar 23 19:20:13 UTC 2007 x86_64
Build Date: 06 April 2007
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 12 10:04:03 2007
(==) Using config file: "/etc/X11/xorg.conf"
 
dlopen: /usr/lib64/xorg/modules/extensions/libGLcore.so: undefined symbol: __glXActiveScreens
(EE) Failed to load /usr/lib64/xorg/modules/extensions/libGLcore.so
(EE) Failed to load module "GLcore" (loader failed, 7)
(EE) Failed to load module "glx" (module does not exist, 0)
(EE) Failed to load module "ati" (module does not exist, 0)
(EE) No drivers available.
 
Fatal server error:

Reproducible: Always

Steps to Reproduce:
1. Boot LiveCD
2. 

Actual Results:  
Watch X fail to start after autoconfig.


Expected Results:  
Shiny X desktop.
Comment 1 Sonny Lander 2007-05-09 15:16:27 UTC
I can confirm this bug, but the fix by setting it to vesa does not work for me :(
I will post the error later today.
---ati radeon 1950pro---
Comment 2 Chris Gianelloni (RETIRED) gentoo-dev 2007-05-09 20:25:07 UTC

*** This bug has been marked as a duplicate of bug 177726 ***