Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 173711 - app-misc/mnemosyne - sophisticated flash-card tool
Summary: app-misc/mnemosyne - sophisticated flash-card tool
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 4 votes (vote)
Assignee: Default Assignee for New Packages
URL: http://mnemosyne-proj.sourceforge.net/
Whiteboard: sunrise suggested
Keywords: EBUILD
: 265740 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-04-07 22:43 UTC by Pavol Cupka
Modified: 2015-12-09 18:24 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
mnemosyne-0.9.7.ebuild (mnemosyne-0.9.7.ebuild,907 bytes, text/plain)
2007-04-07 22:47 UTC, Pavol Cupka
Details
mnemosyne-0.9.7.ebuild (mnemosyne-0.9.7.ebuild,891 bytes, text/plain)
2007-06-01 22:41 UTC, Pavol Cupka
Details
mnemosyne-0.9.8.1.ebuild (mnemosyne-0.9.8.1.ebuild,916 bytes, text/plain)
2007-06-01 22:42 UTC, Pavol Cupka
Details
mnemosyne-0.9.9.ebuild (mnemosyne-0.9.9.ebuild,916 bytes, text/plain)
2007-08-25 09:09 UTC, Pavol Cupka
Details
mnemosyne-1.0.ebuild (mnemosyne-1.0.ebuild,916 bytes, text/plain)
2008-01-27 09:20 UTC, Pavol Cupka
Details
mnemosyne-1.0.1.1.ebuild (mnemosyne-1.0.1.1.ebuild,916 bytes, text/plain)
2008-03-25 10:20 UTC, Pavol Cupka
Details
mnemosyne-1.1.ebuild (mnemosyne-1.1.ebuild,913 bytes, text/plain)
2008-08-17 22:07 UTC, Christian Conkle
Details
New Ebuild for v1.1.1, added latex USE flag (mnemosyne-1.1.1.ebuild,545 bytes, text/plain)
2008-09-20 09:23 UTC, Guy Cirino
Details
Followed their -r1 bump and incorporated changed from sunrise review (mnemosyne-1.1.1.ebuild,688 bytes, text/plain)
2008-09-20 18:33 UTC, Guy Cirino
Details
Mnemosyne version 1.2 from version 1.1 (mnemosyne-1.2.ebuild,702 bytes, text/plain)
2008-12-23 14:55 UTC, Charles Welton
Details
Mnemosyne-1.2 with proper dependency versions (mnemosyne-1.2.ebuild,739 bytes, text/plain)
2008-12-23 16:37 UTC, Charles Welton
Details
mnemosyne 1.2.1 ebuild (mnemosyne-1.2.1.ebuild,694 bytes, text/plain)
2009-07-07 09:27 UTC, Lubos Kolouch
Details
mnemosyne-1.2.2 ebuild, added ~amd64 and dev-python/imaging dependency (mnemosyne-1.2.2.ebuild,721 bytes, text/plain)
2010-03-30 09:00 UTC, darklegion
Details
Mnemosyne-2.3.5.ebuild (Mnemosyne-2.3.5.ebuild,719 bytes, text/plain)
2015-12-09 18:18 UTC, martin.schmidt13
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavol Cupka 2007-04-07 22:43:43 UTC
The Mnemosyne software resembles a traditional flash-card program to help you memorise question/answer pairs.

This is an ebuild for 0.9.7 version.

http://mnemosyne-proj.sourceforge.net/
Comment 1 Pavol Cupka 2007-04-07 22:47:46 UTC
Created attachment 115686 [details]
mnemosyne-0.9.7.ebuild
Comment 2 Pavol Cupka 2007-06-01 22:41:53 UTC
Created attachment 120900 [details]
mnemosyne-0.9.7.ebuild
Comment 3 Pavol Cupka 2007-06-01 22:42:32 UTC
Created attachment 120904 [details]
mnemosyne-0.9.8.1.ebuild
Comment 4 Pavol Cupka 2007-08-25 09:09:21 UTC
Created attachment 129121 [details]
mnemosyne-0.9.9.ebuild
Comment 5 Pavol Cupka 2008-01-27 09:20:24 UTC
Created attachment 141869 [details]
mnemosyne-1.0.ebuild
Comment 6 Pavol Cupka 2008-03-25 10:20:30 UTC
Created attachment 147232 [details]
mnemosyne-1.0.1.1.ebuild
Comment 7 Thomas Nichols 2008-04-25 12:44:14 UTC
Installed ok on x86 into app-misc/mnemosyne -- any suggestions for a better category? Maybe sci-misc?
Comment 8 Beetle B. 2008-05-30 05:43:09 UTC
Just thought I'd point out that the latest ebuild works fine here. Would be really nice if a dev could maintain it and get it into Portage. I suspect that of the free software in the memorizing aid area, this is the best one there is. 
Comment 9 Christian Conkle 2008-08-17 22:07:02 UTC
Created attachment 163157 [details]
mnemosyne-1.1.ebuild
Comment 10 Guy Cirino 2008-09-20 09:23:42 UTC
Created attachment 165886 [details]
New Ebuild for v1.1.1, added latex USE flag

vote +1, helpful memorization aide tool, would be nice in portage
Comment 11 Guy Cirino 2008-09-20 18:33:36 UTC
Created attachment 165924 [details]
Followed their -r1 bump and incorporated changed from sunrise review
Comment 12 Guy Cirino 2008-09-21 16:09:42 UTC
This is now in the Sunrise overlay.  You can get to it with layman (check out sunrise) or at:

http://overlays.gentoo.org/svn/proj/sunrise/reviewed/app-misc/mnemosyne/

Comment 13 Serguei Jidkov 2008-10-12 10:58:20 UTC
It misses dependency on dev-python/setuptools. Otherwise builds ok, thanks for the ebuild. :)
Comment 14 Charles Welton 2008-12-23 14:55:38 UTC
Created attachment 176219 [details]
Mnemosyne version 1.2 from version 1.1

New ebuild for the newest version for mnemosyne.
Tested working with ~x86.

Added dev-python/setuptools as a dependency as suggested by Serguei Jidkov.
Comment 15 Charles Welton 2008-12-23 16:37:36 UTC
Created attachment 176232 [details]
Mnemosyne-1.2 with proper dependency versions

Same ebuild as the previous except that now the dependency has proper versions to the tested(and stable) ones.
Comment 16 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-06 16:08:26 UTC
(this is an automated message based on filtering criteria that matched this bug)
'EBUILD' is in the KEYWORDS which should mean that there is a ebuild attached 
to this bug.
This bug is assigned to maintainer-wanted which means that it is not in the 
main tree.
Heuristics show that no Gentoo developer has commented on your ebuild.

Hello, The Gentoo Team would like to firstly thank you for your ebuild 
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The 
sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to 
commit to and all users can have ebuilds reviewed by Gentoo devs for entry 
into the overlay. So, the sunrise team is suggesting that you look into this 
and submit your ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us. 
We anticipate a large number of requests in a short time. 

Thanks,
On behalf of the Gentoo Sunrise Team,
Jeremy.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq
Comment 17 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-11 10:34:01 UTC
*** Bug 265740 has been marked as a duplicate of this bug. ***
Comment 18 bugs.gentoo.org 2009-04-16 19:54:25 UTC
(In reply to comment #15)
> Created an attachment (id=176232) [edit]
> Mnemosyne-1.2 with proper dependency versions
> 
> Same ebuild as the previous except that now the dependency has proper versions
> to the tested(and stable) ones.
> 

This ebuild does compile, but does not run with python 2.5, at least not on my computer, I am receiving the following:
Fatal Python error: (pygame parachute) Segmentation Fault

it runs with python 2.4; any suggestions or help?

Comment 19 Pavol Cupka 2009-04-16 21:37:19 UTC
version 1.2 builds and runs ok on amd64 with python 2.5
Comment 20 Charles Welton 2009-04-16 22:41:33 UTC
I run it on x86 with python 2.5. You probably installed pygame with python 2.4. You need to update python-based applications to the new version. Just run python-updater as root.
Comment 21 bugs.gentoo.org 2009-04-17 18:47:01 UTC
(In reply to comment #20)
> I run it on x86 with python 2.5. You probably installed pygame with python 2.4.
> You need to update python-based applications to the new version. Just run
> python-updater as root.
> 

After upgrading to python 2.5 I have run python-updater, but still got the error
Comment 22 bugs.gentoo.org 2009-04-17 22:53:13 UTC
this is the last part of strace mnemosyne (still python 2.5):
access("/usr/qt/3/plugins", F_OK)       = 0
access("/usr/bin/mnemosyne", F_OK)      = 0
lstat("/usr/bin/mnemosyne", {st_mode=S_IFREG|0755, st_size=3640, ...}) = 0
lstat("/usr/bin", {st_mode=S_IFDIR|0755, st_size=81920, ...}) = 0
lstat("/usr", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
lstat("", 0x1017fd0)                    = -1 ENOENT (No such file or directory)
stat("", 0x1017fd0)                     = -1 ENOENT (No such file or directory)
access("/usr/bin", F_OK)                = 0
access("/usr/qt/3/plugins/imageformats/.", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/bin/imageformats/.", F_OK) = -1 ENOENT (No such file or directory)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigaction(SIGSEGV, {SIG_DFL, [SEGV], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, {0x7f1d4ea5217c, [SEGV], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, 8) = 0
rt_sigaction(SIGSEGV, {SIG_DFL, [SEGV], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, {SIG_DFL, [SEGV], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, 8) = 0
rt_sigaction(SIGSEGV, {SIG_DFL, [SEGV], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, {SIG_DFL, [SEGV], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, 8) = 0
rt_sigaction(SIGBUS, {SIG_DFL, [BUS], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, {0x7f1d4ea5217c, [BUS], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, 8) = 0
rt_sigaction(SIGFPE, {SIG_DFL, [FPE], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, {0x7f1d4ea5217c, [FPE], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, 8) = 0
rt_sigaction(SIGQUIT, {SIG_DFL, [QUIT], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, {0x7f1d4ea5217c, [QUIT], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, 8) = 0
rt_sigaction(SIGSEGV, NULL, {SIG_DFL, [SEGV], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, 8) = 0
rt_sigaction(SIGBUS, NULL, {SIG_DFL, [BUS], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, 8) = 0
rt_sigaction(SIGFPE, NULL, {SIG_DFL, [FPE], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, 8) = 0
rt_sigaction(SIGQUIT, NULL, {SIG_DFL, [QUIT], SA_RESTORER|SA_RESTART, 0x7f1d56a761d0}, 8) = 0
write(2, "Fatal Python error: (pygame parac"..., 58) = 58
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
tgkill(20733, 20733, SIGABRT)           = 0
--- SIGABRT (Aborted) @ 0 (0) ---
+++ killed by SIGABRT +++
Comment 23 Charles Welton 2009-04-18 00:02:54 UTC
(In reply to comment #21)
> (In reply to comment #20)
> > I run it on x86 with python 2.5. You probably installed pygame with python 2.4.
> > You need to update python-based applications to the new version. Just run
> > python-updater as root.
> > 
> 
> After upgrading to python 2.5 I have run python-updater, but still got the
> error
> 

With the trace _only_, I can't reproduce the bug. But I think this is due to broken packages. Try running revdep-rebuild. If that doesn't work, try re-emerging pygame. Lastly, try upgrading your system. Without your system's information, there is nothing more I can say.
Comment 24 bugs.gentoo.org 2009-04-26 13:56:04 UTC
(In reply to comment #23)
> (In reply to comment #21)
> > (In reply to comment #20)
> > > I run it on x86 with python 2.5. You probably installed pygame with python 2.4.
> > > You need to update python-based applications to the new version. Just run
> > > python-updater as root.
> > > 
> > 
> > After upgrading to python 2.5 I have run python-updater, but still got the
> > error
> > 
> 
> With the trace _only_, I can't reproduce the bug. But I think this is due to
> broken packages. Try running revdep-rebuild. If that doesn't work, try
> re-emerging pygame. Lastly, try upgrading your system. Without your system's
> information, there is nothing more I can say.
> 

here is my system info, i.e. emerge --info:
Portage 2.2_rc31 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.28.9 x86_64)
=================================================================                                
System uname: Linux-2.6.28.9-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-1.12.11.1
Timestamp of tree: Sat, 25 Apr 2009 06:15:02 +0000                                                  
ccache version 2.4 [enabled]                                                                        
app-shells/bash:     3.2_p39                                                                        
dev-java/java-config: 1.3.7-r1, 2.1.7                                                               
dev-lang/python:     2.4.4-r14, 2.6.2                                                               
dev-python/pycrypto: 2.0.1-r8                                                                       
dev-util/ccache:     2.4-r7                                                                         
dev-util/cmake:      2.6.2-r1                                                                       
sys-apps/baselayout: 1.12.11.1                                                                      
sys-apps/sandbox:    1.9                                                                            
sys-devel/autoconf:  2.13, 2.63                                                                     
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                      
sys-devel/binutils:  2.18-r3                                                                        
sys-devel/gcc-config: 1.4.1                                                                         
sys-devel/libtool:   1.5.26                                                                         
virtual/os-headers:  2.6.27-r2                                                                      
ACCEPT_KEYWORDS="amd64"                                                                             
CBUILD="x86_64-pc-linux-gnu"                                                                        
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"                                               
CHOST="x86_64-pc-linux-gnu"                                                                         
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config /var/lib/hsqldb"                                                                                                                                                   
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"                                                                    
CXXFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"                                                                                                               
DISTDIR="/usr/portage/distfiles"                                                                                                                                      
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                   
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ "                                                                                                
LANG="en_US"                                                                                                                                                          
LC_ALL="en_US"                                                                                                                                                        
LDFLAGS="-Wl,-O1"                                                                                                                                                     
LINGUAS="en_US de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local /usr/portage/local/layman/sunrise"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 bash-completion battery berkdb bzip2 cdr cjk cli cpufreq cracklib crypt cups dbus debug directfb doc dri dvd eds examples fortran gdbm gpmgtk hal hddtemp htmlhandbook iconv ipv6 isdnlog jack java kde kdeprefix ladspa ldap lm_sensors midi mmx mono mudflap multilib ncurses nl nls nptl nptlonly opengl openmp pam pcre perl pppd python qt4 readline reflection sensord session spl sse sse2 ssl svg sysfs tcpd unicode vim-syntax webdav wifi xorg xulrunner zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multinull plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse ps2mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US de" USERLAND="GNU" VIDEO_CARDS="intel vesa radeon radeonhd fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 25 Charles Welton 2009-04-27 12:45:26 UTC
(In reply to comment #24)
> ...
> here is my system info, i.e. emerge --info:
> Portage 2.2_rc31 (default/linux/amd64/2008.0, gcc-4.1.2,
> glibc-2.8_p20080602-r1, 2.6.28.9 x86_64)
> ...
> > dev-lang/python:     2.4.4-r14, 2.6.2                                           
> ...

That line shows that you're actually using python 2.4 or 2.6, not 2.5.
Try this: install eselect-python, select the version that you want, run python-updater and revdep-rebuild. 
Comment 26 bugs.gentoo.org 2009-04-28 16:07:22 UTC
(In reply to comment #25)
> (In reply to comment #24)
> > ...
> > here is my system info, i.e. emerge --info:
> > Portage 2.2_rc31 (default/linux/amd64/2008.0, gcc-4.1.2,
> > glibc-2.8_p20080602-r1, 2.6.28.9 x86_64)
> > ...
> > > dev-lang/python:     2.4.4-r14, 2.6.2                                           
> > ...
> That line shows that you're actually using python 2.4 or 2.6, not 2.5.
> Try this: install eselect-python, select the version that you want, run
> python-updater and revdep-rebuild. 

I know, but with python2.6 it does not work either: I did what you said, both with python2.5 and with python2.6, i.e. run eselect-python python set python2.5 (and python 2.6), run python-updater and revdep-rebuild, yet to no avail, mnemosyne only works under python2.4. It seems it only needs PyQt, PyQt4, sip, setuptools, and pygame. And pygame seems to cause the runtime error (Fatal Python error: (pygame parachute) Segmentation Fault).

Any help, please? I am running out of ideas here.
Comment 27 Charles Welton 2009-04-28 19:31:45 UTC
(In reply to comment #26)
> (In reply to comment #25)
> > (In reply to comment #24)
> > > ...
> > > here is my system info, i.e. emerge --info:
> > > Portage 2.2_rc31 (default/linux/amd64/2008.0, gcc-4.1.2,
> > > glibc-2.8_p20080602-r1, 2.6.28.9 x86_64)
> > > ...
> > > > dev-lang/python:     2.4.4-r14, 2.6.2                                           
> > > ...
> > That line shows that you're actually using python 2.4 or 2.6, not 2.5.
> > Try this: install eselect-python, select the version that you want, run
> > python-updater and revdep-rebuild. 
> 
> I know, but with python2.6 it does not work either: I did what you said, both
> with python2.5 and with python2.6, i.e. run eselect-python python set python2.5
> (and python 2.6), run python-updater and revdep-rebuild, yet to no avail,
> mnemosyne only works under python2.4. It seems it only needs PyQt, PyQt4, sip,
> setuptools, and pygame. And pygame seems to cause the runtime error (Fatal
> Python error: (pygame parachute) Segmentation Fault).
> 
> Any help, please? I am running out of ideas here.
> 

Mnemosyne 1.2 uses PyQt, pygame and setuptools. My last idea that what might be wrong is that some package that pygame depends on is seg' faulting. You could try running mnemosyne in gdb and see the trace. _Maybe_ that will give an idea on what is wrong.
Comment 28 Lubos Kolouch 2009-07-07 09:27:57 UTC
Created attachment 197024 [details]
mnemosyne 1.2.1 ebuild

There is long time new version - please find ebuild
Comment 29 Victor Faion 2010-01-27 18:57:14 UTC
I get the following error when trying to emerge mnemosyne-1.2.1:

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "~dev-python/sip-4.7.9".
(dependency required by "dev-python/PyQt-3.17.6" [ebuild])
(dependency required by "app-misc/mnemosyne-1.2" [ebuild])
(dependency required by "mnemosyne" [argument])

This is on a x86_64 machine, but the same thing happens on my 32-bit machine. How do you get around this?
Comment 30 darklegion 2010-03-30 09:00:55 UTC
Created attachment 225803 [details]
mnemosyne-1.2.2 ebuild, added ~amd64 and dev-python/imaging dependency
Comment 31 Francesco Turco 2012-12-21 17:58:34 UTC
Latest version is now 2.2 (2.x is a complete rewrite of the old codebase).
Comment 32 Francesco Turco 2014-08-02 13:06:05 UTC
Mnemosyne 2.3.1 has been released on 2014-06-18.
Comment 33 martin.schmidt13 2015-12-08 20:29:48 UTC
I proudly present an ebuild for 2.3.5 - especially after so long time ;-)
(Thanks to iamben for the quick "inspiration")

Feel free to use/adapt/modify it.
I'm not so experienced with ebuilds - so maybe its not perfect yet but it compiled here without problems.

If you get error messages after successful installation while executing the program i solved this by
compiling the following packages with these new USE flags - but I'm afraid thats not the perfect way...

=dev-python/PyQt4-4.11.1:0 webkit sql
>=dev-lang/python-2.7.10-r1:2.7 sqlite

And here comes the ebuild:

EAPI=5

PYTHON_COMPAT=( python2_7 )
inherit distutils-r1

DESCRIPTION="spaced repetition flash-card program"
HOMEPAGE="http://mnemosyne-proj.org/"
SRC_URI="http://netcologne.dl.sourceforge.net/project/mnemosyne-proj/mnemosyne/mnemosyne-2.3.5/${P}.tar.gz"

LICENSE="I dont know"
SLOT="0"
KEYWORDS="~amd64"

DEPEND="dev-python/PyQt4 dev-python/matplotlib dev-python/cherrypy dev-python/webob dev-python/setuptools"
RDEPEND="${DEPEND}"
Comment 34 martin.schmidt13 2015-12-09 18:18:12 UTC
Created attachment 418902 [details]
Mnemosyne-2.3.5.ebuild
Comment 35 martin.schmidt13 2015-12-09 18:24:09 UTC
Comment on attachment 418902 [details]
Mnemosyne-2.3.5.ebuild

Added slightly better ebuild  (attachment 418902 [details]) -> emerge and program run without problems now