Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 173570 - media-gfx/mscgen (new ebuild)
Summary: media-gfx/mscgen (new ebuild)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 2 votes (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard: sunrise suggested
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2007-04-06 14:38 UTC by Yvan Royon
Modified: 2010-11-03 10:07 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild for mscgen (mscgen-0.3.ebuild,595 bytes, text/plain)
2007-04-06 14:40 UTC, Yvan Royon
Details
ebuild for mscgen-0.6 (mscgen-0.6.ebuild,661 bytes, text/plain)
2007-07-29 18:42 UTC, Yvan Royon
Details
ebuild for mscgen-0.8 (mscgen-0.8.ebuild,661 bytes, text/plain)
2008-01-12 19:11 UTC, Yvan Royon
Details
suppress warnings and QA notice (mscgen-0.8-removewarnings.diff,1.44 KB, patch)
2008-02-04 11:56 UTC, Yvan Royon
Details | Diff
fix warnings and a dependency (mscgen-0.8-r1.ebuild,994 bytes, text/plain)
2008-02-04 12:00 UTC, Yvan Royon
Details
ebuild bump (mscgen-0.9.ebuild,887 bytes, text/plain)
2008-02-10 16:42 UTC, Yvan Royon
Details
ebuild for mscgen 0.10 (mscgen-0.10.ebuild,887 bytes, text/plain)
2008-02-24 14:17 UTC, Yvan Royon
Details
mscgen-0.11.ebuild (mscgen-0.11.ebuild,704 bytes, text/plain)
2008-04-29 18:27 UTC, Peter Simons
Details
mscgen-0.13.ebuild (mscgen-0.13.ebuild,983 bytes, text/plain)
2008-12-12 00:44 UTC, Peter Simons
Details
bump, using EAPI 2 (mscgen-0.17.ebuild,795 bytes, text/plain)
2009-11-20 12:44 UTC, Yvan Royon
Details
version bump (mscgen-0.18.ebuild,867 bytes, text/plain)
2010-09-09 09:13 UTC, Yvan Royon
Details
Rounded BBOX coordinates and whitebox behind text in EPS output (ps_out.c-white-box-and-rounded-bbox.patch,2.23 KB, patch)
2010-11-02 18:32 UTC, Walter
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yvan Royon 2007-04-06 14:38:35 UTC
Mscgen is a Message Sequence Charts parser and generator. It can be called from Doxygen (>=1.5.2), just like Graphviz.

Suggested category is media-gfx (also like Graphviz).

http://www.mcternan.me.uk/mscgen/index.html

Reproducible: Always
Comment 1 Yvan Royon 2007-04-06 14:40:19 UTC
Created attachment 115580 [details]
ebuild for mscgen

Tested on x86 only.
Comment 2 Yvan Royon 2007-07-29 18:42:12 UTC
Created attachment 126374 [details]
ebuild for mscgen-0.6

So, a few changes:

- version bump.

- I've contacted uptream so the tarball name include the version number. Updating should be more package manager friendly now. Thanks Mike!

- A man page is now shipped.

- 'dodoc' was missing.
Comment 3 Yvan Royon 2008-01-12 19:11:43 UTC
Created attachment 140820 [details]
ebuild for mscgen-0.8

Version bump.
Comment 4 Yvan Royon 2008-02-04 11:56:22 UTC
Created attachment 142644 [details, diff]
suppress warnings and QA notice

Added a patch to remove various warnings and QA notice.
Comment 5 Yvan Royon 2008-02-04 12:00:05 UTC
Created attachment 142646 [details]
fix warnings and a dependency

New revision:
1) apply removewarnings patch.
2) add a check in pkg_setup() for png support in libgd.
Comment 6 Michael McTernan 2008-02-09 19:57:06 UTC
I believe this patch is unsafe as tmpfile() returns a FILE *:

+        outImage = (char *)tmpfile();

Please see version 0.9 of mscgen which has a different change to remove warnings (http://www.mcternan.me.uk/mscgen/).
Comment 7 Yvan Royon 2008-02-10 16:42:12 UTC
Created attachment 143137 [details]
ebuild bump

Version bump, drops the patch.
Comment 8 Yvan Royon 2008-02-24 14:17:01 UTC
Created attachment 144499 [details]
ebuild for mscgen 0.10

Version bump.
Comment 9 Peter Simons 2008-04-29 18:27:47 UTC
Created attachment 151362 [details]
mscgen-0.11.ebuild

Attached is an ebuild for version 0.11. I patched the upstream makefiles to build a dynamically linked binary instead of a static one. I also remove the default optimization flags because they override the user-configured ones.
Comment 10 Peter Simons 2008-06-04 18:33:54 UTC
Hi, I wonder what the procedure is when a new ebuild is submitted. It appears that over the course of the last year, there have been plenty of updates and submissions for this package, but nothing has ever happened, really. What is the criteria for deciding that an ebuild is included in the distribution? Who is responsible for that decision? 

I wonder because I'd like to have that package in portage, but at the same time I don't want to waste my time maintaining an ebuild that never leaves the bug tracker.
Comment 11 Michael McTernan 2008-10-27 12:31:06 UTC
Version bump required - now at 0.13, not that this bug seems to be going anywhere :(
Comment 12 Peter Simons 2008-12-12 00:44:14 UTC
Created attachment 175022 [details]
mscgen-0.13.ebuild
Comment 13 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-06 16:07:53 UTC
(this is an automated message based on filtering criteria that matched this bug)
'EBUILD' is in the KEYWORDS which should mean that there is a ebuild attached 
to this bug.
This bug is assigned to maintainer-wanted which means that it is not in the 
main tree.
Heuristics show that no Gentoo developer has commented on your ebuild.

Hello, The Gentoo Team would like to firstly thank you for your ebuild 
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The 
sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to 
commit to and all users can have ebuilds reviewed by Gentoo devs for entry 
into the overlay. So, the sunrise team is suggesting that you look into this 
and submit your ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us. 
We anticipate a large number of requests in a short time. 

Thanks,
On behalf of the Gentoo Sunrise Team,
Jeremy.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq
Comment 14 Olivier Crete (RETIRED) gentoo-dev 2009-11-18 23:35:58 UTC
FYI, the version is now at 0.17 and it expects media-libs/gd to provide a pkgconfig file, but upstream doesn't (but it seems other distributions provide one)... So we need to work around that somehow if we want to get mscgen in the tree.
Comment 15 Yvan Royon 2009-11-20 12:44:11 UTC
Created attachment 210704 [details]
bump, using EAPI 2

OK then, new ebuild, and simpler.

As noted by tester, you'll need a pkg-config file for media-libs/gd. See bug #293839 for that.
Comment 16 Walter 2009-12-13 01:22:04 UTC
10 votes from me.  This is a very cool package for systems documentation.
Comment 17 Christian Kotz 2010-06-27 08:49:49 UTC
I am using this package too, both privately and at the company. 

In my opinion, just counting the number of comments on the ebuild to make a submission decision is a bad idea. Bad ebuilds with a lot of bugs will get the highest atention.
Comment 18 Michael McTernan 2010-09-05 15:07:56 UTC
Version 0.18 doesn't require a package config for libgd; it will attempt to use gdlib-config first if it can be found.
Comment 19 Yvan Royon 2010-09-09 09:13:42 UTC
Created attachment 246578 [details]
version bump

Thanks Michael. I confirm it works without the gdlib.pc file. Bumped.
Comment 20 Walter 2010-11-02 18:32:26 UTC
Created attachment 252929 [details, diff]
Rounded BBOX coordinates and whitebox behind text in EPS output
Comment 21 Samuli Suominen gentoo-dev 2010-11-02 19:14:45 UTC
+*mscgen-0.18 (02 Nov 2010)
+
+  02 Nov 2010; Samuli Suominen <ssuominen@gentoo.org> +mscgen-0.18.ebuild,
+  +files/mscgen-0.18-pkg.patch:
+  Initial commit wrt #173570 by Roy, Peter, Walter (and others).

In portage now.

(In reply to comment #20)
> Created an attachment (id=252929) [details]
> Rounded BBOX coordinates and whitebox behind text in EPS output

Origin of this patch wasn't clear so I left it out.  It should be handed over to the upstream developers.