Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 172919 - sci-electronics/iverilog-0.8.3 fails to build
Summary: sci-electronics/iverilog-0.8.3 fails to build
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: The Soldering-Iron Brotherhood
URL:
Whiteboard:
Keywords:
: 188199 (view as bug list)
Depends on:
Blocks: 302500
  Show dependency tree
 
Reported: 2007-03-31 19:06 UTC by DEMAINE Benoît-Pierre, aka DoubleHP
Modified: 2010-04-11 17:02 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
sci-electronics:iverilog-0.8.3:20070331-190301.log (sci-electronics:iverilog-0.8.3:20070331-190301.log,68.17 KB, text/plain)
2007-03-31 19:06 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
/tmp/emerge--info (emerge--info,4.58 KB, text/plain)
2007-03-31 19:07 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DEMAINE Benoît-Pierre, aka DoubleHP 2007-03-31 19:06:13 UTC
i686-pc-linux-gnu-gcc -DHAVE_CVS_IDENT=1 -I. -I./.. -I..  -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_MALLOC_H=1 -DSIZEOF_UNSIGNED_LONG_LONG=8 -DSIZEOF_UNSIGNED_LONG=4 -DSIZEOF_UNSIGNED=4 -DHAVE_DLFCN_H=1  -fPIC -Wall -O2 -march=athlon-mp -pipe -mmmx -msse -m3dnow -MD -c cadpli.c
mv cadpli.d dep
make[1]: *** No rule to make target `../vvp/libvpi.a', needed by `cadpli.vpl'.  Stop.
make[1]: Leaving directory `/var/tmp/portage/sci-electronics/iverilog-0.8.3/work/verilog-0.8.3/cadpli'

Logs coming after creation.
Comment 1 DEMAINE Benoît-Pierre, aka DoubleHP 2007-03-31 19:06:40 UTC
Created attachment 115073 [details]
sci-electronics:iverilog-0.8.3:20070331-190301.log
Comment 2 DEMAINE Benoît-Pierre, aka DoubleHP 2007-03-31 19:07:08 UTC
Created attachment 115074 [details]
/tmp/emerge--info
Comment 3 Denis Dupeyron gentoo-dev 2007-04-01 09:25:27 UTC
Thanks for reporting this bug. The problem was in the vvp subdirectory, which needed an include file that is generally found in the kernel sources. This was the reason for libvpi.a not being built. As tapping the kernel sources directly isn't a solution, I have implemented a different fix.

Denis.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-08-09 06:39:16 UTC
*** Bug 188199 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-08-09 06:40:50 UTC
Not fixed in stable -> reopen. Please stabilize >=0.8.3
Comment 6 Nicholas Vinen 2007-08-17 03:47:56 UTC
I ran into this problem too.. the problem seems to be that the linux-headers package does not install /usr/include/asm-generic/memory_model.h or /usr/include/asm-generic/page.h . I don't understand why the kernel header package isntalls files into asm-generic, but not these two. I think the fix would be to change sys-kernel/linux-headers to install these two files along with the others it already places in that directory.
Comment 7 Markus Rothe (RETIRED) gentoo-dev 2007-12-05 15:13:22 UTC
I just ran into this problem. sci-electronics/iverilog-0.8.4 is in the tree since 01 Apr 2007 and does not suffer from this problem.

can we please stabilize 0.8.4?
Comment 8 Denis Dupeyron gentoo-dev 2007-12-05 15:58:31 UTC
(In reply to comment #7)
> I just ran into this problem. sci-electronics/iverilog-0.8.4 is in the tree
> since 01 Apr 2007 and does not suffer from this problem.
> 
> can we please stabilize 0.8.4?

Agreed. However, I have recently bumped iverilog to version 0.8.6 and since stabilization seems to be such a long and painful process (even when I provide a full testing recipe that even a non-specialist can run in a few minutes), I would prefer to wait a couple more weeks and stabilize 0.8.6 instead of 0.8.4.

Denis.
Comment 9 Markus Rothe (RETIRED) gentoo-dev 2007-12-06 08:46:34 UTC
how about marking 0.8.4 stable NOW and 0.8.6 in a few weeks. This would fix the stable tree, which shouldn't be broken.
Comment 10 Denis Dupeyron gentoo-dev 2007-12-21 10:10:54 UTC
(In reply to comment #9)
> how about marking 0.8.4 stable NOW and 0.8.6 in a few weeks. This would fix the
> stable tree, which shouldn't be broken.

This kind of non-essential and complicated package (for the general audience) usually takes a lot of time to get stabilized, and I can perfectly understand that. So I prefer to request stabilization when it makes the most sense only.

I'm currently preparing a testbench to add to the already existing (small) collection, see [1]. As soon as this is done I'll request stabilization for 0.8.6 even it's a bit ahead of usual schedule.

Denis.

[1] http://dev.gentoo.org/~calchan/sci-electronics/tests/index.xml
Comment 11 Markus Rothe (RETIRED) gentoo-dev 2007-12-21 10:13:56 UTC
nice testbench! I'm looking forward!
Comment 12 Evil Compile Person 2008-01-07 18:41:24 UTC
Aaaw, I want it fixed! ;)
Comment 13 Markus Rothe (RETIRED) gentoo-dev 2008-03-01 08:38:15 UTC
any news on this one? can we move forward to a working version?
Comment 14 Randall Wald 2008-05-27 05:48:22 UTC
Any progress on this?
Comment 15 DEMAINE Benoît-Pierre, aka DoubleHP 2008-05-27 10:37:28 UTC
I am now using stable, and 0.8.6 is installed and works for me. But after a check, I keyworded it, so, 0.8.6 may not be in stable. Randall, do you mean you tried 0.8.3 and it failed ?

to users: keyword iverilog, and install something recent.

to maintainers: please stabilise a recent version.

0.8.3 is ~ ... so, since we have to keyword for unstable, please, try 0.8.6 , and forget 0.8.3

This bug has to remain open until something is done in portage.
Comment 16 Randall Wald 2008-05-27 15:29:34 UTC
Demaine, I meant, "Any progress on stabilizing the versions which actually work?" I haven't actually bothered un-soft-masking the package, but by reading this bug it sounds like it would work, so I'm not worried about that.
Comment 17 Matti Bickel (RETIRED) gentoo-dev 2008-10-04 20:51:47 UTC
while trying out iverilog-vpi:
mabi@pluto gentoo % cp -r /usr/share/doc/iverilog-0.8.6/examples .
mabi@pluto gentoo % cd examples 
mabi@pluto examples % ls
clbff.v  des.v  hello.vl  hello_vpi.c  hello_vpi.vl  outff.v  pal_reg.v  show_vcd.vl  sqrt-virtex.v  sqrt.vl  xnf_add.vl  xram16x1.v
mabi@pluto examples % gcc -c -fpic hello_vpi.c 
mabi@pluto examples % gcc -shared -o hello_vpi.vpi hello_vpi.o -lvpi
mabi@pluto examples % iverilog-vpi hello_vpi.c                      
Compiling hello_vpi.c...
Making hello_vpi.vpi from  hello_vpi.o...
mabi@pluto examples % ./hello_vpi.vpi 
[1]    15053 segmentation fault  ./hello_vpi.vpi
mabi@pluto examples % 

Is that expected? some testbench i can run?
Comment 18 Jan Paesmans 2009-02-17 11:28:44 UTC
problem also occurs with stable version sci-electronics/iverilog-0.8.2 and a kernel 2.6.27-gentoo-r8
Comment 19 Samuli Suominen gentoo-dev 2010-04-09 15:54:34 UTC
Try 0.9.1.
Comment 20 Jaak Ristioja 2010-04-09 19:22:30 UTC
I don't remember why I CC'd myself for this bug, but iverilog-0.8.6 seems to build now (on a new amd64 system).

I wish you success fixing this. :)
Comment 21 DEMAINE Benoît-Pierre, aka DoubleHP 2010-04-11 17:02:29 UTC
After unmasking, compiled ok.