Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 172333 - net-misc/nxserver-freenx missing Xwindows dependency
Summary: net-misc/nxserver-freenx missing Xwindows dependency
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: NX Server Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-26 20:01 UTC by Adam Carheden
Modified: 2007-04-18 16:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Carheden 2007-03-26 20:01:31 UTC
net-misc/nxserver-freenx is missing a dependency on something related to Xwindows.I noticed this when installing nxserver-freenx on a box that didn't have xorg on it. I emerge icewm, windowmaker and nxserver-freenx-0.6.0 (from the overlay). Things seemed to work fine but the nx window never came up on the client. Eventually I got the "haven't recieved any data from server for a while, do you want to terminate" message. Then I emerged xrdp, which forced an xorg install. While it was installing, I continued to troubleshoot nx and it magically started working before I had change anything. I'm fairly sure this is because the xrdp emerge emerged something that nxserver-freenx should probably depend on.

Unfortunatly, xrdp emerged a lot of stuff, so I'm not sure exactly what package. Maybe I'll figure it out and post it here as a followup, but until then, maybe this will help others in my situation.

Reproducible: Always

Steps to Reproduce:
1. Install Gentoo
2. emerge layman
3. layman -a nx
4. emerge nxserver-freenx icewm # Adding the appropriate stuff to package.use
5. nxsetup --install --setup-nomachine-key --clean --purge # per pkg directions
6. Connect with your client (make sure you set it to run /etc/X11/Sessions/icewm)
7. Note that authentication and everything else appears to work, but your nx window never appears.
8. Emerge something that emerges X (like xrdp).
9. Connect with the client again. Note that it works now.

Actual Results:  
NX client didn't open a window

Expected Results:  
NX Client opens a window
Comment 1 Bernard Cafarelli gentoo-dev 2007-03-26 22:36:46 UTC
I'll look into reproducing this one, can you tell me which USE flags you used for nxserver-freenx?

Also, which revision of the overlay did you use? (you can run `svn info` in /usr/portage/local/layman/nx to get it) Last overlay ebuilds (as well as the ebuilds now in portage) had a fix for servers without X installed
Comment 2 Bernard Cafarelli gentoo-dev 2007-04-18 16:05:02 UTC
OK, freenx lacked deps on xauth (for nxsetup) and font-alias (for nxagent)

Fixed in CVS