Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 172047 - net-im/gaim-2.0.0_beta6 crashes in mono
Summary: net-im/gaim-2.0.0_beta6 crashes in mono
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-24 14:06 UTC by James
Modified: 2007-05-01 03:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James 2007-03-24 14:06:46 UTC
The following version is installed:
[I] net-im/gaim
     Available versions:  1.5.0 (~)2.0.0_beta5-r1 (~)2.0.0_beta5-r2 (~)2.0.0_beta5-r3 (~)2.0.0_beta6
     Installed versions:  2.0.0_beta6(23:46:42 20/03/07)(-avahi -bonjour -cjk -console crypt -custom-cflags dbus -debug -doc eds -gadu -gnutls -groupwise gstreamer gtk -meanwhile mono msn nls perl -qq sasl -silc spell ssl -startup-notification -tcl tk -xscreensaver)
     Homepage:            http://gaim.sourceforge.net/
     Description:         GTK Instant Messenger client


While using gain to link to MSN, it just aborted with the following output:
Stacktrace:


Native stacktrace:

        /usr/lib/libmono.so.0 [0xb6f602b3]
        /usr/lib/libmono.so.0 [0xb6f00c4a]
        [0xffffe440]
        gaim [0x8098ca3]
        /usr/lib/libglib-2.0.so.0 [0xb75965df]
        /usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x191) [0xb7565841]
        /usr/lib/libglib-2.0.so.0 [0xb756609f]
        /usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1b7) [0xb7566447]
        /usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xc1) [0xb7c09b71]
        gaim(main+0x8d7) [0x80ad877]
        /lib/libc.so.6(__libc_start_main+0xd8) [0xb7243838]
        gaim(gtk_widget_grab_focus+0x39) [0x8067601]

Debug info from gdb:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1222650192 (LWP 7929)]
[New Thread -1233462384 (LWP 7931)]
[New Thread -1233380464 (LWP 7930)]
0xffffe410 in __kernel_vsyscall ()
  3 Thread -1233380464 (LWP 7930)  0xffffe410 in __kernel_vsyscall ()
  2 Thread -1233462384 (LWP 7931)  0xffffe410 in __kernel_vsyscall ()
  1 Thread -1222650192 (LWP 7929)  0xffffe410 in __kernel_vsyscall ()

Thread 3 (Thread -1233380464 (LWP 7930)):
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb75eab66 in ?? () from /lib/libpthread.so.0
#2  0xb704363e in collection_thread (unused=0x0) at collection.c:34
#3  0xb75e34bb in start_thread () from /lib/libpthread.so.0
#4  0xb72ebdae in clone () from /lib/libc.so.6

Thread 2 (Thread -1233462384 (LWP 7931)):
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb75e78f6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb704631f in timedwait_signal_poll_cond (cond=0xb6c9b1dc, 
    mutex=0xb6c9b1c4, timeout=0x0, alertable=0) at handles.c:1413
#3  0xb7048b06 in _wapi_handle_timedwait_signal_handle (handle=0x404, 
    timeout=0x0, alertable=0) at handles.c:1493
#4  0xb7048b7a in _wapi_handle_wait_signal_handle (handle=0x404, alertable=0)
    at handles.c:1453
#5  0xb7058ba7 in WaitForSingleObjectEx (handle=0x404, timeout=4294967295, 
    alertable=0) at wait.c:200
#6  0xb6fd114c in finalizer_thread (unused=0x0) at gc.c:819
#7  0xb6ffaf58 in start_wrapper (data=0x813c690) at threads.c:308
#8  0xb7057c02 in thread_start_routine (args=0xb6b47b10) at threads.c:253
#9  0xb70764f5 in GC_start_routine () from /usr/lib/libmono.so.0
#10 0xb75e34bb in start_thread () from /lib/libpthread.so.0
#11 0xb72ebdae in clone () from /lib/libc.so.6

Thread 1 (Thread -1222650192 (LWP 7929)):
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb72e56f1 in ?? () from /lib/libc.so.6
#2  0xb7598818 in g_spawn_sync () from /usr/lib/libglib-2.0.so.0
#3  0xb7598c05 in g_spawn_command_line_sync () from /usr/lib/libglib-2.0.so.0
#4  0xb6f6036e in mono_handle_native_sigsegv (signal=11, ctx=0xbfe49afc)
    at mini-exceptions.c:1066
#5  0xb6f00c4a in sigsegv_signal_handler (_dummy=11, info=0xbfe49a7c, 
    context=0xbfe49afc) at mini.c:11108
#6  <signal handler called>
#7  0x08731002 in ?? ()
#8  0xb76efbb3 in url_fetch_recv_cb (url_data=0x86d3800, source=21, 
    cond=GAIM_INPUT_READ) at util.c:3337
#9  0x08098ca3 in gaim_gtk_io_invoke (source=0x8430060, condition=G_IO_IN, 
    data=0x84c77f0) at gtkeventloop.c:77
#10 0xb75965df in g_io_unix_dispatch () from /usr/lib/libglib-2.0.so.0
#11 0xb7565841 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#12 0xb756609f in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#13 0xb7566447 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#14 0xb7c09b71 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x080ad877 in main (argc=) at gtkmain.c:817
#0  0xffffe410 in __kernel_vsyscall ()


=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

Aborted


Reproducible: Couldn't Reproduce
Comment 1 Olivier Crete (RETIRED) gentoo-dev 2007-03-24 17:13:11 UTC
it crashed while running mono code... try rebuilding -mono
Comment 2 Olivier Crete (RETIRED) gentoo-dev 2007-05-01 03:44:33 UTC
I'm not gonna fix mono's suckiness ;)