Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 169738 - apache-2.0.59 won't build without sys-libs/db-4.3*
Summary: apache-2.0.59 won't build without sys-libs/db-4.3*
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2007-03-07 11:46 UTC by Neil Bothwick
Modified: 2007-03-07 13:34 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Neil Bothwick 2007-03-07 11:46:42 UTC
emerge --depclean -a offered to remove sys-libs/db-4.3.29-r2, so I let it.. revdep-rebuild then required apr-util and apache to be re-emerged. apr-util merged fine but apache gave the folowing. re-emerging db-4.3.29-r2 fixed it.

/usr/share/apr-0/build/libtool --silent --mode=link x86_64-pc-linux-gnu-gcc  -pthread  -march=athlon64 -O2 -pipe -fomit-frame-pointer  -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -DAP_HAVE_DESIGNATED_INITIALIZER   -I/usr/include/apr-0 -I/usr/include/db4.3 -I. -I/mnt/scratch/portage/net-www/apache-2.0.59-r2/work/httpd-2.0.59/os/unix -I/mnt/scratch/portage/net-www/apache-2.0.59-r2/work/httpd-2.0.59/server/mpm/worker -I/mnt/scratch/portage/net-www/apache-2.0.59-r2/work/httpd-2.0.59/modules/http -I/mnt/scratch/portage/net-www/apache-2.0.59-r2/work/httpd-2.0.59/modules/filters -I/mnt/scratch/portage/net-www/apache-2.0.59-r2/work/httpd-2.0.59/modules/proxy -I/mnt/scratch/portage/net-www/apache-2.0.59-r2/work/httpd-2.0.59/include -I/mnt/scratch/portage/net-www/apache-2.0.59-r2/work/httpd-2.0.59/modules/generators -I/usr/include/openssl -I/mnt/scratch/portage/net-www/apache-2.0.59-r2/work/httpd-2.0.59/modules/dav/main -export-dynamic -L/usr/lib64 -L/usr/lib   -o htdigest  htdigest.lo   -lz -lssl -lcrypto -ldl /mnt/scratch/portage/net-www/apache-2.0.59-r2/work/httpd-2.0.59/srclib/pcre/ /usr/lib64/ -lgdbm -ldb-4.3 -lexpat /usr/lib64/ -lrt -lm -lcrypt -lnsl -lpthread -ldl
libtool: link: cannot find the library `/usr/lib64/'
make[2]: *** [htpasswd] Error 1
make[2]: *** Waiting for unfinished jobs....
libtool: link: cannot find the library `/usr/lib64/'
make[2]: *** [htdigest] Error 1
make[2]: Leaving directory `/mnt/scratch/portage/net-www/apache-2.0.59-r2/work/httpd-2.0.59/support'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/mnt/scratch/portage/net-www/apache-2.0.59-r2/work/httpd-2.0.59/support'
make: *** [all-recursive] Error 1

!!! ERROR: net-www/apache-2.0.59-r2 failed.
Call stack:, line 1614:   Called dyn_compile, line 971:   Called qa_call 'src_compile'
  environment, line 3536:   Called src_compile
  apache-2.0.59-r2.ebuild, line 188:   Called die

$ eix -e db
[I] sys-libs/db
     Available versions:
        (1)     1.85-r1 1.85-r2 1.85-r3
        (3)     3.2.9-r10 3.2.9-r11
        (4.2)   4.2.52_p2-r1 4.2.52_p4-r2
        (4.3)   (~)4.3.29-r2
        (4.4)   (~)4.4.20_p4
        (4.5)   (~)4.5.20_p2
     Installed versions:  1.85-r3(1)(01:31:47 09/09/06) 3.2.9-r11(3)(18:40:32 01/09/06)(-doc java -test)
                          4.5.20_p2(4.5)(18:20:40 05/03/07)(-bootstrap -doc -elibc_FreeBSD java -nocxx -tcl -test)
     Description:         Oracle Berkeley DB

$ emerge --info
Portage (default-linux/amd64/2006.1/desktop, gcc-4.1.2, glibc-2.5-r0, 2.6.20-gentoo x86_64)
System uname: 2.6.20-gentoo x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System release 1.12.9
Timestamp of tree: Wed, 07 Mar 2007 06:50:01 +0000
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.31-r4
dev-lang/python:     2.5-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.15
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.20-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /etc/env.d /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/init.d /etc/java-config/vms/ /etc/php/apache1-php5/ext-active/ /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
FEATURES="autoconfig buildpkg ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTDIR_OVERLAY="/mnt/portage/layman/sunrise /mnt/portage/local"
USE="X aac aalib alsa amd64 apache2 asf audiofile beagle berkdb bitmap-fonts bluetooth bzip2 cairo cddb cdr cli cracklib crypt cups curl dbus directfb dv dvb dvd dvdr dvdread encode exif fam ffmpeg flac foomaticdb gdbm gif gimp gimpprint gphoto2 gpm gtk gtk2 hal iconv ieee1394 imagemagick isdnlog jabber java jbig jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility kipi lesstif libg++ libwww lirc lm_sensors mad mailwrapper midi mng mp3 mpeg mplayer musicbrainz mysql ncurses nptl nptlonly nsplugin nvidia offensive ogg opengl oss pcre pda pdf pic png ppds pppd python qt3 qt4 quicktime readline reflection samba scanner sdl session slp spell spl ssl svg tcltk tcpd theora threads tiff truetype truetype-fonts type1-fonts udev usb v4l v4l2 vorbis xcomposite xfs xml xorg xscreensaver xv xvid zlib zvbi" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" CAMERAS="canon nikon" DVB_CARDS="usb-wt220u" ELIBC="glibc" INPUT_DEVICES="keyboard mouse aiptek" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" LIRC_DEVICES="devinput" USERLAND="GNU" VIDEO_CARDS="vesa nv nvidia"
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-03-07 11:49:13 UTC
Re-emerge dev-libs/apr as well.
Comment 2 Neil Bothwick 2007-03-07 12:07:29 UTC
Sorry, I should have mentioned that I tried that. "emerge apr apr-utils apache" failed just the same.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-03-07 12:19:01 UTC
emerge -1 =dev-libs/apr-0*
Comment 4 Neil Bothwick 2007-03-07 13:28:18 UTC
Doh! I hadn't noticed that apr was slotted. dev-libs/apr-0.9.12 emerged OK but dev-libs/apr-util-0.9.12 gave the following error. Apache still gives the same error, but that's probably down to apr-util not being re-emerged.

checking for gdbm.h... yes
checking for gdbm_open in -lgdbm... yes
configure: error: Berkeley DB not found.

!!! Please attach the following file when filing a report to
!!! /mnt/scratch/portage/dev-libs/apr-util-0.9.12/work/apr-util-0.9.12/config.log

!!! ERROR: dev-libs/apr-util-0.9.12 failed.
Call stack:, line 1614:   Called dyn_compile, line 971:   Called qa_call 'src_compile'
  environment, line 3966:   Called src_compile
  apr-util-0.9.12.ebuild, line 51:   Called econf '--datadir=/usr/share/apr-util-0' '--with-apr=/usr' '--with-expat=/usr' '--with-gdbm' '--with-dbm=db45' '--with-berkeley-db=/usr/include/db4.5:/usr/lib64', line 577:   Called die

This looks like bug #169507 but the patch from there makes no difference.

I'll take this over to that bug if you think it's a dupe.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-03-07 13:34:44 UTC
Closing this, not an apache bug. :)