Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 167862 - media-video/mjpegtools-1.8.0-r1 - mpg's made by mplex cause CRC errors in mplayer
Summary: media-video/mjpegtools-1.8.0-r1 - mpg's made by mplex cause CRC errors in mpl...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High minor (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-21 10:53 UTC by Daiajo Tibdixious
Modified: 2009-07-22 23:26 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daiajo Tibdixious 2007-02-21 10:53:28 UTC
I am following the "How to author AVI->DVD with menus using Linux only!"
http://forums.gentoo.org/viewtopic.php?t=117709
One step is to create a picture, then replicate it to several frames to make a movie, using:
$ convert background.png ppm:- | ppmtoy4m -n50 -F25:1 -A59:54 -I p -r -S 420mpeg2 | mpeg2enc -n p -f8 -b5000 -a2 -o background.m2v
the resultant m2v file is playable in mplayer without errors.
The next step is to combine this movie with sound to create the final mpg:
$ mplex -f 8 --mux-limit 2 -o background.mpg background.m2v 096.ac3
the "096.ac3" is the sound track from the avi file created from a previous step. The sound file is much longer than the m2v file, so I added --mux_limit which is not in the guide to limit it to 2 seconds.
The ac3 file is playable in mplayer without errors.
Playing the resultant mpg file (I've tried several different episodes of the same series) all give:
VO: [xv] 640x480 => 640x480 Planar YV12
a52: CRC check failed!  0.009 ct:  0.049  46/ 46  7%  4%  0.6% 0 0
a52: error at resampling
A:   2.0 V:   2.0 A-V: -0.012 ct:  0.045  48/ 48  7%  4%  0.6% 0 0
after playing about 1 second.
I've tried different values on mux_limit to no avail.

Reproducible: Always

Steps to Reproduce:
1. follow http://forums.gentoo.org/viewtopic.php?t=117709
2. at the menu mplex step, add --mux_limit
3. mplayer the mpg output file

Actual Results:  
$ mplayer *.mpg
MPlayer 1.0rc1-4.1.1 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) 64 Processor 3000+ (Family: 15, Model: 12, Stepping: 0)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.

Playing background.mpg.
MPEG-PS file format detected.
VIDEO:  MPEG2  640x480  (aspect 2)  25.000 fps  5000.0 kbps (625.0 kbyte/s)
Opening video filter: [screenshot]
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 640 x 480 (preferred colorspace: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 224.0 kbit/14.58% (ratio: 28000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 640 x 480 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
SwScaler: using unscaled yuv420p -> bgr24 special converter
VO: [xv] 640x480 => 640x480 Planar YV12
a52: CRC check failed!  0.009 ct:  0.049  46/ 46  7%  4%  0.6% 0 0
a52: error at resampling
A:   2.0 V:   2.0 A-V: -0.012 ct:  0.045  48/ 48  7%  4%  0.6% 0 0

Exiting... (End of file)


Expected Results:  
Same as actual without the CRC error.

# eix -n media-video/mjpegtools
[I] media-video/mjpegtools
     Available versions:  (1)  1.8.0-r1 ~1.8.0-r2
     Installed:           1.8.0-r1(1)(11:17:28 AM 02/03/2007)(-3dnow X -dga -dv gtk -mmx png quicktime sdl -sse -v4l -yv12)
     Homepage:            http://mjpeg.sourceforge.net/
     Description:         Tools for MJPEG video

# eix -n mplayer
[I] media-video/mplayer
     Available versions:  1.0_pre8 ~1.0_pre8-r1 1.0_rc1 ~1.0_rc1-r1 1.0_rc1-r2
     Installed:           1.0_rc1-r2(11:44:11 PM 02/14/2007)(-3dfx 3dnow 3dnowext X -aac -aalib alsa -altivec -amr -arts -bidi -bindist -bl -cdparanoia -cpudetection -custom-cflags -debug -dga directfb -doc dts -dv -dvb dvd dvdread -enca encode esd fbcon -ggi gif gtk iconv ipv6 -jack -joystick jpeg -libcaca -linguas_bg -linguas_cs -linguas_da -linguas_de -linguas_el linguas_en -linguas_es -linguas_fr -linguas_hu -linguas_ja -linguas_ko -linguas_mk -linguas_nl -linguas_no -linguas_pl -linguas_pt_BR -linguas_ro -linguas_ru -linguas_sk -linguas_tr -linguas_uk -linguas_zh_CN -linguas_zh_TW -lirc live livecd -lzo mad -matrox mmx mmxext musepack -nas -openal opengl -oss png real -rtc -samba sdl -speex sse sse2 -svga -tga theora truetype unicode -v4l -v4l2 vorbis -win32codecs -x264 xanim xinerama xv -xvid -xvmc)
     Homepage:            http://www.mplayerhq.hu/
     Description:         Media Player for Linux

# emerge --info
Portage 2.1.2-r9 (default-linux/amd64/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r6 x86_64)
=================================================================
System uname: 2.6.18-gentoo-r6 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System release 1.12.9
Timestamp of tree: Wed, 14 Feb 2007 01:28:01 +0000
dev-java/java-config: 1.3.7, 2.0.31
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig buildpkg distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US"
LC_ALL="en_US"
LINGUAS="en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d alsa amd64 avi berkdb bitmap-fonts cairo cdr cli cracklib crypt dbus directfb dlloader dri dts dvd dvdr dvdread eds emboss encode esd fam fbcon firefox fortran gdbm gif gpm gstreamer gtk gtk2 hal iconv ipv6 isdnlog java javascript jpeg kde lesstif libg++ live livecd mad matroska midi mikmod mmx2 motif mp3 mpeg multislot musepack musicbrainz ncurses nls nptl nptlonly ogg oggvorbis opengl pam pcre pdf perl png ppds pppd python qt qt3 qt4 quicktime readline reflection sdl session spell spl ssl tcpd theora truetype truetype-fonts type1-fonts unicode usb vcd vim-with-x vorbis xanim xinerama xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="radeon vesa fbdev"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Steve Dibb (RETIRED) gentoo-dev 2009-01-10 12:21:55 UTC
What's the status with any newer versions?
Comment 2 Samuli Suominen (RETIRED) gentoo-dev 2009-07-22 23:26:24 UTC
What's the status with any newer versions?