Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 167708 - app-office/koffice-1.6.1-r1 fail to compile
Summary: app-office/koffice-1.6.1-r1 fail to compile
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2007-02-20 02:16 UTC by Maxi Combina
Modified: 2007-04-08 13:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Maxi Combina 2007-02-20 02:16:45 UTC
I have tried to compile koffice, but it has failed with the same error several times:

/bin/sh ../libtool --silent --tag=CXX --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../lib/kofficeui -I../lib/kofficeui -I../lib/kofficecore -I../lib/kofficecore -I../lib/store -I../lib/store -I../lib/kwmf -I../lib/kwmf -I../lib/kopalette -I../lib/kopalette -I../lib/kformula -I../lib/kotext -I../lib/kotext -I/usr/kde/3.5/include -I/usr/qt/3/include -I.  -I/usr/kde/3.5/include  -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -O2 -pipe -march=athlon64 -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -DHAVE_KNEWSTUFF -UQT_NO_STL -c -o KWVariable.lo KWVariable.cpp
KWAnchor.cpp: In member function 'virtual void KWAnchor::draw(QPainter*, int, int, int, int, int, int, const QColorGroup&, bool)':
KWAnchor.cpp:125: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:> for instructions.
/usr/qt/3/bin/moc ./KWFrameDia.h -o KWFrameDia.moc
/usr/qt/3/bin/moc ./KWFootNoteDia.h -o KWFootNoteDia.moc
/bin/sh ../libtool --silent --tag=CXX --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../lib/kofficeui -I../lib/kofficeui -I../lib/kofficecore -I../lib/kofficecore -I../lib/store -I../lib/store -I../lib/kwmf -I../lib/kwmf -I../lib/kopalette -I../lib/kopalette -I../lib/kformula -I../lib/kotext -I../lib/kotext -I/usr/kde/3.5/include -I/usr/qt/3/include -I.  -I/usr/kde/3.5/include  -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -O2 -pipe -march=athlon64 -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -DHAVE_KNEWSTUFF -UQT_NO_STL -c -o KWFrameStyle.lo KWFrameStyle.cpp
The bug is not reproducible, so it is likely a hardware or OS problem.
make[3]: *** [KWAnchor.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/app-office/koffice-1.6.1-r1/work/koffice-1.6.1/kword'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-office/koffice-1.6.1-r1/work/koffice-1.6.1/kword'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-office/koffice-1.6.1-r1/work/koffice-1.6.1'
make: *** [all] Error 2

!!! ERROR: app-office/koffice-1.6.1-r1 failed.
Call stack:, line 1614:   Called dyn_compile, line 971:   Called qa_call 'src_compile'
  environment, line 4771:   Called src_compile
  koffice-1.6.1-r1.ebuild, line 84:   Called kde_src_compile
  kde.eclass, line 170:   Called kde_src_compile 'all'
  kde.eclass, line 340:   Called kde_src_compile 'myconf' 'configure' 'make'
  kde.eclass, line 336:   Called die

!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/app-office/koffice-1.6.1-r1/temp/build.log'.

It says "internal compiler error", and then 
it says that the bug is not reproducible, and that it is likely to be a hardware or OS error... but I highly doubt it, since I have all the other packages up-to-date, and this build always has failed with the same error.

Reproducible: Always

Steps to Reproduce:
1. emerge koffice 
2. seat to have some coffee

#emerge --info
Portage 2.1.2-r9 (default-linux/amd64/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r6 x86_64)
System uname: 2.6.18-gentoo-r6 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System release 1.12.9
Timestamp of tree: Sun, 18 Feb 2007 22:30:02 +0000
dev-java/java-config: 1.3.7, 2.0.31
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
CFLAGS="-O2 -pipe -march=athlon64"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib64/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=athlon64"
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
LINGUAS="en es pt it"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X aac aalib alsa amd64 arts audiofile bash-completion berkdb bitmap-fonts bzip2 cairo cdr cgi chm cli cracklib crypt cups curl dbus directfb dlloader doc dri dvd dvdr dvdread eds emboss encode esd exif expat fam fastcgi fbcon ffmpeg firefox flac foomaticdb fortran gd gdbm gif glut gmp gnome gphoto2 gpm gstreamer gtk gtk1 gtk2 gtkhtml hal iconv idn imagemagick isdnlog java jpeg kde lcms libcaca libg++ lm_sensors mad midi mikmod mng motif mozilla mp3 mpeg ncurses nls nptl nptlonly nvidia offensive ogg opengl pam pcre pdf perl png ppds pppd python qt qt3 qt4 quicktime readline reflection samba sdl session slang spell spl ssl svg tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts unicode visualization vorbis xml xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en es pt it" USERLAND="GNU" VIDEO_CARDS="vesa fbdev"

atenea ~ # gcc --version
gcc (GCC) 4.1.1 (Gentoo 4.1.1-r3)
Comment 1 Przemyslaw Maciag (RETIRED) gentoo-dev 2007-03-01 02:18:09 UTC
> KWAnchor.cpp:125: internal compiler error: Segmentation fault

this is really bad! sources _may_ (not need to) be correct, but you system is not.

I would recommend you to run emerge -e world

Comment 2 Carsten Lohrke (RETIRED) gentoo-dev 2007-03-18 22:17:22 UTC
(In reply to comment #1)
> I would recommend you to run emerge -e world

Not helpful. Options are either a compiler bug or broken hardware on an ICE.

Maxi, to quote you: "... and this build always has failed with the same error." 

It doesn't matter, if it's the same error, but if you encounter it always in the same line or not.
Comment 3 Carsten Lohrke (RETIRED) gentoo-dev 2007-04-08 13:00:11 UTC
No feedback...