Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 166609 - emerge --deep --update dependency problem in portage 2.1.2-r9
Summary: emerge --deep --update dependency problem in portage 2.1.2-r9
Status: RESOLVED DUPLICATE of bug 1343
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-13 03:23 UTC by vicaya
Modified: 2007-02-13 09:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vicaya 2007-02-13 03:23:23 UTC
# emerge -duDpvt world produces this:

!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

('ebuild', '/', 'sys-apps/suspend2-userui-0.6.4-r2', 'nomerge') pulled in by
  ('ebuild', '/', 'sys-kernel/suspend2-sources-2.6.19-r2', 'nomerge')

('ebuild', '/', 'sys-apps/suspend2-userui-0.7.0', 'merge') (no parents)

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

<end quote>

Since the current kernel requires a lower version, shouldn't emerge just not upgrade the package (suspend2-userui in this case).

# eselect kernel list

Available kernel symlink targets:
  [1]   linux-2.6.17-suspend2-r6
  [2]   linux-2.6.18-suspend2-r3
  [3]   linux-2.6.19-suspend2-r2 *

Relevant parts from the debug output:
Depstring: sys-apps/suspend2-userui
Priority: soft
Candidates: ['sys-apps/suspend2-userui']
   ebuild: sys-apps/suspend2-userui-0.7.0

Parent:    ('ebuild', '/', 'sys-apps/suspend2-userui-0.7.0', 'merge')
...
Exiting... ('ebuild', '/', 'sys-apps/suspend2-userui-0.7.0', 'merge')

Parent:    ('ebuild', '/', 'sys-apps/suspend2-userui-0.7.0', 'merge')
Parent:    ('ebuild', '/', 'sys-kernel/suspend2-sources-2.6.19-r2', 'nomerge')
Depstring: ~sys-apps/suspend2-userui-0.6.4 >=sys-power/hibernate-script-1.93-r6 !build? ( >=sys-libs/ncurses-5.2 sys-devel/make ) virtual/dev-manager
Priority: medium
Candidates: ['~sys-apps/suspend2-userui-0.6.4', 'sys-fs/udev', 'sys-devel/make', '>=sys-power/hibernate-script-1.93-r6', '>=sys-libs/ncurses-5.2']
   ebuild: sys-apps/suspend2-userui-0.6.4-r2

Parent:    ('ebuild', '/', 'sys-apps/suspend2-userui-0.6.4-r2', 'nomerge')
Depstring:
Priority: hard
Candidates: []
Exiting... ('ebuild', '/', 'sys-apps/suspend2-userui-0.6.4-r2', 'nomerge')

Parent:    ('ebuild', '/', 'sys-apps/suspend2-userui-0.6.4-r2', 'nomerge')
Candidates: ['>=media-libs/libmng-1.0.5', 'sys-libs/zlib', 'media-libs/libpng', 'media-li
bs/lcms', 'media-libs/jpeg', 'sys-libs/glibc', 'media-libs/freetype']
   ebuild: media-libs/libmng-1.0.9-r1
   ebuild: sys-libs/zlib-1.2.3-r1
   ebuild: media-libs/libpng-1.2.16
   ebuild: media-libs/lcms-1.15
   ebuild: media-libs/jpeg-6b-r7
   ebuild: sys-libs/glibc-2.5
   ebuild: media-libs/freetype-2.1.10-r2
Exiting... ('ebuild', '/', 'sys-apps/suspend2-userui-0.6.4-r2', 'nomerge')
   ebuild: sys-fs/udev-104-r11
   ebuild: sys-devel/make-3.81
   ebuild: sys-power/hibernate-script-1.93-r6
   ebuild: sys-libs/ncurses-5.5-r3
Exiting... ('ebuild', '/', 'sys-kernel/suspend2-sources-2.6.19-r2', 'nomerge')
Exiting... None
Comment 1 Bo Ørsted Andresen (RETIRED) gentoo-dev 2007-02-13 03:30:27 UTC
This is a dupe of bug #1343. You need to either mask sys-apps/suspend2-userui-0.7.0 or unmask =sys-kernel/suspend2-sources-2.6.20*
Comment 2 vicaya 2007-02-13 04:24:14 UTC
Hmm... Just noticed suspend2-sources-2.6.20 is in portage, hard masked. 
Comment 3 Bo Ørsted Andresen (RETIRED) gentoo-dev 2007-02-13 05:03:18 UTC
(In reply to comment #2)
> Hmm... Just noticed suspend2-sources-2.6.20 is in portage, hard masked. 

Arguably suspend2-userui-0.7.0 should be hard masked too until 2.6.20 is unmasked.
Comment 4 Alon Bar-Lev gentoo-dev 2007-02-13 06:15:29 UTC
OK.
Added, although I don't understand why it was pulled.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-02-13 09:00:11 UTC

*** This bug has been marked as a duplicate of bug 1343 ***