Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 166554 (VinX) - sys-apps/coreutils-6.7-r1 fails (AT_FDCWD undeclared)
Summary: sys-apps/coreutils-6.7-r1 fails (AT_FDCWD undeclared)
Alias: VinX
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2007-02-12 19:41 UTC by Vincenzo Laurenziello
Modified: 2007-02-13 14:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

this is the build.log (build.log,55.21 KB, text/plain)
2007-02-12 19:43 UTC, Vincenzo Laurenziello
my emerge --info (,3.06 KB, text/plain)
2007-02-12 22:49 UTC, Vincenzo Laurenziello
config.log (config.log,886.48 KB, text/plain)
2007-02-13 11:52 UTC, Vincenzo Laurenziello
my `readelf -s /lib/ | grep at@ ` (readelf.glibc,1.88 KB, text/plain)
2007-02-13 11:54 UTC, Vincenzo Laurenziello
utimens.i for p4 (utimens.i,98.52 KB, text/plain)
2007-02-13 12:42 UTC, Vincenzo Laurenziello

Note You need to log in before you can comment on or make changes to this bug.
Description Vincenzo Laurenziello 2007-02-12 19:41:05 UTC
this is the error:
i686-pc-linux-gnu-gcc -std=gnu99  -I.      -O2 -march=pentium4 -MT utimens.o -MD -MP -MF .deps/utimens.Tpo -c -o utimens.o utimens.c
utimens.c: In function `futimens':
utimens.c:117: warning: implicit declaration of function `futimesat'
utimens.c:117: error: `AT_FDCWD' undeclared (first use in this function)
utimens.c:117: error: (Each undeclared identifier is reported only once
utimens.c:117: error: for each function it appears in.)
make[2]: *** [utimens.o] Error 1
my USE FLAG are:
aiglx alsa amr amuled asf artworkextra audiofile bash-completion bzip2 cdrom cdr crypt curl directfb dvd encode esd extensions fam ffmpeg gtk2 idn imagemagick jpeg jack kde lcms ldap mmx mmxext mng mozilla nls nptl nptlonly openal pam pdf ruby samba sdl slang sqlite ssl sse sse2 svg tcltk tetex tiff unicode usb utempter wifi win32codecs xcomposite xine xmms gtk gnome ipv6
now i'm using:
glibc 2.5
linux kernel and headers 2.6.20

I tried to build coreutils-6.4 but I had same error.
I can reproduce this error with: `emerge coreutils`.
Comment 1 Vincenzo Laurenziello 2007-02-12 19:43:17 UTC
Created attachment 109986 [details]
this is the build.log
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-02-12 22:36:12 UTC
emerge --info please.
Comment 3 Vincenzo Laurenziello 2007-02-12 22:49:02 UTC
Created attachment 110007 [details]
my emerge --info
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-02-12 22:51:57 UTC
You need to reopen bugs after providing requested info, noone will notice again otherwise.
Comment 5 Vincenzo Laurenziello 2007-02-12 22:58:43 UTC
Portage 2.1.2-r9 (default-linux/x86/2006.1/desktop, gcc-3.4.6, glibc-2.5-r0, i686)
System uname: i686 unknown
Gentoo Base System version 1.12.9
Timestamp of tree: Sat, 10 Feb 2007 22:59:01 +0000
dev-java/java-config: 1.3.0-r2, 2.0.27-r1
dev-lang/python:     2.3.5-r2, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.20
CFLAGS="-O2 -march=pentium4"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium4"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
LINGUAS="en it"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X aiglx alsa amr amuled arts artworkextra asf audiofile bash-completion berkdb bitmap-fonts bzip2 cairo cdr cdrom cli cracklib crypt cups curl dbus directfb dlloader dri dvd dvdr eds emboss encode esd extensions fam ffmpeg firefox fortran gdbm gif gnome gpm gstreamer gtk gtk2 hal iconv idn imagemagick ipv6 isdnlog jack jpeg kde lcms ldap libg++ mad midi mikmod mmx mmxext mng mozilla mp3 mpeg ncurses nls nptl nptlonly ogg openal opengl oss pam pcre pdf perl png ppds pppd python qt3 qt4 quicktime readline reflection ruby samba sdl session slang spell spl sqlite sse sse2 ssl svg tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts udev unicode usb utempter vorbis wifi win32codecs x86 xcomposite xine xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en it" USERLAND="GNU" VIDEO_CARDS="sis"
Comment 6 SpanKY gentoo-dev 2007-02-13 00:46:03 UTC
attach the file:

and post the output of:
readelf -s /lib/ | grep at@

also, remove whatever busybox hacks you have on your system
Comment 7 Vincenzo Laurenziello 2007-02-13 11:52:22 UTC
Created attachment 110051 [details]
Comment 8 Vincenzo Laurenziello 2007-02-13 11:54:02 UTC
Created attachment 110052 [details]
my `readelf -s /lib/ | grep at@ `
Comment 9 Vincenzo Laurenziello 2007-02-13 12:04:44 UTC
(In reply to comment #6)
> also, remove whatever busybox hacks you have on your system
uhm... i cannot remove busybox because find of findutils package compile but don't work, i think that if we solve this problem, find returns to work.
Please where are these hacks? I try to solve them!
Comment 10 SpanKY gentoo-dev 2007-02-13 12:18:15 UTC
go into /var/tmp/portage/sys-apps/coreutils-6.7-r1/work/coreutils-6.7/lib

and run:
gcc -DHAVE_CONFIG_H -DLIBDIR=\"/usr/lib64\" -I. -I.. -O2 -march=k8 -pipe \
   -E -dD -o utimens.i utimens.c

and then post the utimens.i file as an attachment

figure out your system ... replacing 'find' with the busybox find will not work
Comment 11 Vincenzo Laurenziello 2007-02-13 12:40:51 UTC
(In reply to comment #10)
> and run:
> gcc -DHAVE_CONFIG_H -DLIBDIR=\"/usr/lib64\" -I. -I.. -O2 -march=k8 -pipe \
>    -E -dD -o utimens.i utimens.c
sorry i have a pentium4 with 32bit... i'm changing this row to:
gcc -DHAVE_CONFIG_H -DLIBDIR=\"/usr/lib\" -I. -I.. -O2 -march=pentium4 -pipe \
   -E -dD -o utimens.i utimens.c

> and then post the utimens.i file as an attachment

> figure out your system ... replacing 'find' with the busybox find will not work
i know, but i can do same commands...

Comment 12 Vincenzo Laurenziello 2007-02-13 12:42:11 UTC
Created attachment 110055 [details]
utimens.i for p4
Comment 13 Vincenzo Laurenziello 2007-02-13 12:45:23 UTC
Comment 14 SpanKY gentoo-dev 2007-02-13 12:52:40 UTC
i dont know what you've done to your system, but you've also screwed around a lot

you've replaced standard utils with busybox

you have crap in /usr/local/include that is overriding the standard glibc headers in /usr/include

fix your system and coreutils should emerge fine ... if you need help fixing your system, please use
Comment 15 Vincenzo Laurenziello 2007-02-13 13:13:28 UTC
(In reply to comment #14)
> you've replaced standard utils with busybox
only find...

> you have crap in /usr/local/include that is overriding the standard glibc
> headers in /usr/include
absolutly not!!
vinTux ~ # ls -la /usr/local/include/
total 104
drwxr-xr-x  6 root root  4096 Oct 30 20:56 .
drwxr-xr-x 11 root root  4096 Oct 30 19:40 ..
drwxr-xr-x  2 root root  4096 Oct 30 19:52 compiz
drwxr-xr-x  2 root root  4096 Oct 30 20:56 drm
-rw-r--r--  1 root root 11286 Sep 29 23:24 features.h
-rw-r--r--  1 root root  2416 Sep 29 23:24 gnu-versions.h
drwxr-xr-x  3 root root  4096 Feb 21  2006 irssi
-rw-r--r--  1 root root  5773 Oct 16 00:21 lauxlib.h
-rw-r--r--  1 root root  4550 Sep 29 23:24 limits.h
-rw-r--r--  1 root root 11612 Oct 16 00:21 lua.h
-rw-r--r--  1 root root   191 Oct 16 00:21 lua.hpp
-rw-r--r--  1 root root 22236 Oct 16 00:21 luaconf.h
-rw-r--r--  1 root root  1022 Oct 16 00:21 lualib.h
drwxr-xr-x  2 root root  4096 Oct 16 00:24 ode
-rw-r--r--  1 root root  2029 Sep 29 23:24 values.h
vinTux ~ # 

gnu-version.h is the only file present in /usr/include too. But:
vinTux ~ # diff /usr/include/gnu-versions.h /usr/include/gnu-versions.h
vinTux ~ #  

> fix your system and coreutils should emerge fine ... if you need help fixing
> your system, please use
emerge -e world?
Comment 16 SpanKY gentoo-dev 2007-02-13 13:39:57 UTC
wrong, that isnt the only header

if you screw with the standard setup and things break, you get to pick up the pieces, not me
Comment 17 Vincenzo Laurenziello 2007-02-13 14:28:06 UTC
(In reply to comment #16)
> wrong, that isnt the only header
ok i found /usr/local/include/features.h... i removed this file
now it work!
thank u so much!!