Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 165135 - games-sports/ultimatestunts-0.7.0 won't compile with media-libs/openal-0.0.8-r1
Summary: games-sports/ultimatestunts-0.7.0 won't compile with media-libs/openal-0.0.8-r1
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Games
Depends on:
Reported: 2007-02-03 15:22 UTC by Martin Jansa
Modified: 2007-08-29 19:01 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Patch to /usr/include/AL/alc.h (openal.patch,1.11 KB, patch)
2007-02-03 15:25 UTC, Martin Jansa
Details | Diff
Better patch (openal.patch,1.12 KB, patch)
2007-02-03 15:27 UTC, Martin Jansa
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Jansa 2007-02-03 15:22:58 UTC
Building failed in /usr/include/AL/alc.h because ALCvoid

In file included from /usr/include/AL/alut.h:13,
                 from sndsample.cpp:40:
/usr/include/AL/alc.h:190: error: '<anonymous>' has incomplete type
/usr/include/AL/alc.h:190: error: invalid use of 'ALCvoid'
/usr/include/AL/alc.h:251: error: '<anonymous>' has incomplete type
/usr/include/AL/alc.h:251: error: invalid use of 'ALCvoid'
make[2]: *** [sndsample.o] Error 1
make[2]: *** Waiting for unfinished jobs....
In file included from /usr/include/AL/alut.h:13,
                 from music.cpp:95:
/usr/include/AL/alc.h:190: error: '<anonymous>' has incomplete type
/usr/include/AL/alc.h:190: error: invalid use of 'ALCvoid'
/usr/include/AL/alc.h:251: error: '<anonymous>' has incomplete type
/usr/include/AL/alc.h:251: error: invalid use of 'ALCvoid'
make[2]: *** [music.o] Error 1
make[2]: Leaving directory `/tmp/paludis/games-sports/ultimatestunts-0.7.0/work/ultimatestunts-src
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/paludis/games-sports/ultimatestunts-0.7.0/work/ultimatestunts-src
make: *** [all] Error 2

!!! ERROR in games-sports/ultimatestunts-0.7.0:
!!! In src_compile at line 45
!!! emake failed

Reproducible: Always
Comment 1 Martin Jansa 2007-02-03 15:25:01 UTC
Created attachment 109015 [details, diff]
Patch to /usr/include/AL/alc.h

Patch used to change
/usr/include/AL/alc.h, than ultimatestunts compiled without problem
(probably should be solved in ebuild of openal)
Comment 2 Martin Jansa 2007-02-03 15:27:58 UTC
Created attachment 109016 [details, diff]
Better patch

Previous one was reversed sorry..
Comment 3 Martin Jansa 2007-02-04 16:29:57 UTC
I know it's unsupported glibc,gcc and flags. I have tried to rebuild

[ebuild   R   ] media-libs/openal-0.0.8-r1  USE="alsa mp3 sdl vorbis -arts -debug -esd" 0 kB
[ebuild   R   ] media-libs/freealut-1.1.0  0 kB
[ebuild   R   ] games-sports/ultimatestunts-0.7.0  USE="nls" 0 kB

with portage instead of paludis, gcc version 4.1.0-alpha20070129 and with flags
CFLAGS="-O2 -march=k8"
CXXFLAGS="-O2 -march=k8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=both"

/usr/include/AL/alc.h is the same but gcc-4.1 seems happy with that. So sorry for bad report, I'll wait untill gcc-4.2 is supported :).

# emerge --info
Portage 2.1.2-r7 (default-linux/amd64/2006.1/desktop, gcc-4.2.0-alpha20070131/amd64-vanilla, glibc-, 2.6.20-rc7 x86_64)
System uname: 2.6.20-rc7 x86_64 AMD Athlon(tm) 64 Processor 3700+
Gentoo Base System release 1.13.0_alpha12
Timestamp of tree: Sun, 04 Feb 2007 11:30:01 +0000
ccache version 2.4 [enabled]
app-admin/eselect-compiler: 2.0.0_rc2-r1
dev-java/java-config: 1.3.7, 2.0.31-r3
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
!!! Invalid db entry: /var/db/pkg/sys-apps/paludis-scm
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/gcc-config: 2.0.0_rc1
sys-devel/libtool:   1.5.22
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-Os -march=k8 -pipe -ftracer -ftree-vectorize -frename-registers -fweb -fno-ident -mmmx -msse -DNDEBUG -DG_DISABLE_ASSERT -DNO_DEBUG"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/eselect/compiler /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /var/lib/rpm"
CXXFLAGS="-Os -march=k8 -pipe -ftracer -ftree-vectorize -frename-registers -fweb -fno-ident -mmmx -msse -DNDEBUG -DG_DISABLE_ASSERT -DNO_DEBUG -fvisibility-inlines-hidden -fvisibility=hidden"
FEATURES="autoconfig ccache cvs distlocks metadata-transfer parallel-fetch prelink sandbox sfperms strict userpriv usersandbox"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=both"
LINGUAS="cs en_GB en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X aalib acpi aiglx alsa amd64 amr apache2 bash-completion berkdb bidi bitmap-fonts bluetooth bzip2 cairo ccache cdparanoia cdr cdrom cgi cli cracklib crypt cups dba dbus dga dio dlloader doc dri dvb dvd dvdr emboss encode fam fbcon ffmpeg firefox flac flash fmod font-server ftp gb gd gif gkrellm glibc-omitfp glut gnokii gnutls gpg2-experimental gpgme gpm gzip hal iconv icq imagemagick imap imlib innodb ipv6 irc irda isdnlog jabber java java5 javascript jikes joystick jpeg kde kdeenablefinal kdehiddenvisibility kqemu krb4 lame libcaca libg++ linuxthreads-tls lirc live lm_sensors logrotate mad maildir matroska midi mikmod mime mozilla mozsvg mp3 mp4 mpeg mysql mysqli ncurses network nls nntp nocd nptl nptlonly nsplugin nvidia ogg openal opengl opera pam pcre pcsc-lite pdf perl php pic png pop posix ppds pppd python qt3 qt4 quicktime readline reflection reiser4 rss rtc samba sasl screen sdl session silc slang smartcard smime smtp sndfile snmp sockets spell spl ssl stream subversion svg svgz symlink sysfs tcpd tetex theora threads tiff timidity truetype truetype-fonts type1-fonts udev unicode usb utempter uudeview v4l v4l2 vdr videos vim vorbis wxwindows x264 xanim xcomposite xml xmlreader xmlrpc xorg xosd xpm xscreensaver xsl xv xvid zip zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="cs en_GB en" LIRC_DEVICES="devinput" USERLAND="GNU" VIDEO_CARDS="nv nvidia v4l vesa"
Comment 4 James Ausmus 2007-08-29 18:38:47 UTC
Re-emerge openal-0.0.8-r1 - a patch was added (without an ebuild rev-bump) that fixes this issue - see bug #166723.

Comment 5 Chris Gianelloni (RETIRED) gentoo-dev 2007-08-29 19:01:26 UTC
Actually, I just forced the bump, so it'll rebuild on his next sync/update anyway.
Comment 6 Chris Gianelloni (RETIRED) gentoo-dev 2007-08-29 19:01:41 UTC
This should be fixed now, per my last comment.