Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 165009 - pine-maildir-4.56.ebuild fails on unmerge
Summary: pine-maildir-4.56.ebuild fails on unmerge
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2007-02-02 18:00 UTC by odontocete
Modified: 2007-02-02 23:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description odontocete 2007-02-02 18:00:01 UTC
When I issue `emerge -C mail-client/pine-maildir`, I see the following:

    selected: 4.56
   protected: none
     omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging mail-client/pine-maildir-4.56...
No package files given... Grabbing a set.
/var/db/pkg/mail-client/pine-maildir-4.56/pine-maildir-4.56.ebuild: line 91: syntax error near unexpected token `('
/var/db/pkg/mail-client/pine-maildir-4.56/pine-maildir-4.56.ebuild: line 91: `                  -e "s:\$(SSLDIR)/certs:/etc/ssl/certs:" \'

!!! ERROR: mail-client/pine-maildir-4.56 failed.
Call stack:, line 1454:   Called die

!!! error sourcing ebuild
!!! If you need support, post the topmost build error, and the call stack if relevant.

!!! FAILED prerm: 1

Reproducible: Always

Steps to Reproduce:
1. emerge -C mail-client/pine-maildir

Expected Results:  
A clean unmerge.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-02-02 18:05:32 UTC
Nothing we could do w/ your locally corrupted ebuild. Edit /var/db/pkg/mail-client/pine-maildir-4.56/pine-maildir-4.56.ebuild and fix the syntax error there.
Comment 2 odontocete 2007-02-02 18:56:25 UTC
Not sure how you determined this file has been corrupted, as it has not been touched on this machine. When I tried to fix the obvious errors it ran into other issues. I have tried deleting the ebuild file, but an `emerge --sync` doesn't seem to bring it back.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-02-02 18:59:23 UTC
Uh, emerge --sync won't bring ebuilds back into your VDB. You can grab one here...
Comment 4 odontocete 2007-02-02 22:22:58 UTC
Yes, and the version in CVS is byte-for-byte the same file I had before. And it fails, just like before.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-02-02 23:11:05 UTC
We won't fix ebuilds removed from the tree, period. Replace the thing with a dummy ebuild if you still can't uninstall it.