Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 16472 - nethack-3.4.1.ebuild
Summary: nethack-3.4.1.ebuild
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: Gentoo Games
Depends on:
Reported: 2003-02-27 09:34 UTC by Ingo -LaSombra- Hoffmann
Modified: 2003-05-09 16:56 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Don't forget to ebuild nethack-3.4.1.ebuild digest ;-) (nethack-3.4.1.ebuild,6.59 KB, text/plain)
2003-02-27 09:37 UTC, Ingo -LaSombra- Hoffmann

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo -LaSombra- Hoffmann 2003-02-27 09:34:27 UTC
Here is a quick ebuild for nethack 3.4.1, have fun :-) 

Reproducible: Always
Steps to Reproduce:
Comment 1 Ingo -LaSombra- Hoffmann 2003-02-27 09:37:41 UTC
Created attachment 8777 [details]
Don't forget to ebuild nethack-3.4.1.ebuild digest ;-)
Comment 2 Johann Scheepers 2003-03-03 02:36:06 UTC
I still get's the new one.

gcc -march=athlon-tbird -O3 -pipe -fomit-frame-pointer -I../include -c
gcc -march=athlon-tbird -O3 -pipe -fomit-frame-pointer -I../include -c
../sys/unix/unixres.c: In function `real_getresuid':
../sys/unix/unixres.c:35: `RTLD_NEXT' undeclared (first use in this
../sys/unix/unixres.c:35: (Each undeclared identifier is reported only
../sys/unix/unixres.c:35: for each function it appears in.)
../sys/unix/unixres.c: In function `real_getresgid':
../sys/unix/unixres.c:47: `RTLD_NEXT' undeclared (first use in this
make: *** [unixres.o] Error 1

!!! ERROR: app-games/nethack-3.4.1 failed.
!!! Function src_compile, Line 142, Exitcode 2
!!! (no error message)

note: iv noticed nethack only bombs out if 'gnome' is included in the USE flags.
Comment 3 Ingo -LaSombra- Hoffmann 2003-03-03 16:40:03 UTC
Strange... I didn't got any errors.
Maybe because I don't emerge it with gnome nor qt.
Comment 4 B. K. Oxley (binkley) 2003-03-03 20:59:00 UTC
To get the build to compile, I need to add _GNU_SOURCE to CFLAGS so that RTLD_NEXT gets 
defined (see <dlfcn.h>).  Of course, it doesn't link because there are too many tile.o's linked in.  Oops. 
Comment 5 Ulrich Plate (RETIRED) gentoo-dev 2003-03-03 22:08:59 UTC
The build compiles well with USE="-gnome". I had to copy
/usr/portage/app-games/nethack/files/dot.nethackrc to 
because I built from portage_overlay. The Qt version 
works now, any chance to get the Gnome interface to 
compile, too?
Comment 6 Eric Hustvedt 2003-03-06 20:26:36 UTC
Bug #16827 has a patch to fix the issues with gnome compilation.
Comment 7 Martin Holzer (RETIRED) gentoo-dev 2003-04-15 12:15:18 UTC
in cvs now
Comment 8 Martin Holzer (RETIRED) gentoo-dev 2003-05-09 16:56:22 UTC