SABnzbd-0.2.5 requires cherrypy-2.2.1, anything higher/lower fails.
SABnzbd-0.2.5 ebuild @ http://bugs.gentoo.org/show_bug.cgi?id=132590
Steps to Reproduce:
Created attachment 108367 [details]
Ebuild for cherrypy-2.2.1, based on the cherrypy-2.1.1 ebuild.
Created attachment 108369 [details, diff]
files/cherrypy-2.2.1-test-gentoo.patch - patch for cherrypy-2.2.1
patch for cherrypy-2.2.1, based on cherrypy-2.1.1-test-gentoo.patch.
That would be a no; fix the other package. Sorry.
(In reply to comment #3)
> That would be a no; fix the other package. Sorry.
why, might I ask?
Cherrypy-2.1.1 is marked stable upstream, and it seem to be backwards compatible with 2.1.1.
(In reply to comment #4)
> why, might I ask?
Because if you tell us that 'anything higher/lower fails' (see comment #1) then the application needs to be fixed to work w/ cherrypy-3.0 as opposed to sticking =dev-python/cherrypy-2.2.1 into DEPEND, causing downgrade on people that are already using 3.0.0 or breaking their depgraph altogether if there's something that requires 3.0 to work and they have it installed.