Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 164232 - ebuild for cherrypy-2.2.1 (as required for SABnzbd-0.2.5)
Summary: ebuild for cherrypy-2.2.1 (as required for SABnzbd-0.2.5)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2007-01-28 13:04 UTC by Pandor
Modified: 2007-02-24 09:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

cherrypy-2.2.1.ebuild (cherrypy-2.2.1.ebuild,814 bytes, text/plain)
2007-01-28 13:05 UTC, Pandor
files/cherrypy-2.2.1-test-gentoo.patch - patch for cherrypy-2.2.1 (cherrypy-2.2.1-test-gentoo.patch,260 bytes, patch)
2007-01-28 13:06 UTC, Pandor
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pandor 2007-01-28 13:04:27 UTC
SABnzbd-0.2.5 requires cherrypy-2.2.1, anything higher/lower fails.
SABnzbd-0.2.5 ebuild @

Reproducible: Always

Steps to Reproduce:
Comment 1 Pandor 2007-01-28 13:05:23 UTC
Created attachment 108367 [details]

Ebuild for cherrypy-2.2.1, based on the cherrypy-2.1.1 ebuild.
Comment 2 Pandor 2007-01-28 13:06:40 UTC
Created attachment 108369 [details, diff]
files/cherrypy-2.2.1-test-gentoo.patch - patch for cherrypy-2.2.1

patch for cherrypy-2.2.1, based on cherrypy-2.1.1-test-gentoo.patch.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-01-28 13:07:36 UTC
That would be a no; fix the other package. Sorry.
Comment 4 Pandor 2007-02-24 09:13:35 UTC
(In reply to comment #3)
> That would be a no; fix the other package. Sorry.
why, might I ask?
Cherrypy-2.1.1 is marked stable upstream, and it seem to be backwards compatible with 2.1.1.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-02-24 09:23:31 UTC
(In reply to comment #4)
> why, might I ask?

Because if you tell us that 'anything higher/lower fails' (see comment #1) then the application needs to be fixed to work w/ cherrypy-3.0 as opposed to sticking =dev-python/cherrypy-2.2.1 into DEPEND, causing downgrade on people that are already using 3.0.0 or breaking their depgraph altogether if there's something that requires 3.0 to work and they have it installed.