Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 163462 - app-emulation/wine-0.9.29 configure can't find dlopen() int in /usr/lib32 w/ -m32
Summary: app-emulation/wine-0.9.29 configure can't find dlopen() int in /usr/...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Wine Maintainers
Depends on:
Reported: 2007-01-23 17:42 UTC by Erik van 't Wout
Modified: 2007-01-24 14:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Erik van 't Wout 2007-01-23 17:42:56 UTC
Something really odd:

When emerging wine (0.9.29) configure can't detect dlopen(), tried to do things myself, and without -m32 everything works fine, but with -m32 gcc complaints it can't find __dlopen.

Checked some symbolic links:

/usr/lib32/ -> /lib32/
/lib32/ ->  /lib32/

But, after this:

rm /usr/lib32/
cp /lib32/ /usr/lib32/

Everything works !! However thought I better filed it here.

Reproducible: Didn't try
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-01-23 20:53:10 UTC
So don't stick stuff like -m32 into your C[XX]FLAGS... :P
Comment 2 Erik van 't Wout 2007-01-24 11:34:13 UTC
May I remind you that -m32 is put into CFLAGS by default (= by configure) when emerging wine on an AMD64?
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-01-24 11:36:10 UTC
May I remind that you are supposed to post emerge --info output and some errors when filing bugs?
Comment 4 Erik van 't Wout 2007-01-24 14:13:37 UTC
First of all: I'm terribly sorry if I insulted anyone somehow.

Second: Tried to reproduce, but it won't let me (creating the symbolic link again makes no difference).

The error I had can be reproduced by (re)moving /usr/lib32/ or something it links to.

I suspect it was an error in the filesystem, but anyway, just to be sure, here is emerge --info:

Portage 2.1.2-r2 (default-linux/amd64/2006.0, gcc-4.1.1, glibc-2.4-r4, 2.6.19-suspend2-r1 x86_64)
System uname: 2.6.19-suspend2-r1 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4000+
Gentoo Base System version 1.12.6
Timestamp of tree: Tue, 23 Jan 2007 13:30:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
CFLAGS="-march=k8 -O2 -pipe"
CONFIG_PROTECT="/etc /home/mythtv/ /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-march=k8 -O2 -pipe"
FEATURES="autoconfig distlocks metadata-transfer prelink sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X aac addbookmarks alias alsa amd64 apache2 arts asf automount autoreplace avahi bash-completion berkdb bitmap-fonts browserplugin bzip2 cdr clearcase cli connectionstatus contactnotes cracklib crypt css cups curl cvs dedicated dlloader dri dts dv dvd dvdr ecore eds emboss encode fbsplash ffmpeg flac foomaticdb gdbm geoip gif gimp gimpprint gphoto2 gpm groupwise gstreamer gtk gtk2 gtkhtml hal highlight history icecast iconv id3 ieee1394 imlib insecure-drivers ipv6 irc isdnlog jack java javascript jpeg kde kdeenablefinal kdehiddenvisibility kdgraphics libcaca lirc logrotate lzw lzw-tiff mms modplug mozcalendar mozilla mozsvg mp3 mpeg multiuser musepack mysql ncurses netboot nethack netmeeting nls nowlistening nptl nptlonly nsplugin nvidia ogg opengl pam pcre pdf perl php pic png pppd python qt qt3 qt4 quicktime rdesktop readline reflection samba sametime scanner sdl session sid slp smp sms sndfile speex spell spl ssl statistics svg tcl tcpd texteffect theora tiff tk toolbar translator truetype truetype-fonts type1-fonts usb userlocales vcd vdr vim-with-x vorbis webpresence winpopup wma wmf xcomposite xext xine xinerama xorg xpm xprint xv xvid xvmc yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="nl" USERLAND="GNU" VIDEO_CARDS="vesa nvidia"