Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 162692 - media-plugins/audacious-docklet fails
Summary: media-plugins/audacious-docklet fails
Status: RESOLVED DUPLICATE of bug 162853
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-18 18:46 UTC by Marcel Meckel
Modified: 2007-01-19 22:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,42.48 KB, text/plain)
2007-01-18 20:44 UTC, Marcel Meckel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Meckel 2007-01-18 18:46:59 UTC
media-plugins/audacious-docklet-0.1.1-r1 depends on dev-perl/XML-Parser.

ebuild needs to be updated.

Reproducible: Always
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-01-18 19:26:31 UTC
No, it doesn't; it depends on intltool. Reopen with `emerge -pv audacious-docklet` output and actual errors.
Comment 2 Marcel Meckel 2007-01-18 20:42:46 UTC
# emerge -pv media-plugins/audacious-docklet

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] media-plugins/audacious-docklet-0.1.1-r1  USE="nls" 0 kB



checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/audacious-docklet-0.1.1-r1/work/audacious-docklet-0.1.1/config.log

!!! ERROR: media-plugins/audacious-docklet-0.1.1-r1 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  audacious-docklet-0.1.1-r1.ebuild, line 29:   Called econf '--enable-nls'
  ebuild.sh, line 540:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant
Comment 3 Marcel Meckel 2007-01-18 20:44:02 UTC
Created attachment 107389 [details]
config.log
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-01-19 07:37:56 UTC
Run perl-cleaner...

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 5 Marcel Meckel 2007-01-19 22:17:27 UTC
as you may have noticed - i don't have XML-Parser installed on this system. so there is no sense in running perl-cleaner.

somewhere is a dependency missing.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-01-19 22:22:52 UTC
(In reply to comment #5)
> as you may have noticed - i don't have XML-Parser installed on this system. so
> there is no sense in running perl-cleaner.

You know, we request emerge --info output for a reason; kindly post it next time.
Comment 7 Marcel Meckel 2007-01-19 22:29:49 UTC
sorry, here it is.

in the meantime o opened a new bug since i think it's a bug in portage: #162853


# emerge --info
Portage 2.1.1-r2 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r4, 2.6.17-gentoo-r8-my i686)
=================================================================
System uname: 2.6.17-gentoo-r8-my i686 AMD Athlon(tm) XP 1700+
Gentoo Base System version 1.12.6
Last Sync: Tue, 16 Jan 2007 15:50:01 +0000
ccache version 2.4 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo"
LINGUAS="de"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowext X a52 aac alsa alsa_cards_ali5451 alsa_cards_als4000 alsa_cards_atiixp alsa_cards_atiixp-modem alsa_cards_bt87x alsa_cards_ca0106 alsa_cards_cmipci alsa_cards_emu10k1x alsa_cards_ens1370 alsa_cards_ens1371 alsa_cards_es1938 alsa_cards_es1968 alsa_cards_fm801 alsa_cards_hda-intel alsa_cards_intel8x0 alsa_cards_intel8x0m alsa_cards_maestro3 alsa_cards_trident alsa_cards_usb-audio alsa_cards_via82xx alsa_cards_via82xx-modem alsa_cards_ymfpci alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol bitmap-fonts bzip2 cdr cli cracklib crypt cups dbus divx dlloader dts dv dvb dvd dvdr dvdread elibc_glibc emboss encode ffmpeg firefox gif gmedia gpm gtk iconv imap imlib input_devices_evdev input_devices_keyboard input_devices_mouse isdnlog jpeg kde kernel_linux libg++ linguas_de mad mbox mikmod mmx mmxext mp3 mpeg ncurses nls nptl nptlonly nsplugin ogg opengl oss pam pcre pdf png ppds pppd qt3 qt4 quicktime readline real realmedia reflection rtc sdl session spl sse ssl tcpd tiff truetype truetype-fonts type1-fonts udev usb userland_GNU video_cards_nv video_cards_nvidia vorbis win32codecs wmp xorg xprint xv xvid xvmc zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2007-01-19 22:45:24 UTC

*** This bug has been marked as a duplicate of bug 162853 ***