Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 162592 - Inverted mouse directions in games-fps/warsow
Summary: Inverted mouse directions in games-fps/warsow
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Games
Depends on:
Reported: 2007-01-17 21:38 UTC by adriancz
Modified: 2007-02-02 00:26 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

games-fps/warsow-0.21-r1.ebuild (warsow-0.21-r1.ebuild,4.13 KB, text/plain)
2007-01-21 09:16 UTC, Keith Gable
files/inverted-mouse-bug-162592.patch (inverted-mouse-bug-162592.patch,420 bytes, patch)
2007-01-21 09:17 UTC, Keith Gable
Details | Diff
games-fps/warsow-0.21-r2.ebuild (warsow-0.21-r2.ebuild,4.02 KB, text/plain)
2007-01-27 01:21 UTC, Keith Gable
games-fps/warsow-0.21-r3.ebuild (warsow-0.21-r3.ebuild,4.02 KB, text/plain)
2007-01-29 01:31 UTC, Keith Gable

Note You need to log in before you can comment on or make changes to this bug.
Description adriancz 2007-01-17 21:38:29 UTC
Some people have problem with mouse in warsow. The solution is simple,

Reproducible: Sometimes

Steps to Reproduce:
1. install warsow
2. play the game
Comment 1 Keith Gable 2007-01-21 08:46:19 UTC
It happens to me too, but it's not really so much that the directions are inverted as that the mouse is not correctly responsive, and inverts randomly. And only in the menus (it's fine in game).

I'm going to see if this patch fixes the problem over here and come back.

Reporter, can you change the summary to say "Inverted mouse directions in games-fps/warsow"? Thanks!
Comment 2 Keith Gable 2007-01-21 09:16:16 UTC
Created attachment 107638 [details]

Yeah, the patch worked. Here's my updated ebuild.

The C files have Windows line endings, so I've placed a dependency on dos2unix since patch doesn't look like it's smart enough to detect the line ending discrepancy, and I don't feel like making my patch in Windows format just to appease the Windows Gods. (however, if this is the way I should have done it, so be it...)

Also, I had to append -U "Screw You Guys" on wget when I downloaded that patch from FreeBSD. They don't allow wget...

Patch file is pending (had to modify it).
Comment 3 Keith Gable 2007-01-21 09:17:04 UTC
Created attachment 107639 [details, diff]

And here's the patch.
Comment 4 Jozsef Daniel 2007-01-25 23:48:38 UTC
I got the bug when I recompiled warsow after an update (to 7.2).
The patch works beautiful. Nice job.
Comment 5 Keith Gable 2007-01-26 02:02:27 UTC

This affects x86 as well. Mind changing "Hardware" to "all", being as it affects all platforms Warsow compiles on?
Comment 6 Paul Bredbury 2007-01-27 01:08:17 UTC
> dependency on dos2unix

Not needed - use edos2unix instead of dos2unix, which is a command in the eutils eclass.

Wrap the variables in quotes, so the scripts won't go wrong if there's e.g. a space involved.
Comment 7 Keith Gable 2007-01-27 01:21:16 UTC
Created attachment 108255 [details]

Ah! I didn't know that.

I've fixed it.
Comment 8 Keith Gable 2007-01-29 01:31:58 UTC
Created attachment 108444 [details]

I messed up and forgot to test the previous ebuild. I forgot to remove -q from dos2unix so when I made it edos2unix it tried passing -q to sed.

This one is tested and works though.
Comment 9 Tristan Heaven (RETIRED) gentoo-dev 2007-02-02 00:26:53 UTC