Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 160381 - net-dialup/linux-atm-2.4.1-r1 compile fails w/ linux-headers-2.6.17-r2
Summary: net-dialup/linux-atm-2.4.1-r1 compile fails w/ linux-headers-2.6.17-r2
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High blocker (vote)
Assignee: Gentoo Toolchain Maintainers
: 160419 168657 171028 188982 (view as bug list)
Depends on:
Blocks: 156814
  Show dependency tree
Reported: 2007-01-06 09:15 UTC by Dariusz Parciak
Modified: 2007-11-17 11:41 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---

A simple patch which seems to work to me (linux-atm-2.4.1-headers-2.6.17-patch.diff,523 bytes, patch)
2007-04-07 22:53 UTC, Giampaolo Tomassoni
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dariusz Parciak 2007-01-06 09:15:04 UTC
It is my first bugreport so please, be batient for me. Sorry for my English :-(
When I yesterday tried to recompile whole system (emerge -e world) linux-atm did not compiled. 

Hehe is the reason.

gcc -DHAVE_CONFIG_H -I. -I. -I../..     -I../../src/include -O2 -march=i686 -pipe -Wall -Wshadow -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -c io.c
In file included from /usr/include/linux/netdevice.h:28,
                 from /usr/include/linux/if_arp.h:26,
                 from io.c:24:
/usr/include/linux/if.h:118: error: redefinition of 'struct ifmap'
/usr/include/linux/if.h:154: error: redefinition of 'struct ifreq'
/usr/include/linux/if.h:204: error: redefinition of 'struct ifconf'
io.c: In function 'accept_new':
io.c:281: warning: pointer targets in passing argument 3 of 'accept' differ in signedness
io.c:296: warning: pointer targets in passing argument 5 of 'getsockopt' differ in signedness
io.c: In function 'get_local':
io.c:618: warning: pointer targets in passing argument 3 of 'getsockname' differ in signedness
make[3]: *** [io.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/linux-atm-2.4.1-r1/work/linux-atm-2.4.1/src/arpd'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/linux-atm-2.4.1-r1/work/linux-atm-2.4.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/linux-atm-2.4.1-r1/work/linux-atm-2.4.1'
make: *** [all-recursive-am] Error 2

!!! ERROR: net-dialup/linux-atm-2.4.1-r1 failed.
Call stack:, line 1546:   Called dyn_compile, line 937:   Called src_compile, line 608:   Called die

If you want I can submit full log of compilation

Reproducible: Always

Steps to Reproduce:
1. emerge -v linux-atm

emerge --info
Portage 2.1.1-r2 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.3.6-r5, 2.6.18-gentoo-r6 i686)
System uname: 2.6.18-gentoo-r6 i686 AMD Duron(tm) Processor
Gentoo Base System version 1.12.6
Last Sync: Fri, 05 Jan 2007 17:00:01 +0000
ccache version 2.4 [disabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: [Not Present]
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="x86 alsa_cards_ali5451 alsa_cards_als4000 alsa_cards_atiixp alsa_cards_atiixp-modem alsa_cards_bt87x alsa_cards_ca0106 alsa_cards_cmipci alsa_cards_emu10k1x alsa_cards_ens1370 alsa_cards_ens1371 alsa_cards_es1938 alsa_cards_es1968 alsa_cards_fm801 alsa_cards_hda-intel alsa_cards_intel8x0 alsa_cards_intel8x0m alsa_cards_maestro3 alsa_cards_trident alsa_cards_usb-audio alsa_cards_via82xx alsa_cards_via82xx-modem alsa_cards_ymfpci alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol atm berkdb bitmap-fonts cli cracklib crypt cups dlloader dri elibc_glibc fortran gdbm iconv input_devices_evdev input_devices_keyboard input_devices_mouse ipv6 isdnlog kernel_linux libg++ ncurses nls nptl nptlonly pam pcre perl php ppds pppd python readline reflection session spl ssl tcpd truetype-fonts type1-fonts udev unicode userland_GNU video_cards_apm video_cards_ark video_cards_ati video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_fbdev video_cards_glint video_cards_i128 video_cards_i740 video_cards_i810 video_cards_imstt video_cards_mga video_cards_neomagic video_cards_nsc video_cards_nv video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo xorg zlib"
Comment 1 SpanKY gentoo-dev 2007-01-06 09:26:26 UTC
ive fixed this in 2.6.19 already
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-01-06 11:23:37 UTC
*** Bug 160419 has been marked as a duplicate of this bug. ***
Comment 3 John Lewis 2007-01-07 19:09:26 UTC
FYI this is also failing with exactly the same error on x86_64 native.
Comment 4 John Lewis 2007-01-07 21:05:08 UTC
So as per Spanky's message you can work around the error by upgrading to unstable linux-headers.
Comment 5 Alan Hourihane 2007-01-08 18:13:07 UTC
I'd rather not upgrade to unstable. Is there any fix that can be backported to stable ??
Comment 6 John Lewis 2007-01-08 20:54:29 UTC
Well I'll tell you what I did and the devs can comment on the wrongness or impending doom if any.

Simply upgrade to unstable linux-headers, install linux-atm and then go back to stable linux-headers, worked for me anyway.
Comment 7 SpanKY gentoo-dev 2007-01-08 21:48:39 UTC
i havent looked at the src code, but that should be no problem

the 2.6.19 headers actually arent too bad ... i imagine it shouldnt be long before they hit stable
Comment 8 John Lewis 2007-01-13 14:56:43 UTC
I really think this should be a MAJOR bug as it could stop some noob from being able to finish their Gentoo install i.e. internet access and put people off Gentoo altogether.
Comment 9 Alan Hourihane 2007-01-13 15:10:46 UTC
I have to agree. I don't know what the problem is with backporting the fix.
Comment 10 John Lewis 2007-01-13 18:21:08 UTC
Yes well the really weird thing is that this only appeared when I "emerge --sync"ed on the 5th of January. Prior to that linux-atm compiled perfectly with the current stable headers i.e. "2.6.17.whatever" so whatever it was that screwed the compilation up came down with "emerge --sync". Not knowing that much about portage I would say it's either the linux-atm "ebuild" or the "2006.1" profile that has caused the problem.
Comment 11 Andreas Fink 2007-01-17 12:25:27 UTC
how to upgrade to unstable linux-headers and to downgrade again?

have i to rebuild kernel?
Comment 12 John Lewis 2007-01-17 12:48:28 UTC
Add "sys-kernel/linux-headers ~x86" to "/etc/portage/package.keywords"

Only put "x86" in there if you are using an Intel processor, alternatively you might be using an AMD chip with 64 bit support in which case you would put ~amd64 in there instead.

Then "emerge -u --oneshot linux-headers && emerge linux-atm"

This will upgrade linux-headers and install linux-atm.

Then remove "sys-kernel/linux-headers ~x86" from "/etc/portage/package.keywords".

and "emerge -u --oneshot linux-headers".

This will downgrade linux-headers back to stable but you will still have linux-atm installed.

You don't need to recompile or upgrade your kernel or gcc or anything like that.

I'm assuming this hasn't been fixed yet because linux-headers-2.6.19 should be stable any day now. Still it would've been nice for a dev to have said this or for an announcement on the forums or in newsletter.

Incidentally devs there is exactly the same problem with stable 64 bit linux-headers.
Comment 13 Chris Gianelloni (RETIRED) gentoo-dev 2007-02-07 23:56:30 UTC
There's currently no stabilization bug for newer headers, so we either need to backport this to the current stable, or mark a newer set of headers stable before we make the 2007.0 snapshot.
Comment 14 Thilo Bangert (RETIRED) (RETIRED) gentoo-dev 2007-02-11 22:34:13 UTC
jupp - been bit by this one as well.
i guess no new linux-headers in 2007.0?!
Comment 15 Chris Gianelloni (RETIRED) gentoo-dev 2007-02-14 19:44:49 UTC
This is now blocking the snapshot.  We can either get this fixed, or we can drop support for any ATM-based devices (which includes several DSL modems) from the upcoming release.
Comment 16 Thilo Bangert (RETIRED) (RETIRED) gentoo-dev 2007-02-19 22:09:11 UTC
i don't know the process involved - but if its fixed in linux-headers-2.6.19 then lets get them to stable...
Comment 17 Alan Hourihane 2007-02-25 21:23:19 UTC
Is there any progress on backporting the fix ??
Comment 18 Jakub Moc (RETIRED) gentoo-dev 2007-02-27 23:52:58 UTC
*** Bug 168657 has been marked as a duplicate of this bug. ***
Comment 19 Alan Hourihane 2007-03-08 23:18:56 UTC
Hello - any news ???
Comment 20 Jakub Moc (RETIRED) gentoo-dev 2007-03-15 14:10:30 UTC
*** Bug 171028 has been marked as a duplicate of this bug. ***
Comment 21 Warwick Chapman 2007-03-22 16:05:20 UTC
What is holding the new headers back from being marked stable?!  Surely this is a show stopper?  Anyone merging a new stable version of Gentoo will be stumped at this point...
Comment 22 Giampaolo Tomassoni 2007-04-07 22:53:34 UTC
Created attachment 115688 [details, diff]
A simple patch which seems to work to me

It seems that linux-headers-2.6.19 still has some troubles to be safely put stable.

I'm proposing this simple patch which should fix the problem against linux-headers-2.6.17-r2.

Well, maybe this is not the right way to face the problem. But, you know, I need my ADSL lines...
Comment 23 Alin Năstac (RETIRED) gentoo-dev 2007-04-13 22:36:04 UTC
Fixed in cvs by replacing net/if.h with linux/if.h.

However, the package compiles with dozens of QA warnings. One of these days I will have to make a new revision with all those QA issues fixed.
Comment 24 Alin Năstac (RETIRED) gentoo-dev 2007-04-14 16:19:22 UTC
FYI: I've committed linux-atm-2.4.1-r2, which fixes all QA warnings of the previous revision.
Comment 25 Jakub Moc (RETIRED) gentoo-dev 2007-08-15 12:27:25 UTC
*** Bug 188982 has been marked as a duplicate of this bug. ***
Comment 26 Aniruddha 2007-11-17 00:11:45 UTC
What is the reason this bug is fixed? I still can't emerge net-misc/networkmanager-0.6.5_p20070823 without unstable linux-headers.
Comment 27 Alin Năstac (RETIRED) gentoo-dev 2007-11-17 11:41:33 UTC
(In reply to comment #26)
How is this related to linux-atm?