Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 160349 - app-pda/jpilot-0.99.8-r1 configure fails w/ USE="-gtk"
Summary: app-pda/jpilot-0.99.8-r1 configure fails w/ USE="-gtk"
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Gentoo PDA Herd
URL:
Whiteboard:
Keywords:
: 151350 196801 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-01-05 17:34 UTC by R. David Murray
Modified: 2008-02-28 14:16 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description R. David Murray 2007-01-05 17:34:04 UTC
On a ~x86 system that is current, emerging jpilot with USE="-gtk" results in the following error:

checking for GTK - version >= 1.2.0... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
configure: error: *** GTK >= 1.2.0 not found ***

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/app-pda/jpilot-0.99.8-r1/work/jpilot-0.99.8/config.log

!!! ERROR: app-pda/jpilot-0.99.8-r1 failed.
Call stack:
  ebuild.sh, line 1593:   Called dyn_compile
  ebuild.sh, line 951:   Called src_compile
  jpilot-0.99.8-r1.ebuild, line 36:   Called econf '--disable-gtk2' '--disable-nls'
  ebuild.sh, line 557:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-01-06 08:59:41 UTC
*** Bug 151350 has been marked as a duplicate of this bug. ***
Comment 2 Wulf Krueger (RETIRED) gentoo-dev 2007-09-17 05:43:16 UTC
Fixed in CVS in 0.99.9.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-10-23 21:01:33 UTC
*** Bug 196801 has been marked as a duplicate of this bug. ***
Comment 4 Jan Hrabe 2008-02-10 19:35:41 UTC
Could you please give some estimate when the fixed version is going to become
stable?
Comment 5 Wulf Krueger (RETIRED) gentoo-dev 2008-02-10 19:46:18 UTC
cf. bug 209068.
Comment 6 Aniruddha 2008-02-28 14:16:07 UTC
(In reply to comment #4)
> Could you please give some estimate when the fixed version is going to become
> stable?
> 

Just do a "echo "app-pda/jpilot ~x86" >> /etc/portage/package.keywords" and emerge jpilot.