Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 160317 - sys-apps/man-1.6e: makewhatis crontab has wrong path for nice
Summary: sys-apps/man-1.6e: makewhatis crontab has wrong path for nice
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: coreutils-6.7-r1 161316 172316 172849 172856 173933 177792 (view as bug list)
Depends on: 172761
Blocks:
  Show dependency tree
 
Reported: 2007-01-05 13:12 UTC by Paul Taylor
Modified: 2007-05-09 17:11 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Taylor 2007-01-05 13:12:49 UTC
Output from /etc/cron.weekly/makewhatis (received in email message):

/etc/cron.weekly/makewhatis: line 5: /bin/nice: No such file or directory
/etc/cron.weekly/makewhatis: line 5: exec: /bin/nice: cannot execute: No such file or directory

The correct path is /usr/bin/nice.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-01-05 14:18:13 UTC
Re-emerge man and try again...
Comment 2 Paul Taylor 2007-01-05 14:39:00 UTC
After resyncing and running "emerge man", /etc/cron.weekly/makewhatis has been removed:

# equery files man | fgrep cron
/etc/cron.daily
/etc/cron.daily/makewhatis

The cron.daily script also has the incorrect path to nice:

# fgrep nice /etc/cron.daily/makewhatis
exec /bin/nice /usr/sbin/makewhatis -u
Comment 3 SpanKY gentoo-dev 2007-01-05 17:34:29 UTC
fixed in 1.6e-r1, thanks for the report !
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-01-07 02:29:35 UTC
*** Bug 160609 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-01-10 13:45:29 UTC
*** Bug 161316 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-03-26 18:48:07 UTC
*** Bug 172316 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-03-26 18:49:18 UTC
We need >=1.6e-r1 stable...
Comment 8 SpanKY gentoo-dev 2007-03-26 23:21:38 UTC
... so file a stabilization bug
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2007-03-30 07:53:27 UTC
(In reply to comment #8)
> ... so file a stabilization bug

Guess why I did reopen this one... Sigh. :X
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2007-03-31 06:51:06 UTC
*** Bug 172849 has been marked as a duplicate of this bug. ***
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2007-03-31 09:03:50 UTC
*** Bug 172856 has been marked as a duplicate of this bug. ***
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2007-04-09 18:43:34 UTC
*** Bug 173933 has been marked as a duplicate of this bug. ***
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2007-05-09 17:11:58 UTC
*** Bug 177792 has been marked as a duplicate of this bug. ***