Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 158439 - Cannot halt the system with baselayout-1.12.7-r4
Summary: Cannot halt the system with baselayout-1.12.7-r4
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2006-12-18 02:28 UTC by Fab
Modified: 2006-12-19 03:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Fab 2006-12-18 02:28:42 UTC

With baselayout-1.12.7-r4, I can't halt the system : all services and processes are shutting down normally, but at the end :

[*] Remounting remaining filesystems readonly       [ok]
INIT: no more processes left in this runlevel

But the system doesn't stop.

Reverting to baselayout-1.12.6 solve the problem.

 $ emerge --info
Portage 2.1.2_rc3-r6 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r3 i686)
System uname: 2.6.18-gentoo-r3 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.12.6
Last Sync: Sun, 17 Dec 2006 07:50:01 +0000
ccache version 2.4 [disabled]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
CFLAGS="-O2 -march=pentium4 -pipe -ggdb"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -pipe -ggdb"
FEATURES="autoconfig buildpkg buildsyspkg candy distlocks metadata-transfer parallel-fetch sandbox sfperms splitdebug strict userfetch userpriv usersandbox"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/bg-overlay"
USE="x86 X aac alsa apache2 apm audiofile berkdb bitmap-fonts bzip2 cairo cdr cli cracklib crypt cups curl dbus dlloader dri dts dvd dvdr dvdread elibc_glibc emboss encode exif fam ffmpeg firefox flac foomaticdb fortran gdbm gif gimpprint gnome gpm gstreamer gtk gtkhtml hal iconv imlib input_devices_evdev input_devices_keyboard input_devices_mouse isdnlog java jpeg kernel_linux ldap libg++ libnotify linguas_fr logrotate mad mikmod mmx mozsvg mp3 mpeg mysql ncurses nls nptl nptlonly nsplugin ogg openal opengl oss pam pcre perl png ppds pppd python qt3 quicktime readline reflection sdl session spell spl sse sse2 ssl tcltk tcpd tiff truetype truetype-fonts type1-fonts udev unicode usb userland_GNU userlocales video_cards_nv video_cards_nvidia vorbis win32codecs xine xml xorg xv xvid zlib"
Comment 1 Roy Marples (RETIRED) gentoo-dev 2006-12-18 02:42:03 UTC
Have a long hard look at bug #156766
Do as much debugging as you can in /etc/init.d/ to find out what your error is so I can fix it.
Comment 2 Fab 2006-12-18 03:53:15 UTC
Ok, I will try to tweak this script to see what's going on, but I need time to do it. I know that /etc/init.d/shutdown is called at the end.

echo "going to load /etc/init.d/$1"
# Load the final script depending on how we are called
[[ -e /etc/init.d/"$1".sh ]] && source /etc/init.d/"$1".sh

Do you know if there's a way to relaunch the system without really rebooting ? Currently I'm using the magic sys keys to do it, but it take time to reboot just to do a test. Thanks.
Comment 3 Roy Marples (RETIRED) gentoo-dev 2006-12-18 04:10:41 UTC
Does /etc/init.d/ exist?

To save time you can use kexec
Comment 4 Fab 2006-12-18 04:38:08 UTC
(In reply to comment #3)
> Does /etc/init.d/ exist?

# ls /etc/init.d/ | grep shut

Strange... It does not, I don't know why. I will try to re-emerge sysvinit.

I found another problem during the "unmounting filesystems" step :
my partitions are unmounted in this order :

* Unmounting filesystems

The problem is the following : accordingly to my fstab, /opt is a bind to /usr/opt :
$ mount
/dev/hdd1 on /usr type ext3 (rw,noatime)
/usr/opt on /opt type none (rw,bind)

It means that /opt should be unmounted before /usr. Currently it doesn't, and the script is trying to force the unmount of /usr because it fails before.
Comment 5 Fab 2006-12-18 05:03:33 UTC
Re-emerging sys-apps/sysvinit-2.86-r6 solved the shutdown problem.
I don't know why the script has disappeared.

What do you think about the bind's unmount problem ? Do you think you will fix it ?
Anyway, thanks for you help.
Comment 6 Roy Marples (RETIRED) gentoo-dev 2006-12-19 03:32:40 UTC
Shouldn't be a problem really as the actual mount point will be cleanly unmounted later.

We can't actually test if it's a mountpoint or not as the kernel does not tell us this in /proc/mounts. Otherwise we would unmount the binds first.
Comment 7 Fab 2006-12-19 03:58:00 UTC
Yes. I made some tests : I tried to unmount binds before regulars mount points : it changed nothing for /usr : the script still failed on /usr and tries to force to umount it. Probably a process which is used at this moment. I close this bug. Thanks.